Welcome to Agilent Wireless Test Manager Help

Welcome to the
Agilent N4018C/N4019C Bluetooth®/Wireless LAN
Wireless Test Manager Help

Help Revision Date: December 11, 2006

This online help describes how to use the Agilent N4018C/19C Bluetooth/Wireless LAN Wireless Test Manager. The help is organized into the following sections:

  • Getting Help provides information on how to get the most from this online help.

  • Getting Started provides information on items such as minimum system requirements, supported hardware, and other introductory information on using the Wireless Test Manager.

  • How To... includes step-by-step procedures for performing the most common tasks with the Wireless Test Manager.

  • Graphical User Interface Reference describes the Wireless Test Manager's Graphical User Interface.

  • N4018C/19C Wireless Test Manager Reference describes the Bluetooth and Wireless LAN test plan steps, test parameters, and test limits (specifications).

  • Developer Information provides useful information if you are a developer and want to customize the user interface.

  • Troubleshooting provides contact information for Agilent service centers, and troubleshooting information relating to installation, setup or use.

Bluetooth is a registered trademark of Bluetooth SIG, Inc., U.S.A. and licensed to Agilent Technologies, Inc

© Agilent Technologies, Inc. 2006


Getting Help

This section provides details on how to use this online help and how to get additional information on the Internet.

For more information, choose a topic below:

  • Using the Wireless Test Manager's Online Help

  • Getting Updates for Wireless Test Manager Help


Using the Wireless Test Manager's Online Help

To open the Help from the Wireless Test Manager

Select the Help button [image] on the toolbar.

To find a topic in Help

Use one of the following methods:

  • Select the Contents tab in the left pane of the Help window to browse through topics by category.

  • Select the Index tab to see a list of index entries: either type the word you're looking for or scroll through the list.

  • Select the Search tab to search for words or phrases that may be contained in a Help topic.

To get context-sensitive Help in a screen

Use one of the following methods:

  • If you just want brief help on an item, hold the mouse over the item for a short time, and a pop-up window will display a short description of the item.

  • Select with your second button (right click for a right-handed mouse setup) on the item you want information about. Then pick View Help on that topic from the dialog box that appears.

  • If you want help on a test plan step, highlight the step you want, right-click the mouse and select to view the help.

To get context-sensitive Help in a dialog box

Select [image] at the top of a dialog box, and then Select the item you want information about.


Getting Updates for Wireless Test Manager Help

To get the most up-to-date version of the Wireless Test Manager Help

Visit the Agilent Technologies Wireless Test Manager Web site on the Internet at the following URL:

http://www.agilent.com/find/wtmanagers/


Getting Started

The topics in this section provide important introductory information if you are a new user.

For more information, choose a topic below:

  • Minimum System Requirements

  • Supported Hardware

  • Installing the Wireless Test Manager

  • Introduction to the Wireless Test Manager

  • Starting to Use the Wireless Test Manager

  • Understanding the Different Operating Modes

  • Glossary


Minimum System Requirements

This section specifies the minimum system requirements for the Agilent N4019C Wireless Test Manager.

To run the Wireless Test Manager and its online help, your system must meet the following requirements:

  • An IBM® (or compatible) PC with at least:

    • 600 MHz Pentium III Processor

    • Microsoft® Windows® XP Professional (SP2) or 2000 Professional (SP4)

    • 512 MB of RAM recommended, 256 MB RAM minimum

    • 200 MB of available hard disk space

    • 10x CD-ROM

    • USB Port
      (for hardware security key)

    • Video adapter settings: 800x600 or greater resolution; at least 256 colors
      Small font display settings should be used. Large font settings are not recommended.

  • Microsoft Visual Studio®.NET 2003 Professional (also compatible with Visual Studio® .NET 2005 Professional or Standard Edition)
    (required to use software development environment)

  • Microsoft Internet Explorer® version 5.0 or later
    (required to correctly run this help system)

  • An installed, configured, and tested Agilent Technologies or National Instruments™ IEEE 488.2 GPIB interface (one per test system).

  • The latest version of VISA (Virtual Instrument Software Architecture) from the manufacturer of your GPIB card.
    This must be installed and working correctly on your computer before you install this application. (The latest version of VISA can be downloaded from the manufacturer's web site, either http://www.agilent.com or http://www.ni.com.)

  • A USB 1.1 Port or later (for hardware security key)

  • Serial Ports for fixtures, device control and bar code reader

  • An Agilent N4010A Wireless Connectivity Test Set
    The test set options that are required depend on which functionality is needed, and are listed below

  • Bluetooth 1.x

N4010A Option 101

  • Bluetooth 2.0(EDR)

N4010A Option 107

  • Wireless LAN 2.4GHz

N4010A Option 102

  • Wireless LAN 2.4GHz & 5GHz

N4010A Option 103

IBM® is a registered trademark of IBM Corporation.
National Instruments™ is a registered trademark of National Instruments Corporation.
Microsoft® Windows® XP and 2000 are U.S. registered trademarks of Microsoft Corporation.


Supported Hardware

The Wireless Test Manager supports the following hardware:

Test Instruments

  • Agilent N4010A Wireless Connectivity Test Set. (See Minimum System Requirements for details of the test set features required for this Wireless Test Manager. )

PC Cards

  • Agilent Technologies GPIB

  • National Instruments GPIB

  • Advantech PCI-1750 32-channel Isolated Digital I/O Card

  • Comtrol RocketPort 95870-3 and 99096-3 multi-port serial adapters

Peripherals

  • Symbol LS-1220-1200A fixed bar code reader

  • Symbol LS-3603MX-1200A, P300FZY, and LS4004I-I100 hand-held bar code readers

  • The majority of later model Hewlett-Packard printers

  • Epson TM-U200D and TM U220D strip printers

Fixtures

  • TestCom TC-5941, TC-5942B (formerly sold as Agilent Technologies N4049A), and TC-5952B Wireless Test Fixtures

Adapters

  • Agilent 82357A USB/GPIB interface

  • National Instruments™ GPIB-USB-A external controller


Installing the Wireless Test Manager

This topic provides guidelines for installing the Wireless Test Manager from your CD-ROM.

Click on a link below to go to the section you want.

  • Installation overview

  • To Install the Wireless Test Manager using Autorun

  • To Install the Wireless Test Manager manually

  • To start the Wireless Test Manager

  • To start the Wireless Test Manager Development Environment

  • To deploy the Wireless Test Manager on a production line

Installation overview

The Install Wizard guides you through the process of installing the Wireless Test Manager. Three installation options are available which each have different system requirements. These installation options are shown in the following table.

Installation Type

Description/Requirements

Demonstration-mode-only

This installs only a demonstration version of the Wireless Test Manager. Your system does not require any of the following:

  • VISA (Virtual Instrument Software Architecture)

  • Connections between your computer and supported instruments

  • A hardware security key

This mode is intended for you to try out the Wireless Test Manager before installing the Runtime-only or Runtime and Development versions.

Runtime-only

This installs the Wireless Test Manager's Operator and Administrator graphical user interface (GUI).

Your system must have VISA (from the manufacturer of your GPIB card) installed and working correctly prior to this installation. The Install Wizard checks that VISA is correctly installed before completing the installation.

In addition, you need to connect your hardware security key to your computer's USB or parallel port to use this installation.

Runtime and Development Environment

This installs the Wireless Test Manager software development environment, in addition to the Operator and Administrator graphical user interface (GUI).

Prior to this installation, your system must have Microsoft® Visual Studio®.NET 2003 , and VISA (from the manufacturer of your GPIB card) installed and working correctly. The Install Wizard checks that Visual Basic® and VISA are installed before completing the installation.

In addition, you need to connect your hardware security key to your computer's USB or parallel port to use this installation.

Refer to Minimum System Requirements for more details.

To install the Wireless Test Manager using Autorun

  1. Close any Microsoft® Windows® applications that are running.

  2. Insert the CD-ROM into the CD-ROM drive. The SETUP program should start automatically. If the SETUP program does not start, click the Start button on the taskbar (Windows® 2000/XP), then click Run. The Run dialog box is displayed. Type d:\setup.exe (type the location of your CD-ROM drive where the "d" is) and click the OK button. The Install Wizard then installs the software.

If your computer is not set up to autorun programs installed in the CD-ROM drive, you must install the Wireless Test manager using the following procedure.

To install the Wireless Test Manager manually

  1. Close any Windows applications that are running.

  2. Insert the Wireless Test Manager installation CD-ROM.

  3. From the Windows Desktop, select Start.

  4. Select Run.

  5. Select Browse, and select your CD-ROM drive (such as D:) to display the available files on the Wireless Test Manager CD-ROM.

  6. Select the Setup.exe file, and click Open.

  7. Select OK to install the Wireless Test Manager.

  8. When the installation is finished, one or more icons will be added to your desktop, depending on the installation type you selected.

To start the Wireless Test Manager

Double-click the 'N401xC BT WLAN' icon on the Windows desktop to start the Wireless Test Manager's Operator and Administrator graphical user interface (GUI).

To start the Wireless Test Manager Development Environment

Double-click the 'Project for N401xC BT WLAN' icon on the Windows desktop to start the Wireless Test Manager's development environment.

To deploy the Wireless Test Manager on a production line

Before you deploy a newly developed Run-Time application on multiple computers for manufacturing use, the ExecSetting.xml file needs to be modified to reflect the <Target Directory> for the installation.

Use the following procedure:

  1. Within the ExecSetting.xml file, the following items need to be edited to reflect the <Target Directory> for the installation:

  • ExecCommon\AppDataPath

  2. After the ExecSetting.xml has been modified, you need to install the Runtime-only version of the Wireless Test Manager provided on your installation CD-ROM.

  3. After this installation is complete, the following files need to be placed onto the target computer's hard disk in their respective directories:

  • <Target Directory>\N401xC\RunTime\N401xC_BT_WLAN_SAM_Net.exe

  • <Target Directory>\N401xC\RunTime\Agilent.Components.DeviceControl.BT.Bcsp.dll

  • <Target Directory>\N401xC\RunTime\Agilent.Components.DeviceControl.BT.Uart.dll

  • <Target Directory>\N401xC\TestData\BT_WLAN_English.mdb

  • <Target Directory>\N401xC\TestData\ExecSetting.xml

  • <Target Directory>\N401xC\TestLocalization\English.lng


Introduction to the Wireless Test Manager

The Wireless Test Manager is designed for testing wireless devices. It is a powerful, flexible, all-in-one test system software application that provides automated test development and support. The Wireless Test Manager has an easy-to-use Graphical User Interface (GUI) that allows test operators to quickly run test plans for testing wireless devices. If required, administrators can easily change the configuration of the GUI to hide or show controls as required.

The Wireless Test Manager is supplied with default Operator and Administrator user interfaces. If these do not meet your specific testing needs, development interfaces are provided which integrate with Microsoft® Visual Studio®.NET 2003. These development interfaces allow the developer to integrate the Wireless Test Manager and Methods of Measurement (MoM) instrument drivers within their own Microsoft® Visual Basic® project file (.vbproj).

In addition, the Add Wireless Test Wizard and Add Instrument Control Wizard automate many programming tasks, reducing the amount of manual coding required. Using these development interfaces, developers can create a user-designed custom interface that contains very specific content based on their own particular test requirements.


Implementing Wireless LAN DUT Drivers

To use N4018C/N4019C Wireless Test Manager to perform measurements on Wireless LAN devices, some development work may be required :

  • Using AutoRange with Wireless LAN DUTs

  • Adding WLAN DUT Driver to Development Code

  • Creating .NET project

  • Adding reference to .NET project

  • Creating .vb DUT Driver

  • Adding dll's

  • Referencing new DUT Driver in WTM

Using AutoRange with Wireless LAN DUTs

If you do not wish to modify the existing code to include specific Wireless LAN DUT Drivers, the supplied AutoRange Test Plans will be able to help you perform basic measurements without extra development effort.

The Device Under Test must be set up to transmit, using the supplied control software from the DUT manufacturer, and the parameters for the Wireless LAN Test Step within the autorange sequence must be modified to ensure that the correct frequency, band and power range are set to match the transmitted signal. Then the autorange test step will calculate the expected power range and trigger values before perfomring the basic measurements.

The Autorange test steps cannot be placed into a loop, due to the fact that the DUT transmission is not controlled by the code but by the user.

Adding WLAN DUT Driver to Development Code

There are a few steps to follow to implement a new Wireless LAN DUT Driver. This can only be done with N4019C, the development version of the Bluetooth/Wireless LAN Wireless Test Manager. Please contact us if you only have the run time license.

Creating .NET project

This new project, within the N4019C solution should include all drivers necessary to control the DUT. Once compiled, the resultant .NET object should be callable by the N4019C project.

Create the new project within the N4019C solution and build it.

Within the N4019C project, add a reference to this new project, to ensure that we will be able to instantiate this object.

Please contact Agilent if you need any assistance with development of WTM.

Creating .vb DUT Driver

Copy the file <Install Directory>\N4019C\Development\SampleDUTDriver.vb to <Install Directory>\N4019C\Development\<DUT Driver Name of your choice>.vb

At the top of the file is the creation of the DUT object, this should be modified to make DUT an instantiation of your DUTControl object, specified in the .NET project you created.

For each Sub in this new file, include the code to control your device. If your device cannot do any of the basic driver commands then more modifications may be required, please contact us for support if necessary.

Adding dll's

If your DUT Driver requires any dll's to enable the control software to work, it is suggested that you copy them into the <Install Directory>\N4019C\Runtime directory, to ensure that they are not uninstalled by mistake.

Referencing new DUT Driver in WTM

Within <Install Direcory>\N4019C\Development\WLAN80211bg.vb, locate Sub CreateInst. This handles the creation of the WLAN Test Set Driver & the WLAN Device Driver.

Within the code in this SubRoutine is the following:

' User to modify this section to add integrated DUT Control. Dependant on Global parameter WLANDutType
' in user test plan, create required DUT Driver e.g. DUT = New UserDutDriverClass
DutType = CDbl(TestData.FindParm("WLANDutType"))
If (DutType = 2) Then
DUT = New SampleDUTDriver
Else
DUT = New SampleDUTDriver

End If
DUT.Create()
DUT.Connect()

The user must modify this code to create a DUT, using the new Driver class. The reason the code relies on the Global parameter WLANDUTType is to enable the user to implement more than one device driver, if different DUTs are being used.

So the user must decide which number refers to which WLAN DUT type & then replace 'new SampleDUTDriver' with 'new <DeviceDriverClassName>'.

Then the user must ensure that the global parameter WLANDUTType is correct for each test plan.


Starting to Use the Wireless Test Manager

This topic provides general guidelines on the steps you need to perform during initial use of the Wireless Test Manager. The exact procedure depends on your system configuration and the system components that you have.

This covers the Wireless Test Manager's Operator and Administrator graphical user interface (GUI). If you want details on using the software development environment, see Developer Information.

To start using the Wireless Test Manager

  1. Ensure that the hardware security key provided is properly connected to your computer's USB or parallel port.

  2. Connect any supported hardware that you have to your test system.

  3. When you start the Wireless Test Manager for the first time after installation, you are asked to set up the password that is used to gain Administrator mode access. Enter this password now.

  4. Click the Change Configuration tab.

  5. In the Select a configuration type to change box, click Run Test Conditions.
    The Run test conditions group is displayed to the right.

  6. Ensure that the Demo mode check box is not selected. If it is, click to clear it.

  7. In the Select a configuration type to change box, click System IO ports.
    The System IO ports group is displayed to the right with tabs allowing you to assign ports to various hardware devices.

  8. Identify the tabs that correspond to the hardware devices you have, and specify the correct ports for each device in turn. For example, if you have a supported bar code reader connected to COM port 3, click the Bar Code Reader tab and select COM3 from the drop-down list box.

  9. After you have correctly assigned the port numbers for each hardware device in the previous step, use the Select a configuration type to change box to set up each hardware device in turn. For each hardware device, you must specify the model or type of device, and various other settings to ensure the device is configured correctly.

    In most cases, you can test the communication between the device and the Wireless Test Manager. (For example, if you have a TestCom 5942B (Agilent N4049A) Wireless Test Fixture connected to your system, you can test that its Open, Close, Engage and Disengage actions are working correctly using the tabs in the Fixture control group.

  10. After you have tested that the communication between the Wireless Test Manager and all your hardware devices is working correctly, you should select the test plan that you want to run. See Selecting a Test Plan.

  11. Ensure that the specifications and parameters for each test plan step are set appropriately in order to meet your requirements. See Setting Specifications (Pass/Fail Limits) and Setting Parameter Values.

  12. Now that you have correctly configured your hardware devices, selected the test plan you want, and set up the specifications and parameters for each test plan step to meet your requirements, you are now ready to run your test plan. To do this, click the Run Test Plan tab then click the Run Test Plan button.


Understanding the Different Operating Modes

Understanding the Different Operating Modes: Operator, Administrator, and Developer

The Wireless Test Manager is comprised of a number of different operating modes. Each operating mode has different user interface features and permission levels. The different operating modes are described below:

The sections below use the E6560C cdma2000/IS-95/AMPS Wireless Test Manager specifically to show example screenshots. However, you should note that these guidelines apply to all Wireless Test Managers. Any references to the E6560C model number in the sections below should be changed according to the model number of the Wireless Test Manager you are using.

Operator

The Operator operating mode of the Wireless Test Manager is the GUI (Graphical User Interface) environment which allows operators to quickly log on to, and test, wireless devices. The user interface features that are available to the Operator are determined by someone with permission to use the Administrator operating mode. Each time the Wireless Test Manager starts, the initial mode is Operator mode.

Example of a typical Operator user interface:

Administrator

The Administrator operating mode of the Wireless Test Manager allows access to all of the user interface features. Someone with permission to use Administrator operating mode can run and define test plans, set global parameter values and change any of the available configuration types. Access to the Administrator operating mode is password controlled.

To change to Administrator mode, click the [image] button on the toolbar to open the Administrator Mode Access dialog box. Type the correct password then click OK. To return to Operator mode, click the [image] button on the toolbar. Note that these buttons are action buttons which show the opposite of the current state.

Example of a typical Administrator user interface:

Developer

The Developer operating mode of the Wireless Test Manager allows a software developer to incorporate the Wireless Test Manager in their own software application source code using Microsoft® Visual Studio®.NET 2003. The Wireless Test Wizard also provides a quick and easy way for the developer to add new test plan steps or modify existing test plan steps.

If you want details on how to start the development environment, see: To start the Wireless Test Manager development environment.

Example of using the Wireless Test Manager control in Visual Studio.NET 2003:


Glossary

Term

Definition

Administrator Mode

A mode of operation for the Wireless Test Manager which allows access to additional features. If you have permission to use Administrator mode (password protected) you can decide which features are visible to someone using the Wireless Test Manager in Operator mode.

Available Step

A step which is available to be added to a test plan. The Wireless Test Manager provides a list of available steps on the Define Test Plan tab from which you can select to add to your test plan.

Current Test Plan Step

A step which is currently added to a test plan. The Wireless Test Manager lists all of the current test plan steps for the selected test plan on the Define Test Plan tab.

Developer Mode

A mode of operation for the Wireless Test Manager which allows a software developer to incorporate the Wireless Test Manager in their own software application source code.

Fail Step

A step which you can attach to an existing test plan step. If the test plan step (to which the fail step is attached) fails, the fail step is run.

Global Parameter

A type of parameter which applies to all steps within a test plan.

A global parameter is different from a parameter which is assigned to a specific step. A step parameter only affects the individual step to which it is assigned, whereas a global parameter affects all steps within a test plan.

Each test plan can have it's own set of global parameter values.

Operator Mode

A mode of operation for the Wireless Test Manager which allows operators to quickly run test plans for testing wireless devices. The user interface features that are available to the Operator are determined by someone with permission to use the Administrator operating mode.

Step or Test Plan Step

The terms Step and Test Plan Step have the same meaning.

A single component which you can add to a test plan. Each step performs a single task or related group of tasks. For example, a step may establish a call, change a channel, make a measurement, or perform a looping function. The developer can even create their own steps which can then be added to test plans.

In the Wireless Test Project developer class modules, a Step is defined as a Test within the source code.

System

You can have multiple systems depending on the number of test sets in your wireless test system. For example, if you have two test sets you can set the Wireless Test Manager to control two systems.

Test Plan

A test plan is a complete suite of tests which you run using the Wireless Test Manager. A test plan is composed of steps (also known as test plan steps). The Wireless Test Manager comes with a selection of pre-defined test plans. In addition, you can add your own custom test plans.


How To ...

The topics in this section provide step-by-step procedures for performing the most common tasks with the Wireless Test Manager.

For more information, choose a topic below:

  • Adding a Fail Step to a Test Plan Step

  • Adding a New Test Plan

  • Adding a Step to a Test Plan

  • Changing the Password

  • Configuring Input/Output (IO) Ports

  • Configuring Yield Calculations

  • Copying and Pasting Test Plan Steps

  • Interpreting Test Results

  • Running a Test Plan

  • Saving Results to a File

  • Selecting a Test Plan

  • Selecting which Features are Visible in Operator Mode

  • Setting a Test Plan's Global Parameters

  • Setting Parameter Values

  • Setting Specifications (Pass/Fail Limits)

  • Setting Up a Bar Code Reader

  • Setting Up a Printer

  • Setting Up a Software Controllable Fixture

  • Setting Up Instrument Control

  • Setting up RF Path Loss Values

  • Testing with Multi-systems

  • Using the Hardware Security Key


Adding a Fail Step to a Test Plan Step

The Wireless Test Manager allows you to add a fail step to any of the steps in a test plan. A fail step is run only if the step that it is added to fails. Specifications and parameters for a fail step are set independently of other steps in a test plan.

To add a fail step to a test plan step

  1. Click the Define Test Plan tab.

  2. Verify that the test plan you want is selected in the Current test plan box. If not, select the test plan you want.

  3. In the Available steps box, click the step you want to add as a fail step.

  4. In the Current test plan steps box, click the test plan step that you want to add a fail step to.

  5. Click Add Fail Step.
    The fail step is added below the test plan step you selected. If the test plan step already has one or more fail steps, the new fail step is added to the bottom of the list. Use a drag-and-drop operation if you want to re-order any of the fail steps.


Adding a New Test Plan

The Wireless Test Manager comes with a selection of pre-defined test plans. You can also add your own custom test plans and define the steps that you want to include in your new test plan.

To add a new test plan

  1. Click the Define Test Plan tab.

  2. Click Add New Plan.
    The Add New Plan dialog box is displayed.

  3. In the Formats(s) for this test plan box, click to select or clear the formats that you want the new test plan to apply to. Note that at least one format must be selected.

  4. In the Test plan name box, type a name for the new test plan.

  5. Click OK to finish adding a new test plan, or click Cancel.


Adding a Step to a Test Plan

The Wireless Test Manager allows you to add as many steps as you want to your test plan. Test plan steps are run in the test plan in the same order in which they are listed in the Current test plan steps box on the Define Test Plan tab.

To add a step to a test plan

  1. Click the Define Test Plan tab.

  2. Verify that the test plan you want is selected in the Current test plan box. If not, select the test plan you want.

  3. In the Available Steps box, find the step you want to add to the test plan.

  4. Use a drag-and-drop operation to add the step to the test plan at the position you want.
    The step you added is displayed in the     Current test plan steps box.

  5. Repeat steps 3 and 4 above for any additional steps you want to add to the test plan.

Tip: You can add a step to a test plan by double-clicking the name of the step in the Available Steps box. However, the step is always added after any existing test plan steps. If you want to move the step to a different position in the test plan, use a drag-and-drop operation.


Changing the Password

For security reasons, a password is required to access Wireless Test Manager's Administrator operating mode. You must have Administrator permission to change the password.

To change the password

  1. Ensure that Wireless Test Manager is in Administrator mode.

  2. Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click Viewable Features Selection.

  4. Click the Change Password button.
    The Change Password dialog box is displayed allowing you to set a new password.


Configuring IO Ports

Configuring Input/Output (IO) Ports

You can specify the system IO port settings for each of the devices that the Wireless Test Manager controls. This includes devices which use serial communication (COM) ports, GPIB (General Purpose Interface Bus) ports, and Digital IO ports. For example, you can configure IO ports for GPIB interface cards, bar code readers, fixtures, and such like.

To be able to configure IO ports, you must either be using the Wireless Test Manager in Administrator mode, or the Operator mode must be set by the administrator to show the System IO ports group, on the Change Configuration tab. See Selecting which Features are Visible in Operator Mode.

To configure system IO ports

  1. Ensure that the Wireless Test Manager is in Administrator operating mode.

  2. Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click System IO Ports.

  4. Click the tab corresponding to the device you want to configure. For example, click the Bar Code Reader tab if you want to change the COM port settings of your bar code reader.

  5. Set the options to match the device connected to the port.
    For information about the correct settings, see the user documentation supplied with the device.

Tip: Use the Find GPIB Ports button if you want the Wireless Test Manager to search for GPIB ports and display descriptions of currently connected GPIB devices. This button is available on the GPIB tab.

Tip: Use the Find Serial Ports button if you want the Wireless Test Manager to search for available serial COM ports. This button is available on any of the tabs which allow you to configure a serial device (that is, the Bar Code Reader, DUT Phone Control, Fixture 1, or Fixture 2 tabs).

Related Topic: System IO Ports


Configuring Yield Calculations

Yield is defined as the number of passed units divided by the total number tested. Yield is expressed as a percentage. For example, if 95 out of 100 units pass a test plan, the yield is 95%.

To be able to configure yield calculations, you must either be using the Wireless Test Manager in Administrator mode, or the Operator mode must be set by the administrator to show the Data collection group, on the Change Configuration tab. See Selecting which Features are Visible in Operator Mode.

To configure yield calculations

  1. Ensure that the Wireless Test Manager is in Administrator operating mode.

  2. Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click Data Collection.

  4. In the Calculate yield over last group, type the number of Units over which you want the yield to be calculated. The maximum value you can enter is 300.

  5. If you want to reset the yield calculation, click the Reset Calculation button.


Copying and Pasting Test Plan Steps

The Wireless Test Manager allows you to copy one or more test plan steps and then paste them into any of your existing test plans or new test plans that you create. Test plan steps are run in the test plan in the same order in which they are listed in the Current test plan steps box on the Define Test Plan tab, so you need to make sure that you paste the test plan steps you have copied into the correct position in your test plan.

You cannot paste test plan steps into fail steps.

To copy and paste test plan steps

  1. Click the Define Test Plan tab.

  2. Verify that the test plan you want to copy test plan steps from is selected in the Current test plan box. If not, select the test plan you want.

  3. Click the Copy button to display the Select current test plan steps to copy box.

  4. Click the test plan step you want to copy.

Tip: To select more than one test plan step to copy, hold down the CTRL key, and then click the test plan steps you want. To select a group of test plan steps that are next to each other, click a test plan step at one end of the group, hold down the SHIFT key, then select the other test plan steps you want.

  5. Click the Return button to close the Select current test plan steps to copy box.

  6. Verify that the test plan you want to paste the test plan steps into is selected in the Current test plan box. If not, select the test plan you want.

  7. In the Current test plan steps box, highlight the test plan step just before the position where you want to paste in the test plan step(s) you have copied.

  8. Click the Paste button.
    The copied test plan step(s) are pasted into the test plan just after the test plan step you highlighted.


Interpreting Test Results

Test Results Overview

Three different types of test results are available in the Wireless Test Manager. These are:

  • Overall Pass/Fail,

  • Basic, or

  • Comprehensive.

The three results types are explained in more detail in the following sections.

Overall Pass/Fail Results

This result is displayed in the Information Display Box after a test plan has finished running, or as soon as a test plan is aborted. A Passed, Failed or Aborted result is displayed.

Basic Results

These results are displayed on the Run Test Plan tab. The results relate to the last test plan which was run. The following information can be displayed:

  • Test Title

  • Measured Value

  • Lower Limit

  • Upper Limit

  • Pass/Failed

If you only want to display a subset of this information, click the Change Configuration tab, then click Display Control in the Select a configuration type to change box to display the Display control group. Select or clear the check boxes as required.

Comprehensive Results

These results are displayed within the Previous Test Results Dialog Box. You specify which previous results to view using the button you want in the Previous test results group. For more details on the information provided by the Comprehensive test results, see Previous Test Results dialog box.


Running a Test Plan

Running a test plan is the most common task you are likely to want to perform with the Wireless Test Manager.

To run a test plan

  1. Click the Run Test Plan tab.

  2. In the Current test plan box, select a test plan to run.

  3. Click Run Test Plan to start the testing.
    The Test Plan Progress Indicator shows the progress of the currently running test plan. When the test plan finishes, the overall pass/fail result is shown in the Information Display Box.


Saving Results to a File

You can save your test results to a file so that you can look at them later, or so that they can be transferred to a database.

To be able to set up the Save results to a file feature, you must either be using the Wireless Test Manager in Administrator mode, or the Operator mode must be set by the administrator to show the Data collection group, on the Change Configuration tab. See Selecting which Features are Visible in Operator Mode.

To save results to a file

  1. Click the Change Configuration tab.

  2. In the Select a configuration type to change box, click Data Collection.

  3. Select Save results to a file. A new set of controls is displayed.
    Selecting Save Results to a file ensures that test results are saved every time you run a test plan.

  4. In the Results file type box, select the file type that you want results to be saved to; either XML, Comma Separated text file, Tab Separated text file, or Reduced/Graphical CSV.

  5. Three check boxes are available:

    1. Output unicode file - Select this if you want the data stored in unicode format. While this will work with English, it is most commonly used with local languages that need 16 bit representation rather than 8 bit. Typically, these are associated with Asian languages.

    2. Keep data from aborted tests - Select this if you want data to be saved from test plans that are aborted rather than have a normal completion.

    3. Keep only failed test plans - Select this to store data from test plans that contain a failure.

  6. In the Primary data collection path box, select the drive or folder on your computer in which you want to save the test results. If this path is not available, the test results will be saved to the drive or folder specified in the Secondary data collection path box.
    You have now finished setting up test results to be saved to a file. Each time you run a test plan, the results will be saved in the file format and location that you have specified.


Selecting a Test Plan

The Wireless Test Manager comes installed with a number of pre-defined test plans. In addition, you can create your own test plans. Before you can perform any tasks with a test plan (for example, run, modify, or change the test plan's global parameters) you have to ensure that you have selected it.

To select a test plan

  1. Click any one of the following tabs; Run Test Plan, Define Test Plan, Set Specs/Parameters, Set Global Parameters.
    The tab you click should depend on the operation you want to perform. For example, if you want to add a step to a test plan, you should click Define Test Plan.

  2. In the Current test plan box, select the test plan you want.


Selecting which Features are Visible

Selecting which Features are Visible in Operator Mode

If you have permission to use the Wireless Test Manager in Administrator mode, you can configure the user interface to show or hide certain features when the Wireless Test Manager is in Operator mode.

To select which features are visible in Operator mode

  1. Ensure that the Wireless Test Manager is in Administrator mode.

  2. Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click Viewable Features Selection.
    Note that     Viewable Features Selection is only visible in Administrator mode.

  4. Select or clear the user interface features that you want to be visible in Operator mode.
    The next time the Wireless Test Manager is returned to Operator mode, the user interface is configured to show only the features that you specified.


Setting a Test Plan's Global Parameters

A global parameter is different from a parameter which is assigned to a specific step. A step parameter only affects the individual step to which it is assigned, whereas a global parameter affects all steps within a test plan. Each test plan can have it's own set of global parameter values. If you want to assign identical global parameter values between different test plans, you can do this using the Global parameters source selection group on the Set Global Parameters tab.

You can change any of the global parameter values for the currently selected test plan.

To set a test plan's global parameters

  1. Click the Set Global Parameters tab.

  2. Verify that the test plan you want is selected in the Current test plan box. If not, select the test plan you want.

  3. In the Global parameters for test plan group, click the global parameter you want to change.

  4. Type or select a new value for the global parameter from the drop-down list.
    The new value you specified takes effect immediately.

  5. Repeat Steps 3 and 4 above for each global parameter that you want to change.


Setting Parameter Values

The majority of steps which make up a test plan have their own parameters which you can set to different values. (For example, a step which performs a measurement function may contain a Measurement Timeout parameter.) Any changes you make to parameter values only affects the currently selected test plan.

To set parameter values for a step

  1. Click the Set Specs/Parameters tab.

  2. Verify that the test plan you want is selected in the Current test plan box. If not, select the desired test plan.

  3. In the Current test plan steps box, select the test plan step for which you want to change the parameter value(s).
    The specifications and parameters for the selected step are displayed on the right.

  4. In the Parameters for test plan step group, click on the parameter that you want to change.
    The parameter's current value is highlighted.

  5. Type or select a new value for the parameter from the drop-down list.
    The new value you specified takes effect immediately.

  6. Repeat Steps 3 and 4 above for each of the test plan's parameters that you want to change.


Setting Specifications (Pass/Fail Limits)

The majority of steps which make up a test plan have their own specifications (pass/fail limits) which you can set to different values. (For example, in the E6560C cdma2000/IS-95/AMPS Wireless Test Manager, an Analog TX RF Power Output measurement function may contain upper and lower limit specifications for output power.) Any changes you make to specification values only affects the currently selected test plan.

To set specifications for a step

  1. Click the Set Specs/Parameters tab.

  2. Verify that the desired test plan is selected in the Current test plan box. If not, select the desired test plan.

  3. In the Current test plan steps box, select the test plan step for which you want to change the specifications.
    The specifications and parameters for the selected step are displayed on the right.

  4. In the Specifications for test plan step group, click on the specification that you want to change.
    The specification's current value is highlighted.

  5. Type or select a new value for the specification from the drop-down list.
    The new value you specified takes effect immediately.

  6. Repeat Steps 3 and 4 above for each of the test plan's specifications that you want to change.


Setting up a Bar Code Reader

This topic provides general guidelines on the steps you need to perform to set up a bar code reader. The exact procedure depends on your system configuration and the system components that you have.

To be able to set up a bar code reader, you must either be using the Wireless Test Manager in Administrator mode, or the Operator mode must be set by the administrator to show the System IO ports and Bar code reader control groups, on the Change Configuration tab. See Selecting which Features are Visible in Operator Mode.

To set up a bar code reader

  1. Connect your bar code reader to an available serial (COM) port in your system.

  2. In the Wireless Test Manager, click the Change Configuration tab.

  3. In the Select a configuration type to change box, click System IO Ports.
    The System IO ports group is displayed to the right.

  4. Click the Bar Code Reader tab, and in the Bar code for System 1 drop-down list box, select the COM port number which matches the one where your bar code reader is connected.

  5. Once you are sure that you have correctly specified the COM port, go to the Select a configuration type to change box, and click Bar Code Reader Control.
    The Bar code reader control group is displayed to the right.

  6. In the Bar code model drop-down list, select RS-232.
    Additional items are now displayed below to help you configure and test your bar code reader's serial communication settings.

  7. Set the options such as Baud rate and Handshaking control to match the settings required by you bar code reader. For information about the correct settings, see the user documentation supplied with your bar code reader.

  8. Test the communication between the Wireless Test Manager and your bar code reader using the Bar code information received box.

  9. You're bar code reader should now be ready for use.


Setting up a Printer

It is important that you set up your printer in the Wireless Test Manager to ensure that the results print correctly.

To set up a printer

  1. Click the Change Configuration tab.

  2. In the Select a configuration type to change box, click Printer Control.
    The Printer control group is displayed to the right.

  3. Select Print test results.

  4. In the Default Printer: box, select the printer you want to use. This list the list of installed printers on your computer in the Windows® operating system.

  5. In the Printer Type box, select the type of printer you are using, either 80 characters or 40 characters.
    If you are not sure which type of printer you are using, either try out each setting with your printer to find out which works best, or refer to your printer's user documentation.

  6. Select the appropriate check boxes (for example, Print measured values) to define the information which you want to be printed.


Setting up a Software Controllable Fixture

The Wireless Test Manager supports the following fixtures:

  • TestCom 5942B Test Fixture (formerly sold as the Agilent Technologies N4049A)

  • Generic RS-232 Fixture

  • Manual fixture

Set up procedures for each of the supported fixture types are provided in the following sections.

To be able to set up a fixture, you must either be using the Wireless Test Manager in Administrator mode, or the Operator mode must be set by the administrator to show the System IO ports and Fixture control groups, on the Change Configuration tab. See Selecting which Features are Visible in Operator Mode.

To set up a TestCom 5942B Wireless Test Fixture

  1. Connect your TestCom 5942B Wireless Test Fixture to an available serial (COM) port in your system.

  2. In the Wireless Test Manager, Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click System IO Ports.
    The System IO ports group is displayed to the right.

  4. Click the Fixture 1 tab, and in the Fixture 1 port for System 1 drop-down list box, select the COM port number which matches the one where your 5942B Wireless Test Fixture is connected.

  5. Once you are sure that you have correctly specified the COM port, go to the Select a configuration type to change box, and click Fixture Control.
    The Fixture control group is displayed to the right.

  6. In the Fixture model drop-down list box, select N4049A(TC-5942B).
    The Multi-fixture testing and Close/Open/Engage/Disengage options are displayed.

  7. Use the Close/Open/Engage/Disengage tabs to test that each of the 5942B Wireless Test Fixture's actions (such as Open) are working correctly.

  8. Once you have tested that all of the fixture actions are working correctly, your 5942B Wireless Test Fixture should be ready for use with the Wireless Test Manager.

If you want to set up a second 5942B Wireless Test Fixture, repeat the steps above, assigning the second fixture to a different COM port in Step 4 using the Fixture 2 tab. After Step 5 above, you also need to select Multi-fixture testing to set the Wireless Test Manager to support two fixtures.

To set up a Generic RS-232 fixture

  1. Connect your Generic RS-232 fixture to an available serial (COM) port in your system.

  2. In the Wireless Test Manager, Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click System IO Ports.
    The System IO ports group is displayed to the right.

  4. Click the Fixture 1 tab, and in the Fixture 1 port for System 1: drop-down list box, select the COM port number which matches the one where your Generic RS-232 fixture is connected.

  5. Once you are sure that you have correctly specified the COM port, go to the Select a configuration type to change box, and click Fixture Control.
    The Fixture control group is displayed to the right.

  6. In the Fixture model drop-down list box, select RS-232.
    Various additional options are displayed allowing you to configure your Generic RS-232 fixture, including serial communication settings such as Baud rate and tabs to test the fixture actions.

  7. Use the Close/Open/Status/Engage/Disengage tabs to test that each of the Generic RS-232 fixture's actions (such as Open) are working correctly. Text boxes are available on each tab for you to edit the syntax for each action (if necessary).

  8. Once you have tested that all of the fixture actions are working correctly, your Generic RS-232 fixture should be ready for use with the Wireless Test Manager.

If you want to set up a second Generic RS-232 fixture, repeat the steps above, assigning the second fixture to a different COM port in Step 4 using the Fixture 2 tab. After Step 5 above, you also need to select Multi-fixture testing to set the Wireless Test Manager to support two fixtures.

To set up a Manual fixture

  1. In the Wireless Test Manager, Click the Change Configuration tab.

  2. In the Select a configuration type to change box, click Fixture Control.
    The Fixture control group is displayed to the right.

  3. In the Fixture model drop-down list box, select Manual.
    The Multi-fixture testing option is displayed.

  4. Your manual fixture should be ready for use with the Wireless Test Manager.


Setting Up Instrument Control

Instrument Control is one choice on the Change Configuration Tab. This is used to select the type of interface, the address of the test equipment, and to test the settings. Default instruments are the Test Set and the 663NNX Power Supply family. Other instruments can be added with the Add Instrument Wizard in the Development environment.

To set up instrument control

  1. Click the Change Configuration tab.

  2. When this tab first opens, it will have two large buttons: View Instrument Types and Find Instruments. Clicking the View Instrument Types will toggle this button to View Address Settings.

  3. When the View Instrument Types is active, each instrument will have its own drop down selection of its interface type. Select the interface you will use to control that instrument.

  4. The Find Instruments button will identify only those instruments that are controlled via GPIB.

  5. When the interface type for each instrument has been selected, click the View Instrument Types button to change it to View Address Settings. Each instrument will have its own address box. How these are set depends on the choice of interface.

  1. If GPIB has been selected, there is a drop down list of values from 0 to 31. Click on the arrow and select the appropriate address from the list.

  2. If LAN has been selected, there is a button labeled LAN... which can be clicked to open a dialog box. This allows you to select which LAN board should be used if more than one are installed in the computer. The IP address of the instrument or its network name, if one has been assigned by the network, may be entered in the field Machine Name/IP. This is accepted or cleared with the OK or Cancel button.

  3. If USB has been selected, there is a button labeled USB... which can be clicked to open a dialog box. This allows you to select which USB board should be used if more than one are installed in the computer. Clicking the Find button will display all the instruments that are connected to that USB port. The desired instrument may be selected from this list with a double click. Click on OK or Cancel to close the dialog box.

  4. If ASRL has been selected, there is a button labeled ASRL... which can be clicked to open a dialog box. This allows you to select which Serial Interface board to use if more than one is installed in the computer. There is also a button labeled Find Serial Ports that will display all active and inactive COM ports on the computer, and can be used to launch Device Manager which can be used to manage the Serial ports or read the mapping between COM ports in the computer and the physical serial ports. ASRL does not assign addresses; each instrument must have its own cable connecting it to a unique serial port.

  5. When an address or port if ASRL has been assigned, a new button will be next to each instrument interface selection box. It is labeled *IDN? and will query the instrument ID when clicked.

Related Topic: Instrument Control.


Setting up RF Path Loss Values

It is important that you set up RF path loss values correctly for your test system.

The Bluetooth/Wireless LAN Wireless Test Manager DOES NOT utilise the path loss file system.

It utilises global parameters instead. Bluetooth uses the BT Loss Compensation parameter, Wireless LAN uses WLAN Path Loss A Band (5GHz) and WLAN Path Loss B Band (2.4GHz)

The remainder of the Path Loss Details below are in case additional fixtures etc are added to the system.

The RF Paths exist because wireless devices are generally tested for functionality while inside a fixture (fixtures provide a consistent test environment). Cables, switches and other devices connect the fixture to the test instrumentation that is making measurements on the wireless device. The fixture/cable/switch combinations provide a RF path to the test instruments, and the effects that this RF path has on signals must be taken into account to correct the wireless device's measurements.

Path losses are stored as a pair of values in the form (frequency, gain). Note that path losses are represented with negative gain values.

To set up RF path loss values

  1. Click the Change Configuration tab.

  2. In the Select a configuration type to change box, click Path Loss Values.
    The Path loss values group is displayed to the right.

  3. The currently selected path loss file is shown in the Current path loss path box.
    The path loss information is stored in an XML file format.

  4. If you want to select a different path loss file, click the Select Path Loss File button.

  5. Click on the fixture and level file you wish to edit, the current values will show in tabular form in the right window. New values may be added, they will automatically sort in frequency order if viewed later.

Default Path Loss Names and Naming Conventions

Default Path Loss Naming Conventions

The default path loss naming conventions are as follows:

RF IN/OUT_SYSx_FIXy

  • where x is system number in the range 1 up to the maximum number of systems your Wireless Test Manager supports.

  • where y is fixture number 1 or 2.

Default Path Loss Names

When you are using a single system without a fixture, the Wireless Test Manager searches for the following path loss name by default:

RF IN/OUT_SYS1_FIX1

When Multi-system testing and Multi-fixture testing are selected, the Wireless Test Manager searches for the following path loss names by default:

  • SYSTEM 1:

  • RF IN/OUT_SYS1_FIX1

  • RF IN/OUT_SYS1_FIX2

  • SYSTEM N (where n is the system number). For example, for system 2:

  • RF IN/OUT_SYS2_FIX1

  • RF IN/OUT_SYS2_FIX2

Default Path Losses

For each of the path loss names specified above, the default path loss values are set as shown in the following table:

Frequency | Loss
400 MHz | 0.4 dB
1 GHz | 1 dB
2 GHz | 2 dB


Testing with Multi-systems

The Wireless Test Manager supports testing on one or multiple test systems.

When multiple instances of the Wireless Test Manager are currently running, the configuration settings are saved from the last instance that is closed down.

It is recommended that you only use multiple instances of Wireless Test Manager once your test code is stable, or when you are running test plans on the production line. You should not run multiple instances during test development in a pre-production environment.

To test with multi-systems

  1. Ensure that the Wireless Test Manager is in Administrator mode.

  2. Click the Change Configuration tab.

  3. In the Select a configuration type to change box, click System IO Ports.

  4. Select Multi-system testing.

  5. Now you must exit and re-start the Wireless Test Manager.

  6. The first instance of the Wireless Test Manager starts. The green background on the toolbar indicates that this instance of the Wireless Test Manager is controlling System Number 1.

  7. Start another instance of the Wireless Test Manager by double-clicking the desktop icon again. The blue background on the toolbar indicates that this instance of the Wireless Test Manager is controlling System Number 2.

You can now test with multiple systems independently. Each of these systems can control one or two fixtures.


Using the Hardware Security Key

The hardware security key is intended to prevent unlicensed use of this software.

You can run the software without the key, but only in the demonstration mode. To make any real measurements you need to connect the key to your computer's USB port. One key is required for each computer on which you want to install the software. The key only works with licensed copies of the software. For Option 100, the older parallel port security is used.

If you want to run the E6570C Wireless Test Manager Extended Capability you need to connect the additional hardware security key to the same port. Therefore, when running the E6570C, two hardware security keys will be connected to this port.

Different Hardware security keys are provided for different versions of the Wireless Test Manager. Here is a summary of the available keys:

Key Type | USB Security Key- .Net WTM only (N4019C versions) | Parallel Port Key - Legacy Software
Development | Key DU | Key A
Runtime | Key EU | Key B

Related Topic: If you have trouble with the hardware security key


Graphical User Interface Reference

The books and topics in this section provide reference information about the Wireless Test Manager's Graphical User Interface.

For more information, choose the book below:

  • Add New Plan/Copy Plan Dialog Box

  • Information Display Box

  • Previous test results

  • Status Bar

  • Test plan progress indicator

  • Toolbar

  • Tabs and Associated Controls


Add New Plan/Copy Plan Dialog Box

The Add New Plan/Copy Plan dialog box is used to specify the name and wireless formats for a new test plan, or to specify a new name for a test plan you want to copy.

The items that are displayed depends on the button you clicked to open this dialog box. If you clicked the Copy Plan button, the Format(s) for this test plan and Notes for format items are not available.

Click on an item to get more details:

  • Format(s) for this test plan

  • Notes for format

  • Test plan name

  • OK

  • Cancel

  • Help

Format(s) for this test plan

Use this box to select the format(s) which apply to the new or copied test plan.

Notes for format

Use this box to view notes that apply to the format currently selected in the Format(s) for this test plan box.

Test plan name

Use this edit box to specify a name for the new or copied test plan.

OK

Click the OK button to accept your changes and close the dialog box.

Cancel

Click the Cancel button to cancel your choices and close the dialog box.

Help

Click the Help button to display this help topic.


Graphics Tool

A Graphical plotting tool is included as part of the WTM package. It is a separate application that is launched by clicking on the graphics tool button on the toolbar. This tool is compatible with files stored in the Reduced/Graphical CSV format.

Help for this tool is available inside that program.


Information Display Box

This box displays different information depending on which tab is currently selected:

  • If the Run Test Plan Tab is currently selected this box shows an overall pass/fail result when the current test plan has completed.

  • If any other Tab is currently selected, this box shows useful instructional information.


Previous test results

Use to select which test results to view. The test results you select are opened in the Previous Test Results dialog box.

Separate comprehensive test results are available for the previous seven test plans that were run. Click on the results you want to view.

Yield information is displayed below the previous test results buttons. The color shown on each button indicates the overall test plan result:

  • Green indicates that the test plan passed.

  • Yellow indicates that the test plan was aborted.

  • Red indicates that the test plan failed.

Tip: To view the most recent test plan that was run, click button 1 [image].


Status Bar

There are two status areas at the bottom of the screen. While a test plan is running, the center portion displays real-time status information about the test plan's specifications and measurements.

Once the test plan has finished, this displays the number of lines in the test plan which have passed and failed.

The right hand portion of this is blank while a test plan is running, and shows the duration of the last test when a test plan has finished. It is blank before any test plan has been run.


Test Plan Progress Indicator

Test Plan Progress Indicator (Left Status Bar)

This indicates the progress of the currently running test plan.


Toolbar

The toolbar provides shortcuts to common commands and status information.

Button: | Purpose:
 | Use this to launch the graphics tool to allow display of graphical test results that have been saved in Reduced/Graphical CSV format.
 | Use this to access Administrator operating mode. Note that you will be asked to enter a password to gain access.
 | Use this to access Operator operating mode.
 | Use this to select the size of the user interface window; either standard or compact.
 | Use this to select the application to be active with the Wireless Test Manager.
 | Use this to export the Test Plan to WordPad. You can then print the test plan.
 | Use this to open the Online Help.
 | Use this to find out the revision number of Agilent Technologies Wireless Test Manager that you are using.
 | This indicates that a fixture has been selected.
 | This indicates that a bar code reader has been selected.
 | This indicates that test plan results are being saved to a file.
 | This indicates that the Print test plan results option is currently selected.
 | This indicates that WTM LAN communication control has been selected, but that the LAN interface is not able to talk to the instrument.
 | This indicates that WTM LAN communication control has been selected and that the LAN interface is able to talk to the instrument.


Tabs and Associated Controls

The books and topics in this section provide help for each of the items contained on the Wireless Test Manager's graphical user interface.

For more information, choose a book or topic below:

  • Run Test Plan Tab

  • Define Test Plan Tab

  • Set Specs/Parameters Tab

  • Set Global Parameters Tab

  • Change Configuration Tab


Run Test Plan Tab

The Run Test Plan tab allows you to select and run a test plan, view test plan results and in Developer mode, define your own user interface controls.

For more information, choose a topic below:

  • Test control


Test control (Run Test Plan Tab)

The items in this group allow you to select, control and run a test plan. Click on an item to get more details:

  • Current test plan

  • Current fixture

  • Run Test Plan

  • Stop Test Plan

  • View Results

  • View Test Conditions

Current test plan

Use this drop-down list to select the test plan you want to run.

Current fixture

Use these options to select which fixture to apply the current test plan to. Select either One or Two.

These options are only displayed if Multi-fixture testing has been selected.

Run Test Plan

Use the Run Test Plan button to run the currently selected test plan.

This button is replaced by the Stop Test Plan button while a test plan is running.

Stop Test Plan

Use the Stop Test Plan button to abort the currently running test plan.

This button is only displayed while a test plan is running.

View Results

Use the View Results button to view the results of the previously run test plan. When clicked, this button is replaced by the View Test Conditions button.

If you want to return to the test conditions after you have finished looking at the test plan results, click the View Test Conditions button.

View Test Conditions

Use the View Test Conditions button to return to the test conditions after you have finished looking at the test plan results. When clicked, this button is replaced by the View Results button.


Define Test Plan Tab

The Define Test Plan tab provides controls which allow you to add new test plans or define existing test plans.

For more information, choose a topic below:

  • Test plan manager

  • Define test plan


Test plan manager (Define Test Plan Tab)

The items in this group allow you to perform common tasks with test plans. Click on an item below to get more details:

  • Current test plan

  • Make test plan visible

  • Comments

  • Available Steps

  • Add New Plan

  • Copy Plan

  • Delete Plan

  • Copy Plan to "TemporaryPlan"

Current test plan

Use this drop-down list to select the test plan you want to define. Once you have selected a test plan, the Current test plan steps box shows the steps which are currently part of the test plan. Changing the current test plan on one tab changes it on all tabs.

Make test plan visible

Use this check box to select whether or not the currently selected test plan is visible in the Operator user interface.

Make test plan visible is only available in Administrator mode.

Comments

Use to open the Comments for test plan: edit box. This edit box allows you to enter comments relating to the currently selected test plan. Once you have finished entering comments, click the Available Steps button to close the edit box.

Available Steps

Use to close the Comments for test plan edit box and replace it with the Available steps box.

Add New Plan

Use to add a new test plan. The Add New Plan dialog box opens allowing you to enter a name for the new test plan.

Copy Plan

Use to make a copy of the currently selected test plan. The Copy Plan dialog box opens allowing you to enter a name for the test plan copy.

Delete Plan

Use to delete the currently selected test plan. The Delete Test Plan dialog box opens asking you to confirm that you want to delete the plan. If you are sure you want to delete the test plan, click Yes. If you don't want to delete the test plan, click No.

Copy Plan to "TemporaryPlan"

Use to copy the currently selected test plan to a temporary test plan.

This provides you with a quick way to experiment with your test plan (for example, adding additional steps, changing parameter values for a step) without going through the process of creating a copy of the current test plan. In this way, you can easily go back to your original test plan knowing that no permanent changes have been made.


Define test plan (Define Test Plan Tab)

The items in this group allow you to define the currently selected test plan (for example, add or re-order its steps). Click on an item below to get more details:

  • Available steps

  • Comments for test plan

  • Current test plan steps

  • Select current test plan steps to copy

  • Available steps filter

  • Delete Step

  • Add Fail Step

  • Copy

  • Return

  • Paste

Available steps

Use this box to select available steps that you want to place in the currently selected test plan.

To add steps to a test plan, select the step you want and use a drag-and-drop operation to add the step to the Current test plan steps box.

If you want a description of any step listed in the Available steps box, highlight the step you want, right-click the mouse to open the shortcut menu, and select to view the help for the step.

Comments for test plan

Use this box to type or edit information that you want to record about your test plan.

Current test plan steps

Use this box to view or re-order the steps which are defined for the currently selected test plan.

If you want a description of any step listed in the Current test plan steps box, highlight the step you want, right-click the mouse to open the shortcut menu, and select to view the help for the step.

Select current test plan steps to copy

Use this box to select one or more test plan steps (along with their associated specifications and parameters) to copy into a test plan.

Tip: To select more than one test plan step to copy, hold down the CTRL key, and then click the test plan steps you want.

To select a group of test plan steps that are next to each other, click a test plan step at one end of the group, hold down the SHIFT key, then select the other test plan steps you want.

Available steps filter

Use this drop-down list to filter the steps which appear in the Available steps box. This provides a way to reduce the number of steps which are displayed making it easier to locate the step you are trying to find.

Delete Step

Use to delete the currently selected step from the current test plan.

Add Fail Step

Use this to add a fail step. A fail step is initiated only if the step that the fail step is attached to fails. Note that results from a failure are not displayed in the basic test results view. However, you can view failed results by selecting one of the Previous test results.

Copy

Use the Copy button to display the Select current test plan steps to copy box. This allows you to select one or more test plan steps (along with their associated specifications and parameters) that you want to copy into a test plan.

When clicked, this button is replaced by the Return button.

Return

Use the Return button to close the Select current test plan steps to copy box and return to the Current test plan steps box.

The test plan steps that you have selected before clicking Return are copied to the clipboard for pasting into your selected test plan.

When clicked, this button is replaced by the Copy button.

Paste

Use the Paste button to paste the test plan steps you have copied to the clipboard into any one of your existing test plans, or a newly created test plan.

You cannot paste test plan steps into fail steps.

Related Topic: Copying and Pasting Test Plan Steps


Set Specs/Parameters Tab

The Set Specs/ Parameters tab allows you to change specification and parameter settings for each of the steps within the selected test plan.

For more information, choose a topic below:

  • Test plan

  • Specifications for test plan step

  • Parameters for test plan step


Test plan (Set Specs/Parameters Tab)

The items in this group allow you to select a test plan and test plan step for which you want to set specifications and parameters. Click on an item to get more details:

  • Current test plan

  • Current test plan steps

  • Maximum fail repeats

Current test plan

Use this drop-down list to select the test plan you want to set specifications and parameters for. Changing the current test plan on one tab changes it on all tabs.

Current test plan steps

Use this box to select a step from the currently selected test plan. When you select a step, its specifications and parameters are displayed for you to set.

If you want a description of any step listed in either the Available steps box or the Current test plan steps box, highlight the step you want, right-click the mouse to open the shortcut menu, and select to view the help for the step.

Maximum fail repeats

Use this to set the number of times a test plan step repeats if it fails.

Note that results from a failure are not displayed in the basic test results view. However, you can view comprehensive test results (including intermediate/failed results) by selecting one of the Previous test results.


Specifications for test (Set Specs/Parameters Tab)

Specifications for test plan step (Set Specs/Parameters Tab)

This table displays the specifications for the currently selected test plan step. The name of each specification is displayed along with the current lower and upper limit settings. To change a limit value, click the limit you want to change and then type or select a new value.

Related Topic: Setting Specifications (Pass/Fail Limits)


Parameters for test plan step (Set Specs/Parameters Tab)

This table displays the parameters and corresponding settings for the currently selected step. The name of each parameter is displayed along with its current value. To change a value, click the parameter you want to change and then type or select a new value.

If you type a value which is outside the valid range of the parameter, an Incorrect Parameter Data message is displayed ,showing the allowable range of values (example:).

Close the message box and type a valid value.

Related Topic: Setting Parameter Values


Set Global Parameters Tab

The Set Global Parameters tab allows you to change settings for global parameters.

A global parameter is different from a parameter which is assigned to a specific step. A step parameter only affects the individual step to which it is assigned, whereas a global parameter affects all steps within a test plan. Each test plan can have it's own set of global parameter values.

For more information, choose a topic below:

  • Test plan

  • Global parameters source selection

  • Global parameters for test plan


Test plan (Set Global Parameters Tab)

The items in this group allow you to select a test plan and assign a path loss name to the currently selected test plan. Click on an item below to get more details:

  • Current test plan

  • Path loss path name

Current test plan

Use this drop-down list to select the test plan you want to set global parameters for. Changing the current test plan on one tab changes it on all tabs.

Path loss path name

Use this drop-down list to select the path loss path name that you want to be assigned to the currently selected test plan.

You can select any path name in the currently selected path loss file. The currently selected path loss file can be changed using the Path loss values group on the Change Configuration tab.


Global parameters source selection (Set Global Parameters Tab)

The items in this group allow you to assign identical global parameter values between different test plans.

Click on an item below to get more details:

  • Copy from test plan

  • From Test Plan

  • Reset Defaults

Copy from test plan

Use this drop-down list to select the test plan that you want to copy the global parameters values from.

After you have selected a test plan from this list, clicking the From Test Plan button changes the global parameter values of the current test plan to those of the test plan you have selected in the Copy from test plan drop-down list.

If the same test plan is selected in the Current test plan and Copy from test plan drop-down lists, no changes are made to the global parameter values when the From Test Plan button is pressed.

From Test Plan

Use the From Test Plan button to change the global parameter values of the current test plan to those of the test plan you have selected in the Copy from test plan: drop-down list.

Reset Defaults

Use the Reset Defaults button to set the global parameters of the current test plan (that is, the one selected in the Current test plan drop-down list) to the default global parameter values.


Global parameters for test plan (Set Global Parameters Tab)

This table displays the global parameters for the currently selected test plan.

A global parameter is different from a parameter which is assigned to a specific step. A step parameter only affects the individual step to which it is assigned, whereas a global parameter affects all steps within a test plan. Each test plan can have it's own set of global parameter values.

The name of each global parameter is displayed along with its current value. To change a global parameter value, click the global parameter you want to change and type or select a new value.

If you type a value which is outside the valid range of the global parameter, an Incorrect Parameter Data message is displayed ,showing the allowable range of values (example:).

Close the message box and type a valid value.


Change Configuration Tab

The Change Configuration tab provides controls which allow you to change settings for the Wireless Test Manager.

For more information, choose a topic below:

  • Select a configuration type to change

  • Bar code reader control

  • Data collection

  • Display Control

  • DUT control

  • Fixture control

  • Instrument control

  • Path loss values

  • Printer Control

  • Run test conditions

  • System IO ports

  • Test plan attributes database

  • Test plan start and end control

  • Viewable Features Selection


Select a Configuration Type to Change (Change Configuration tab)

Use this box to select a configuration type that you want to change. Once you select a configuration type, the settings that you can change are displayed to the right of this box.

When the Wireless Test Manager is In Operator mode, the configuration types that are available for you to change are determined by the Administrator. See Viewable Features Selection.


Bar Code Reader Control (Change_Configuration_Tab)

The items in this group allow you to configure a bar code reader. Click on an item below to get more details:

  • Bar code model

  • Baud rate

  • Handshaking control

  • Parity

  • Number of data bits

  • Stop bits

  • Data terminal ready

  • Request to send

  • Test communication

Bar code model

Use this drop-down list to select whether or not you want to configure a bar code reader (RS-232 or None).

When you select RS-232, additional controls are displayed to help you configure your bar code reader. In addition, the bar code reader icon [image] is displayed on the toolbar to show that a bar code reader has been selected.

Baud rate

Use this drop-down list to select the serial IO baud rate (that is, the time to transfer data) for the bar code reader.

Handshaking control

Use this drop-down list to select the type of Handshaking control for your bar code reader (None, Xon/Xoff, RTS,or RTSXon/Xoff).

Parity

Use this drop-down list to select the Parity (that is, the error checking method) for your bar code reader (Even, Mark, None, Odd, or Space).

The Rocket 9870-3 multi-port serial adapter does not support Parity settings of Mark or Space.

Number of data bits

Use this drop-down list to select the number of data bits for each character of your bar code reader (7 or 8).

Stop bits

Use this drop-down list to select the Serial IO stop bits for your bar code reader (1 or 2).

Data terminal ready

Use this drop-down list to enable or disable the data terminal.

Request to send

Use this drop-down list to enable or disable the Request To Send (RTS) message.

An RTS message is a signal sent (for example, from your computer to the bar code reader) to request permission to transmit.

Test communication

Use this to test the communication between your bar code reader and the Wireless Test Manager.

The Bar code information received box displays any data returned from your bar code reader.


Data Collection (Change Configuration Tab)

The items in this group allow you to change settings for calculating yield and saving test plan results. Click on an item below to get more details:

  • Calculate yield over last

  • Save results to a file

  • Results file type

  • Output unicode file

  • Keep data from aborted tests

  • Keep only failed test plans

  • Primary data collection path

  • Secondary data collection path

Calculate yield over last

Use the Units box to set the number of units over which the yield is calculated. After the number of units you set is reached, a running yield is calculated over the last N units.

Use the Reset Calculation button to reset the yield calculation.

Save results to a file

Use this check box to select whether or not to save your results to a file.

If selected, additional controls are displayed which allow you to configure the file type and specify the file location. In addition, the data collection icon [image] is displayed on the toolbar to show that you have selected to save results to a file.

Results file type

Use this drop-down list to select the file type for saving your results (XML, Comma Separated text file, Tab Separated text file, or Reduced/Graphical CSV).

Output unicode file

Use this check box to select whether or not the results are to be output in a unicode text file format.

Keep data from aborted tests

Use this check box to select whether or not to save data from tests which are aborted.

Keep only failed test plans

Use this check box to select whether or not to save results from only failed test plans. If this box is checked, results from test plans which pass are not saved.

Primary data collection path

Use to select the primary drive and folder in which you want to save the results file. The drive or folder you select appears below in the text box.

Secondary data collection path

Use to select the secondary drive and folder in which you want to save the results file if the primary drive or folder can not be found. The drive and folder you select appears below in the text box.

Related Topic: Interpreting Test Results


Display control (Change Configuration Tab)

The items in this group allow you to change the type of information which is displayed along with test results. Click on an item below to get more details:

  • Display measured values

  • Display upper and lower test limits

  • Display failed results only

  • Display last result when measured

Display measured values

Use this check box to select whether or not measured values are displayed as part of the test results.

Display upper and lower test limits

Use this check box to select whether or not upper and lower test limits are displayed as part of the test results.

Display failed results only

Use this check box to select whether or not only failed results are displayed.

Select this check box to display only failed results as part of the test results. Results of steps which have passed are not shown.

Displaying only failed results reduces the time it takes for a test plan to run.

Display last result when measured

Use this check box to select whether or not to display the most recent test result in real time as it is being measured.

When selected, the contents of the test results window are continually refreshed while the test plan is running so that the most recent result is displayed at the bottom of the window.

Tip: You should clear this check box when running test plans on the production line as it reduces the time it takes for a test plan to run.

Related Topic: Interpreting Test Results


DUT Control (Change Configuration Tab)

The items in this group allow you to set up communication settings for the device under test (DUT), but not the commands to control it. The developer can do this in the Visual Studio® development environment. If you want more details, see the help system available in the development environment. Click on an item below to get more details on the communication settings:

  • Baud rate

  • Handshaking control

  • Parity

  • Number of data bits

  • Stop bits

  • Data terminal ready

  • Request to send

  • Receive termination

  • Transmit termination

  • Test communication

Baud rate

Use this drop-down list to select the serial IO baud rate (that is, the time to transfer data) for the device under test.

Handshaking control

Use this drop-down list to select the type of Handshaking control for the device under test (None, Xon/Xoff, RTS,or RTSXon/Xoff).

Parity

Use this drop-down list to select the Parity (that is, the error checking method) for the device under test (Even, Mark, None, Odd, or Space).

The Rocket 9870-3 multi-port serial adapter does not support Parity settings of Mark or Space.

Number of data bits

Use this drop-down list to select the number of data bits for each character of the device under test (4, 5, 6, 7, or 8).

Stop bits

Use this drop-down list to select the Serial IO stop bits for the device under test (1 or 2).

Data terminal ready

Use this drop-down list to enable or disable your data terminal.

Request to send

Use this drop-down list to enable or disable the Request To Send (RTS) message.

An RTS message is a signal sent (for example, from your computer to the DUT) to request permission to transmit.

Receive termination

Use this drop-down list to select the type of receive termination.

Transmit termination

Use this drop-down list to select the type of transmit termination.

Test communication

Use this to test the communication between your DUT and the Wireless Test Manager.

Press the Receive button to get information from the device under test. Press the Send button to push information to the device under test.

Related Topic: Handshaking


Fixture Control (Change Configuration Tab)

The items in this group allow you to set up the communication between the Wireless Test Manager and the fixture(s) you are using. Different items are displayed in this group depending on the model of fixture you select in the Fixture model drop-down list box.

Click on an item below to get more details:

  • Fixture model

  • Multi-fixture testing

  • Automatically multiplex fixtures

  • Close/Open/Engage/Disengage (only displayed when the N4049A (TC-5942B) fixture is selected)

  • Close/Open/Status/Engage/Disengage (only displayed when the RS-232 fixture is selected)

  • Baud rate

  • Handshaking control

  • Parity

  • Number of data bits

  • Stop bits

  • Data terminal ready

  • Request to send

Fixture model

Use this drop-down list to select the type of fixture that you are using (None, TC-5942B/52B, RS-232, or Manual).

The selection you make determines the controls which are displayed.

Multi-fixture testing

Use this check box to turn On (selected) or Off (cleared) multi-fixture testing.

When selected, you can configure and use two fixtures for each system containing a test set.

Automatically multiplex fixtures

Use this check box to turn On (selected) or Off (cleared) automatic multiplexing of fixtures.

This means that the test plan's focus automatically alternates between fixtures.
This check box is only displayed if Multi-fixture testing is selected.

Close/Open/Engage/Disengage

These tabs are only displayed when the N4049A (TC-5942B) fixture is selected. See Close/Open/Engage/Disengage.

Close/Open/Status/Engage/Disengage

These tabs are only displayed when the RS-232 fixture is selected. See Close/Open/Status/Engage/Disengage.

Baud rate

Use this drop-down list to select the serial IO baud rate (that is, the time to transfer data) for the RS-232 fixture.

Handshaking control

Use this drop-down list to select the type of Handshaking control for your RS-232 fixture (None, Xon/Xoff, RTS,or RTSXon/Xoff).

Parity

Use this drop-down list to select the Parity (that is, the error checking method) for your RS-232 fixture (Even, Mark, None, Odd, or Space).

The Rocket 9870-3 multi-port serial adapter does not support Parity settings of Mark or Space.

Number of data bits

Use this drop-down list to select the number of data bits for each character of your RS-232 fixture (7 or 8).

Stop bits

Use this drop-down list to select the Serial IO stop bits for your RS-232 fixture (1 or 2).

Data terminal ready

Use this drop-down list to enable or disable the data terminal.

Request to send

Use this drop-down list to enable or disable the Request To Send (RTS) message.

An RTS message is a signal sent (for example, from your computer to the fixture) to request permission to transmit.

Related Topic: Setting Up a Software Controllable Fixture


Instrument Control (Change Configuration Tab)

The items in this group allow you to specify instrument settings.

Click on an item to get more details:

  • Interface Types

  • Address Settings

  • Find Instruments

  • Wireless Test Set

  • 663NNX PS

  • *IDN?

  • LAN…

  • USB…

  • ASRL…

Additional user interface items for other instruments may be displayed below, or to the right of the Wireless Test Set address box. (Up to a maximum of nine instruments.) These additional items are displayed if the developer has added the additional instruments during the software development process.

Interface Types

Use this to switch from Address Settings to Interface Types for specifying the communication method for any instruments currently connected (GPIB, LAN, USB, or ASRL).

Address Settings

Use this to switch from Interface Types to Address Settings for specifying the GPIB address, LAN configuration, USB configuration, or ASRL configuration of any instruments currently connected.

Find Instruments

Use this to search for available GPIB ports and any instruments which are currently connected to them.

Wireless Test Set

Use this to select the address of the Agilent Wireless Communications Test Set.

663NNX PS

Use this to select the address of the Agilent 66319B or 66321B mobile communications DC source (power supply).

If no power supply is available, you should set this to None.

*IDN?

Use this to send a *IDN? query to the test set. The *IDN? results are displayed in the *IDN? results box.

LAN…

Opens a dialog box that allows the user to specify the LAN connection configuration for the instrument that is associated with this button.

USB…

Opens a dialog box that allows the user to specify the USB connection configuration for the instrument that is associated with this button.

ASRL…

Opens a dialog box that allows the user to specify the ASRL (asynchronous serial/RS-232) connection configuration for the instrument that is associated with this button.


Path loss values (Change Configuration Tab)

The items in this group allow you to configure path loss values. Each file shown in the file system in the left window is directly accessible in the right window. Click on the blank table entries at the end of the list, (New Frequency) and (New Path Gain) will appear. Clicking in either box will clear the title, and a value may be entered. Note that a loss is entered as a negative gain value.

Click on an item to get more details:

  • Current path loss path

  • Select Path Loss File

Current path loss path

This text box displays the directory path to the currently selected path loss file. If you want to select a different path loss file, click the Select Path Loss File button.

Select Path Loss File

Use this to change the currently selected path loss file (.xml).

Related Topic: Setting up RF Path Loss Values


Printer Control (Change Configuration Tab)

The items in this group allow you to configure the printer. Click on an item to get more details:

  • Print test results

  • Default Printer

  • Printer Type

  • Print measured values

  • Print upper and lower test limits

  • Print failed results conditions

  • Print in localized language

Print test results

Use this check box to turn On (selected) or Off (cleared) the printing of test results. When selected, the printer icon [image] is displayed on the toolbar to show that a printer has been selected.

If Print Test Results is selected, each test plan will print a header and summary of tests unless the Print failed test plans only is also selected, in which case nothing is printed for a passed test plan.

If you have not set up a printer on your computer, this check box is unavailable. To set up a printer, click the Start button, point to Settings, and then point to Printers. When the Printers window opens, double-click Add Printer. This opens the Add Printer Wizard which provides on-screen instructions for you to follow.

Default Printer

This gives a choice of printers that have been installed in the Microsoft Windows® system on the PC running Wireless Test Manager.

Printer properties must be set in the Windows environment; Wireless Test Manager does not provide access to these controls. These can be changed while WTM is running and will be effective immediately.

Printer Type

Use this drop-down list to select the printer type; either 80 Characters-per-line or 40 Characters-per-line.

If you select 40 characters-per-line, the Print measured values, Print upper and lower test limits, and Print failed results only check boxes are unavailable.

Print measured values

Use this check box to turn the printing of measured values On (selected) or Off (cleared). This is only available if Printer Type 80 Characters is selected.

Print upper and lower test limits

Use this check box to turn the printing of upper and lower test limits On (selected) or Off (cleared). This is only available if Printer Type 80 Characters is selected.

Print failed results conditions

Use this check box to select whether or not you want to print just those results which have failed (selected) or all results (cleared).

If selected, and the Printer Type is 80 Characters, three more choices become available; one and only one must be selected:

  • Print failed test plans only - Any failure in a test plan will cause the results for the entire test plan to be printed.

  • Print failed test results only - Only those specifications that fail in a test plan step are printed.

  • Print failed test results with test conditions - Comments are added that better describe the test conditions along with the failed test results. Only the comments that are relevant to the failed test specification are printed.

If selected and the Printer Type is 40 Characters, there are two print options; one and only one must be selected:

  • Print failed test plans only - Any failure in a test plan will cause the results for failed specifications to be printed. Nothing is printed for test plans that pass.

  • Print failed test results only - For test plans with any specification failures, the printout will be identical to the prior option. A test plan that passes will print test conditions and summary.

Print in localized language

Use this check box to select whether you want to print the test results in the localized language (selected) or English (cleared). There is special treatment of PASS and FAIL. The examples below show the English version of these.

  • Item 13098 in the *.lng file is a null which replaces PASS in the print results independent of whether localization is selected or not. This is done to make the printed results easier to interpret as only failed points get flagged.

  • Item 13098 in the *.lng file is the PASS indication (in English) and is used only for display on screen.

  • Item 13100 in the *.lng file is the FAIL indication (in English) and is always used for the screen. If localization is selected, it will be used for the printer, as well.

These items numbers in alternative *.lng files will have the same behavior as shown here with PASS and FAIL replaced with the localized equivalents.


Run Test Conditions (Change Configuration Tab)

The items in this group allow you to change the way a test plan runs. Click on an item to get more details:

  • Single step

  • Pause testing on failure

  • Debug mode enabled

  • Demo mode

  • Terminate on failures

  • Repeat test plan

Single step

Use this check box to turn On (selected) or Off (cleared) the single step feature. This feature allows you to run the test plan, pausing the test plan after each test plan step. The next step is only run after you click the Next Result button on the Single Step Testing dialog box.

Pause testing on failure

Use this check box to turn On (selected) or Off (cleared) the Pause Testing on Failure feature. If a failure occurs during the testing, a dialog box opens and the testing pauses. There are three choices when this happens:

Next Result: Continue with the test plan, but pause again if another failure occurs.

Go To End of Test: The test plan resumes, but it will not pause at any new failure.

Abort Testing: The test plan is aborted.

Debug mode enabled

Use this check box to enable (selected) or disable (cleared) Debug mode. Debug mode provides additional information while a test plan is running. This is useful during test development or while you are trying to troubleshoot a problem.

Debug mode should not be used once your test code is stable, or when you are running test plans on the production line. The additional information that this mode generates may slow down your test times.

Demo mode

Use this check box to turn On (selected) or Off (cleared) the demonstration mode. Demonstration mode allows you to run the Wireless Test Manager without any connections between your computer and supported instruments.

When the Wireless Test Manager is installed, demonstration mode is selected by default.

Terminate on failures

Use this check box to select whether or not the test plan aborts after the previous test plan steps have greater than the number of failures you specify in the Failures edit box. The maximum value you can enter in the Failures edit box is 32767.

Example:

For the purposes of this example, assume that Terminate on failures is selected and Failures is set to 3.

Test Plan Step A incorporates 5 measurements, and Test Plan Step B incorporates 4 measurements. While the test plan is running, the first 3 measurements in Test Plan Step A fail. The test plan continues to run and show results for all measurements within Test Plan Step A. However, when Test Plan Step A completes, testing aborts.

Test Plan B does not run. Therefore, no measurement results are available for any measurements within Test Plan Step B.

Repeat test plan

Use this check box to select whether or not to repeat a test plan. You can specify the number of times you want to repeat the test plan using the Times edit box (maximum value = 32767).

Related Topic: Running a Test Plan.


System IO Ports (Change Configuration Tab)

The items in this group allow you to configure the system IO ports. Click on an item to get more details:

  • Multi-system testing

  • GPIB/Bar Code Reader/DUT Phone Control/Digital IO/Fixture 1/Fixture 2/WTM LAN Control

Multi-system testing

Use this text box to turn On (selected) or Off (cleared) Multi-system testing.

When using the E6570C Wireless Test Manager Extended Capability, this control is a drop-down list allowing you to select up to eight test systems.

When multiple instances of the Wireless Test Manager are currently running, the configuration settings are saved from the last instance that is closed down.

GPIB/Bar Code Reader/DUT Phone Control/Digital IO/Fixture 1/Fixture 2/WTM LAN Control

See the topic GPIB/Bar Code Reader/DUT Phone Control/Digital IO/Fixture 1/Fixture 2/WTM LAN Control.

Related Topic: Testing with Multi-systems


Test Plan Attributes Database (Change Configuration Tab)

Test Plan Attributes Database

The Wireless Test Manager and the Wireless Test Wizard use a Microsoft® Access® database file format (.mdb) to store information about your test plans, test plan steps, specifications, parameters and global parameters.

Although it is possible to open and view the database file using a database application such as Microsoft Access®, you must not make any changes to the database structure in this way. Otherwise, the database may not work correctly with the Wireless Test Manager. The recommended way to make changes to the database is to use the Wireless Test Wizard. The Wireless Test Wizard automatically updates the database (while maintaining the correct structure), to implement any changes you specify.

The testing options that are available to you within the Wireless Test Manager are determined by the currently selected database.

The items in this group provide information about the currently selected database, and allow you to select a different database if you want to.

Click on an item to get more details:

  • Current database path

  • Current database name

  • Current database revision

  • Open database

Current database path

This text box displays the directory path to the currently selected database. If you want to select a different database, click the Open Database button.

By default, the test plan attributes database is stored in the "...\WirelessTestManager\E6560C\TestData\" folder within the target installation folder.

Current database name

This text box displays the name of the currently selected database.

Current database revision

This text box displays the revision of the currently selected database.

Open database

Use this to change the currently selected database.

When the Open Database button is clicked, the File Open dialog box opens, allowing you to select a different database.


Test Plan Start and End Control (Change Configuration Tab)

The items in this group allow you to configure the events that occur either before a test plan starts or after it has finished. Click on an item to get more details:

  • Start test plan when bar code information received

  • Start test plan from 8960 front panel

  • Start test plan when fixture is closed

  • Return to view test conditions at end of test plan

  • Open fixture at end of test plan

  • Disengage DUT at end of test plan

  • Open fixture if test plan aborts

  • Disengage DUT if test plan aborts

Start test plan when bar code information received

Use this check box to specify whether or not the test plan starts automatically as soon as the bar code number has been received from the bar code reader.

Start test plan from 8960 front panel

Use this check box to specify whether or not you start the test plan by pressing a key on the front panel of the 8960 test set. If selected, the graphic on the Run Test Plan button changes to indicate that this selection has been made.

Start test plan when fixture is closed

Use this check box to specify whether or not the test plan starts automatically as soon as the fixture holding the device under test is closed.

If this box is selected, Open fixture at end of test plan must also be checked to avoid an infinite looping condition.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Return to view test conditions at end of test plan

Use this check box to specify whether or not the results remain displayed after the test plan has finished.

Selecting this check box closes the results display grid after the test plan has finished.

Clearing this check box ensures that the results remain displayed after the test plan has finished.

Open fixture at end of test plan

Use this check box to specify whether or not the fixture opens automatically after the test plan is complete.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Disengage DUT at end of test plan

Use this check box to specify whether or not the device under test is disengaged automatically after the test plan is complete.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Open fixture if test plan aborts

Use this check box to specify whether or not the fixture opens automatically if the test plan aborts.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Disengage DUT if test plan aborts

Use this check box to specify whether or not the device under test is disengaged automatically if the test plan aborts.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.


Viewable Features Selection (Change Configuration Tab)

The items in this group allow the administrator to define which features are visible in Operator mode. Click on an item to get more details:

  • Define Test Plan tab item

  • Set Specs/Parameters tab items

  • Set Global Parameters tab item

  • Change Configuration tab items

  • Change Password

  • Show localization numbers

Define Test Plan tab item

Use this check box to select whether or not the Define Test Plan tab is visible in the Operator mode user interface.

Set Specs/Parameters tab items

Use these check boxes to select whether or not the Specifications and Parameters items are displayed on the Set Specs/Parameters tab in the Operator mode user interface.

Set Global Parameters tab item

Use this check box to select whether or not the Set Global Parameters tab is displayed in the Operator mode user interface.

Change Configuration tab items

Use these check boxes to select the items you want to be displayed on the Change Configuration tab in the Operator mode user interface.

Change Password

Use to set a new password for access to the Administrator mode User Interface.

Show localization numbers

Use this check box to select whether or not the localization numbers are displayed on the Wireless Test Manager graphical user interface (GUI) alongside the text labels.

This feature is useful if you are localizing the Wireless test Manager GUI, and want to identify the number in the localization file (.lng) that corresponds to a particular text label.


Test Plan Steps

Description

A test plan step is a single component which you can add to a test plan. Each test plan step performs a single task or related group of tasks. For example, a test plan step may establish a call, change a channel, make a measurement, or perform a looping function. The developer can even create their own steps which can then be added to test plans.

Accessing Test Plan Steps

To view the available test plan steps in the Wireless Test Manager, select the Define Test Plan tab.

The Define test plan group box displays the Available steps and Current test plan steps for the test plan displayed in the Current test plan field. Click on the example graphic link below (available steps are highlighted in yellow).

To view all available steps, select All Tests using the drop-down combo box in the Available Steps filter window. Click on the example graphic link below (the Available Steps filter window is highlighted in cyan).

To select an available step and assign it to the current test plan, double-click the step or single click the step and drag-and-drop to the Current test plan steps window. For more information, see Adding a Step to a Test Plan.

Click here for an example graphic of the Wireless Test Manager window.

For more information, choose a book or topic below

  • Generic Steps

    • Add Test Comments

    • Bluetooth Config Device Under Test

    • Bluetooth Config N4010A

    • Bluetooth Disconnect Device Under Test

    • Bluetooth DUT Enter Test Mode

    • BT Clear Sequence

    • BT Run Sequence

    • Dispose WLAN Driver

    • End Loop

    • End Test Plan

    • Preset N4010A

    • Start Loop

    • Switch to WTM Control

  • Bluetooth

    • BT Setup Output Power

    • BT Setup Power Control

    • BT Setup Carrier Freq Drift

    • BT Setup Initial Carrier Frequency Tolerance

    • BT Setup Modulation Characteristics

    • BT Setup Single Slot Sensitivity

    • BT Setup Multi Slot Sensitivity

    • BT Setup Maximum Input Level

    • BT EDR Setup Relative Power

    • BT EDR Setup Carrier Freq Stab Mod Accuracy

    • BT EDR Setup Differential Phase Encoding

    • BT EDR Setup Guard Interval

    • BT EDR Setup Sensitivity

    • BT EDR Setup BER Floor Performance

    • BT EDR Setup Max Input Level

    • BT Fetch Output Power Results

    • BT Fetch Power Control Results

    • BT Fetch Carrier Freq Drift Results

    • BT Fetch Initial Carrier Freq Tolerance Results

    • BT Fetch Modulation Characteristics Results

    • BT Fetch Single Slot Sensitivity Results

    • BT Fetch Multi Slot Sensitivity Results

    • BT Fetch Maximum Input Level Results

    • BT EDR Fetch Relative Power Results

    • BT EDR Fetch Carrier Freq Stability Results

    • BT EDR Fetch Diff Phase Encoding Results

    • BT EDR Fetch Guard Interval Results

    • BT EDR Fetch Sensitivity Results

    • BT EDR Fetch BER Floor Performance Results

    • BT EDR Fetch Max Input Level Results

  • Wireless LAN

    • Demod A/G (OFDM) Measurements

    • Demod B (DSSS) Measurements

    • Transmitter Spectral Flatness (OFDM) Measurement

    • Transmitter Spectral Mask (OFDM/DSSS) Measurement

    • Transmitter Power Up Power Down Ramp (DSSS) Measurement

    • Receiver PER (OFDM/DSSS) Measurement


Add Test Comments

Description

The Add Test Comments test plan step allows you to add comments at any position in your test plan. This is useful if you want to provide additional information before a test plan step runs to explain why it has been included in your testing.

You can define up to four comments each of which can be a maximum of 50 characters long.

Specifications

None

Parameters

  • Comment 1

  • Comment 2

  • Comment 3

  • Comment 4


Comment 1

Description

The Comment 1 parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan. You can type a comment up to a maximum of 50 characters. If you leave the parameter value blank (null), no comment is printed.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: String 1

To change the default value, select it and enter the value you want.


Comment 2

Description

The Comment 2 parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan. You can type a comment up to a maximum of 50 characters. If you leave the parameter value blank (null), no comment is printed.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: String 2

To change the default value, select it and enter the value you want.


Comment 3

Description

The Comment 3 parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan. You can type a comment up to a maximum of 50 characters. If you leave the parameter value blank (null), no comment is printed.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: String 3

To change the default value, select it and enter the value you want.


Comment 4

Description

The Comment 4 parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan. You can type a comment up to a maximum of 50 characters. If you leave the parameter value blank (null), no comment is printed.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: String 4

To change the default value, select it and enter the value you want.


Bluetooth Config Device Under Test Description

Description

Configures Device Under Test for Bluetooth Measurements.

Parameters

Local

Parameter | Range | Default/ Compliance
BT Initiate Authentication | ON or OFF | OFF
BT Page Scan Repetition Mode | R1, R2 or R3 | R1
BT PIN | 4 digit numeric number | 0000
BT Power Class | 1, 2 or 3 | 2
BT Power Control Mode | NONE | INCR | DECR | MINimum | MAXimum | MAXimum
BT Power Control Step | 1 to 10 | 1
BT Require Encryption | ON or OFF | OFF
LinkInq Duration | 1.28 seconds to 61.44 seconds | 12.8 s


Bluetooth Config N4010A Description

Description

Configures Global Parameters for N4010A to allow for Bluetooth testing.

Parameters

Local

Parameter | Range | Default/ Compliance
Rx Power Level (dBm) | -70 to 25 | 25
Tx Power Level (dBm) | -95 to 0 | -40

Global Parameters (Refer to Alphabetic Listing of Global And Test Parameters for more details)

  • BT Activate Delay

  • BT Command Delay

  • BT Exit TestMode Before Disconnect

  • BT Frequency Reference

  • BT Loss Compensation

  • BT STE BDAddress


Bluetooth Disconnect Device Under Test Description

Description

disconnects the Bluetooth Device Under Test cleanly, closing the connection between the Device Under test and the N4010A.

Parameters

None

Specifications/Results

None


Bluetooth DUT Enter Test Mode Description

Description

Places Bluetooth Device into testmode. Supports UART devices and CSR USB Devices, if applicable drivers have been installed.

Parameters

Local

Parameter | Range | Default/ Compliance
BT DUT Name | String represnting device name | COM1
BT DUT Protocol | String representing Device Protocol | H4
BT DUT Speed | Speed of device transport | 115200
BT DUT Transport | String representing device transport | UART


Bluetooth Clear Sequence

Use this test step to clear the sequence of measurements in the N4010A, should be called at the start of each test plan to ensure an empty sequence before test steps are added.

Parameters

None

Specifications/Results

None


Bluetooth Run Sequence

Use this test step to run the sequence of measurements in the N4010A, has to be called after any setup test steps and before any fetch test steps.

Parameters

None

Specifications/Results

None


Dispose WLAN Driver

Disposes the Wireless LAN Driver object, which clears the session lock on the N4010A. This has to be called if Bluetooth tests are called in the same test plan as Wireless LAN tests.

Parameters

None

Specifications/Results

None


End Loop

Description

The End Loop test plan step specifies the end of a looping structure in the test plan. It is one half of the matched pair 'Start Loop' and 'End Loop' which define the start and end of a looping structure. Steps that fall between a 'Start Loop' and 'End Loop' test plan step pair are looped through using the looping parameters specified in the 'Start Loop' test plan step.

Specifications:

None

Parameters:

None


End Test Plan

Description

The End Test Plan test plan step can be added at any point in the test plan, however it is intended to be used at the end of an on fail sequence.

By setting the Always Fail Test Plan parameter to yes, your test plan will always fail. This means that even if all test steps pass, the overall test plan will fail.

Specifications

None.

Parameters

  • Always Fail Test Plan


Always Fail Test Plan

Description

The Always Fail Test Plan parameter allows you to select whether or not your overall test plan fails if any of the fail steps are entered in to.

Accessing Parameter Name (s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

The following values are available from the drop-down list in the Value column in the Parameters for test plan step group box:

  • No

  • Yes

Default Value

The default value for this parameter is: Yes

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.

Data Range

The value you enter must be in the following range: No or Yes


Finish WTM Control

Unlocks the front panel of the N4010A, removing WTM Control message.

Parameters

None

Specifications/Results

None


Preset N4010A

Description

This command resets the instrument to factory defaults


Start Loop

Description

The Start Loop test plan step specifies the start of a looping structure in the test plan. It is one half of the matched pair 'Start Loop' and 'End Loop' which define the start and end of a looping structure. Test steps that fall between a 'Start Loop' and 'End Loop' test step pair are looped through tests using the loop parameters specified in this test step. The software comes with five looping parameters while new looping parameters can be defined by the developer.

Specifications

None.

Parameters

  • Loop Parameter

  • Loop Separated Sequence

  • Loop Start

  • Loop Step

  • Loop Stop

  • BT EUT Channel TxRx Pair

  • WLAN Band/Freq

  • WLAN DUT Data Rate


Loop Parameter

Description

The following choices are available for Loop Parameter:

  • Channel Number

  • MS TX Level

  • MS TX Level Pair Index

  • Timing Advance

  • Repeat Steps

The selected loop parameter choice is set to values defined in the Loop Separated Sequence (unless it is empty) and the Loop Start, Loop Step, and Loop Stop values (unless they are empty). Use either or both to define the looping values. All of the values in the Loop Separated Sequence are used first and the Loop Start, Loop Step, and Loop Stop values are used second.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

The following values are available from the drop-down list in the Value column in the Parameters for test plan step group box:

  • Channel Number

  • MS TX Level

  • MS TX Level Pair Index

  • Timing Advance

  • Repeat Steps

Default Value

The default value for this parameter is: Channel Number

To change the default value, select it and enter the value you want.


Loop Separated Sequence

Description

The Loop Separated Sequence parameter is a comma separated list of values or strings corresponding to the loop parameter setting on each successive iteration of the loop. This can be set to an empty list or used in conjunction with the Loop Start, Loop Step, and Loop Stop parameters to define what the loop parameter is to be set to. The values in this list (unless it is empty) are always used first to define the looping values.

The syntax of Loop Separated Sequence can be a comma separated list of values or string value which is described as follows: <num value>|[, <num value>] |... |{[, <start num value>] | [to <stop num value>] | [step <step num value>]}. The followings are the examples

  • The parameter can be 1, 2, 3.

  • The parameter can also be the string sequence: 1, 2 to 6 step 2, 7 to 10. It tests 1, 2, 4, 6, 7, 8, 9, 10. The string sequence " 2 to 6" shows the sequence range while the " step 2" tells the value step between 2 and 6. The parenthesis can be used to make it more readable like the following: 1, (2 to 6) step 2, 7 to 10. The default value for step is 1.

Note: In this case, the stop point will not be tested if stop value is not equal to <start num value> + N *<step num value>. For example, 1 to 6 step 2, 6 will not be tested.

Every value, comma and string you enter in the Loop Separated Sequence parameter is stored as a text character. A maximum of 50 characters can be used.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 1, 2

To change the default value, select it and enter the value you want.

Additional Information

Channel Number

Channel Number specifies that the looping structure loops on channel numbers (valid value range = 0 to 1023).

MS TX Level

MS TX Level specifics that the looping structure loops on the wireless device uplink power control level (valid value range = 0 to 31)

Timing Advance

Time Advance specifics that the looping structure loops on the wireless device station's uplink traffic Channel timing advance.(valid value range = 0 to 63)

Examples

  1. To set up a channel looping structure to loop on level 0, 1, 2, 3, 5, 7, 11, 13, 15, 17, 19, 21, 23, 25, 27, 29, 31:

    Parameter Name

    Value

    Loop Parameter

    MS TX Level

    Loop Separated Sequence

    0, 1, 2

    Loop Start

    3

    Loop Step

    2

    Loop Stop

    31


Loop Start

Description

The Loop Start parameter is the single value defining the initial value that the loop parameter is to be set to when the Loop Start...Loop Stop looping is started. The Loop Start value can be empty; if it is, the Loop Step and Loop Stop values must also be empty.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 1

To change the default value, select it and enter the value you want.

Additional Information

Channel Number

Channel Number specifies that the looping structure loops on channel numbers (valid value range = 0 to 1023).

MS TX Level

MS TX Level specifics that the looping structure loops on the wireless device uplink power control level (valid value range = 0 to 31)

Timing Advance

Time Advance specifics that the looping structure loops on the wireless device station's uplink traffic Channel timing advance.(valid value range = 0 to 63)

Examples

  1. To set up a channel looping structure to loop on level 0, 1, 2, 3, 5, 7, 11, 13, 15, 17, 19, 21, 23, 25, 27, 29, 31:

    Parameter Name

    Value

    Loop Parameter

    MS TX Level

    Loop Separated Sequence

    0, 1, 2

    Loop Start

    3

    Loop Step

    2

    Loop Stop

    31


Loop Step

Description

The Loop Step parameter is the single value defining the step size that the loop structure uses to define the next value. The Loop Step value can be empty; if it is, the Loop Start and Loop Stop values must also be empty.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 1

To change the default value, select it and enter the value you want.

Additional Information

Channel Number

Channel Number specifies that the looping structure loops on channel numbers (valid value range = 0 to 1023).

MS TX Level

MS TX Level specifics that the looping structure loops on the wireless device uplink power control level (valid value range = 0 to 31)

Timing Advance

Time Advance specifics that the looping structure loops on the wireless device station's uplink traffic Channel timing advance.(valid value range = 0 to 63)

Examples

  1. To set up a channel looping structure to loop on channels 100, 500, 1000, 1001, 1006, 1011, 1016, 1021:

Parameter Name | Value
Loop Parameter | Channel Number
Loop Separated Sequence | 100, 500, 1000
Loop Start | 1001
Loop Step | 5
Loop Stop | 1021


Loop Stop

Description

The Loop Stop parameter defines the value at the end of the loop. The Loop Stop value can be empty; if it is, the Loop Start and Loop Step values must also be empty. The Loop Stop value will always be tested even if it is not equal to <Loop Start Value> + N * <Loop Step value>

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 3

To change the default value, select it and enter the value you want.

Additional Information

Channel Number

Channel Number specifies that the looping structure loops on channel numbers (valid value range = 0 to 1023).

MS TX Level

MS TX Level specifics that the looping structure loops on the wireless device uplink power control level (valid value range = 0 to 31)

Timing Advance

Time Advance specifics that the looping structure loops on the wireless device station's uplink traffic Channel timing advance.(valid value range = 0 to 63)

Example

  1. To set up a channel looping structure to loop on channels 100, 500, 1000, 1001, 1006, 1011, 1016, 1021:

Parameter Name | Value
Loop Parameter | Channel Number
Loop Separated Sequence | 100, 500, 1000
Loop Start | 1001
Loop Step | 5
Loop Stop | 1021


Switch to WTM Control

locks the front panel of the N4010A, displaying a message indicating that the N4010A is under WTM Control.

Parameters

None

Specifications/Results

None


Output Power Test Description

Description

Sets up all parameters for Output Power Measurement. See Bluetooth Fetch Output Power Results for fetching of results.

Perform the Output Power Test to verify the maximum peak and average RF transmit power of the EUT. Regulations allow ISM band transmitters to emit up to 20 dBm (average) when spread spectrum techniques are used. Bluetooth uses frequency hopping to spread the spectrum. There are 3 EUT power classes defined within the Bluetooth specification. Each class of equipment must conform to the relevant specifications.

Power levels within specified limits are required to ensure interoperability and regulatory requirements.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 1
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the test with the EUT in loopback or transmitter test mode as required by the Bluetooth Test Specification.

Test Method:

The compliant output power test is performed with the EUT in loopback or transmitter test mode using the PRBS9 modulation pattern and the longest supported packets. Hopping is turned on (and data whitening off). The Test Set determines the position of p0 and calculates the average power over 20% to 80% of the burst and also records the peak power measured within the burst as described in the BT Test Specification TRM/CA/01/C.

No additional test equipment is needed.


Power Control Test Description

Description

Sets up all parameters for Power control Measurement. See Bluetooth Fetch Power Control Results for fetching of results.

Perform the Power Control Test to verify the correct operation of the EUT transmitter level control. There are 3 EUT power classes defined within the Bluetooth specification. Power control is a mandatory for Class 1 equipment and optional for Class 2 and 3 equipment.

Power control within specified limits is required to ensure interoperability and predictable power consumption for EUTs to be used in battery powered products.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 10
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH1
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the test with the EUT in loopback or transmitter test mode as required by the Bluetooth RF Test Specification.

Test Method:

The power control test is performed with the EUT in loopback or transmitter test mode using the PRBS9 modulation pattern in DH1 packets. Hopping is turned off. The Test Set uses Link Management Protocol (LMP) commands to control the EUT power levels as described in the BT Test Specification TRM/CA/03/C.

No additional test equipment is required.


bluetooth setup carrier frequency drift

Carrier Frequency Drift Rate Test

Description

Sets up all parameters for Carrier Frequency Drift Rate Measurement. See Bluetooth Fetch Carrier Frequency Drift Results for fetching of results.

Perform the Carrier Frequency Drift Test to verify the performance of the modulation circuitry and stability of the EUT voltage controlled oscillator (VCO). Due to the frequency hopping scheme, a Bluetooth transmitter must be capable of performing as many as 3200 hops per second but must also remain stable during the data transfer phase.

Carrier frequency drift performance within specified limits is required to ensure interoperability.

The EUT transmitter center frequency drift, and center frequency drift rate are measured with this test.

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the test in loopback or transmitter test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant frequency drift test is performed with the EUT in loopback or transmitter test mode using the BS55 modulation pattern of 0101 and DH1, DH3, and DH5 packets. Hopping is turned on and data whitening off. The Test Set compares 10 bit groups in the payload with 4 preamble bits over 10 packets and DH1/DH3/DH5 packet types as described in the BT Test Specification TRM/CA/09/C.

The Frequency Drift Rate is calculated by comparing the measured drift in each 10 bit group and comparing it with the measured drift in each of the 2 adjacent 10 bit groups. The largest difference is taken as the measurement result.

No additional test equipment is needed.

Specifications

  • None

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (Hz) | 1300000, 3000000, 5000000 | 1300000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 10
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH135
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | BS55
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off


Initial Carrier Frequency Tolerance Test Description

Initial Carrier Frequency Tolerance

Description

Sets up all parameters for Initial Carrier Frequency Tolerance Measurement. See Bluetooth Fetch Initial Carrier Freq Tolerance Results for fetching of results.

Perform the Initial Carrier Frequency Tolerance (ICFT) Test to verify the performance of the EUT voltage controlled oscillator (VCO) and phase locked loop (PLL). This is achieved by measuring the accuracy of the EUT transmitter center frequencies. Due to the frequency hopping scheme a Bluetooth transmitter must quickly and accurately establish the frequency of each of the 79 channels before data transfer begins.

ICFT performance within specified limits is required to ensure interoperability.

A consistent offset is observed in the results may be removed by fine tuning the EUT transmitter VCO reference oscillator frequency.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 1300000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 10
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH1
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test will be performed with the EUT in loopback or transmitter test mode as required by the Bluetooth Test Specification.

Test Method:

The compliant ICFT test is performed with the EUT in loopback or transmitter test mode using PRBS 9 modulation in DH1 packets. Hopping is turned on and Whitening turned off. The Test Set determines the carrier frequency from the 4 preamble bits plus 1st bit after the 4th preamble bit over 10 packets at low, mid, and high operating frequencies as described in the BT Test Specification TRM/CA/08/C.

No additional test equipment is needed.


Modulation Characteristics Test Description

Why Perform this Test?

Sets up all parameters for Modulation Characteristics Measurement. See Bluetooth Fetch Modulation Characteristics Results for fetching of results.

Perform the Modulation Characteristics Test to verify the performance of the modulation circuitry. Bluetooth uses gaussian frequency shift keying (GFSK) to transfer data at a rate of 1 Mb per second. A binary 1 causes a positive frequency shift while a binary 0 causes a negative shift.

The modulation depth and rate are chosen to minimize unwanted products within the Bluetooth channel spacing. The circuitry must be capable of generating the rate and depth of modulation required for a receiver to decode a 101010 pattern. However, it must not over-modulate when sending continuous blocks of 1 or 0 in the data, swamping the receiver.

Modulation performance within specified limits is required to ensure interoperability.

No additional test equipment is required.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 1300000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 10
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | BS0F55
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the test with the EUT in loop back or transmitter test mode as required by the Bluetooth Test Specification.

Test Method:

The compliant modulation characteristics test is performed with the EUT in loopback or transmitter test mode using the longest supported packet length. Hopping is turned on and data whitening off. The Test Set determines the Delta f1 modulation value using a 00001111 (BS0F) data payload and Delta f2 is determined using a 10101010 (BS55) payload as described in the Bluetooth Test Specification TRM/CA/07/C.

The EUT is required to transmit at maximum power level for this test.

No additional test equipment is needed.


Single Slot Sensitivity Test Description

Description

Sets up all parameters for Single Slot Sensitivity Measurement. See Bluetooth Fetch Single Slot Sensitivity Results for fetching of results.

Perform the Sensitivity Tests to verify the performance of the EUT receiver when presented with a non-ideal signal. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Parameters

Only loopback is available with a test mode connection.

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | On
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 10,000,000 | 1600128
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH1
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -70
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the sensitivity test with the EUT in loopback test mode as required by the Bluetooth Test Specification giving results for single (DH1) slot packets and multi (DH3, DH5) slot packets.

The sensitivity test is performed with the EUT in loopback test mode using PRBS 9 modulation pattern in DH1 packets for the single slot test, DH3 and DH5 packets for multi slot tests. Hopping is turned off. Dirty Transmitter impairments are applied. The Test Set measures the Bit Error Rate (BER) of the looped back data whilst transmitting at -70 dBm at the EUT input as described in the BT Test Specification RCV/CA/01/C and RCV/CA/02/C.

Parameters and Limits show settings required for compliance.

No additional test equipment is needed.


Multi Slot Sensitivity Test Description

Description

Sets up all parameters for Multi Slot Sensitivity Measurement. See Bluetooth Fetch Multi Slot Sensitivity Results for fetching of results.

Perform the Sensitivity Tests to verify the performance of the EUT receiver when presented with a non-ideal signal. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Parameters

Only loopback is available with a test mode connection.

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | On
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 10,000,000 | 1600080
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -70
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the sensitivity test with the EUT in loopback test mode as required by the Bluetooth Test Specification giving results for single (DH1) slot packets and multi (DH3, DH5) slot packets.

The sensitivity test is performed with the EUT in loopback test mode using PRBS 9 modulation pattern in DH1 packets for the single slot test, DH3 and DH5 packets for multi slot tests. Hopping is turned off. Dirty Transmitter impairments are applied. The Test Set measures the Bit Error Rate (BER) of the looped back data whilst transmitting at -70 dBm at the EUT input as described in the BT Test Specification RCV/CA/01/C and RCV/CA/02/C.

Parameters and Limits show settings required for compliance.

No additional test equipment is needed.


Maximum Input Level Test Description

Description

Sets up all parameters for Maximum Input Level Measurement. See Bluetooth Fetch Maximum Input Level Results for fetching of results.

Perform the Maximum Input Level Test to verify the performance of the EUT receiver at high input RF power levels. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low power levels but equally must also sustain communication when the input level is high due to a nearby transmitter emitting high power levels.

Maximum input level performance within specified limits is required to ensure interoperability.

Parameters

Only loopback is available with a test mode connection.

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | On
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | On
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 10,000,000 | 1600128
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | DH1
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -20
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the sensitivity test with the EUT in loopback test mode as required by the Bluetooth Test Specification giving results for single (DH1) slot packets and multi (DH3, DH5) slot packets.

The sensitivity test is performed with the EUT in loopback test mode using PRBS 9 modulation pattern in DH1 packets for the single slot test, DH3 and DH5 packets for multi slot tests. Hopping is turned off. Dirty Transmitter impairments are applied. The Test Set measures the Bit Error Rate (BER) of the looped back data whilst transmitting at -70 dBm at the EUT input as described in the BT Test Specification RCV/CA/01/C and RCV/CA/02/C.

Parameters and Limits show settings required for compliance.

No additional test equipment is needed.


EDR Relative Power Test Description

Description

Sets up all parameters for EDR Relative Power Measurement. See Bluetooth Fetch EDR Relative Power Results for fetching of results.

Perform the EDR Relative Power Test to verify the difference in average transmit power during frequency modulated [GFSK] and phase modulated [DPSK] portions of a packet.

Power levels within specified limits are required to ensure interoperability and regulatory requirements.

No additional test equipment is required.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 10
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The compliant EDR Relative Power test is performed with the EUT in loopback or transmitter test mode transmitting the longest supported p/4-DQPSK packet type (2-DHx) with maximum length payload containing PRBS9.

If 8DPSK modulation is supported by the same EUT, the test process is repeated using an additional test sequence while the EUT transmits the longest supported 8DPSK packet type (3-DHx) with maximum length payload containing PRBS9.

Hopping and data whitening are turned off.

The EUT transmits at maximum output power and the lowest operating TX frequency to the Test Set.

The Test Set calculates average power PGFSK over at least 80% of the GFSK portion (Access Code & Header period) of the packet and calculates the average power PDPSK over at least 80% of the DPSK portion of the packet (Synchronization sequence and payload)

This test is repeated while the EUT continues to transmit at the maximum output power in the mid operating frequency and the high operating frequency.

This test is repeated with the EUT transmitting minimum output power over the three operating frequencies.

This is described in the BT Test Specification TRM/CA/10/C.

No additional test equipment is required.


EDR Frequency Stability and Modulation Accuracy Test Description

Description

Sets up all parameters for EDR Frequency Stability and Modulation Accuracy Measurement. See Bluetooth EDR Fetch Carrier Freq Stability Results for fetching of results.

Perform the EDR Frequency Stability and Modulation Accuracy Test to verify the transmitter carrier frequency stability and modulation accuracy.

It tests, the clock's "crystal trim" accuracy by measuring the frequency error and the DEVM to measure the modulation accuracy.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Blocks | 1 to 50,000 | 200
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set can perform the test in loopback or transmitter test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant EDR Frequency Stability and Modulation Accuracy test is performed with the EUT in loopback or transmitter test mode transmitting the longest supported p/4-DQPSK packet type (2-DH1, 2-DH3 or 2-DH5). The payload bytes contain PRBS9 data. The number of payload bytes is 31 for 2-DH1 packets, 356 for 2-DH3 packets or 656 for 2-DH5 packets.

For 8DPSK modulation use the longest supported 8DPSK packet type (3-DH1, 3-DH3 or 3-DH5). The number of payload bytes is 11 for 3-DH1 packets, 536 for 3-DH3 packets or 986 for 3-DH5 packets.

Hopping and data whitening are turned off.

The EUT transmits at the lowest operating TX frequency to the Test Set. The Test Set calculates the initial center frequency error for a packet transmitted by the EUT. This is performed on the basic rate portion of the packet.

Referring to the above sketch, the Test Set determines the start time of the first preamble bit p0 and calculates the frequency deviations a) at the bit centres (referenced to p0) of the packet header (fGSFK) bits, relative to the ideal carrier frequency (fc0).

The Test Set selects bits from the header that have the same value as previous and following bits to avoid inter-symbol interference. It calculates the average frequency deviation ∆ω1 of those selected header bits that represent a transmitted ‘1’, it calculates the average frequency deviation ∆ω2 of those selected packet header bits that represent a transmitted ‘0’, and finally, calculates the initial frequency error ωi = (∆ω1+∆ω2)/2.

The Test Set compensates the payload (fDPSK)for the initial frequency error ωi of the packet. A square-root raised cosine measurement filter with a roll-off factor of 0.4 and a 3 dB bandwidth of ±500 kHz is applied to the payload portion of the packet.

The Test Set partitions the output of the measurement filter into non-overlapping blocks of 50 µsecs beginning at the nominal start of the synchronization symbol following the reference symbol and finishing at the nominal end of the final payload CRC symbol. The number of payload bytes has been chosen to make an integral number of blocks. The default block value is 200, this value is achieved by selecting the number of packets and length of packets based on which packet type is selected. The following table shows the relationship between packet type, the number of packets and length of packets to make a payload block.

Default Value to Achieve 200 Payload Blocks
Packet Type | Number of Packets | Length of Packets
2DH1 | 67 | 31
2DH3 | 7 | 356
2DH5 | 4 | 656
3DH1 | 200 | 11
3DH3 | 7 | 536
3DH5 | 4 | 986

For each block, The Test Set calculates the sampling phase ε0 and frequency error ω0 for the RMS DEVM for the block. The frequency error ω0 and the RMS DEVM for each block are recorded. The Test Set also calculates the Peak DEVM and 99th Percentile DEVM for each symbol in the each block using the sampling phase ε0 and frequency error ω0 for the block. The Peak DEVM and 99th Percentile DEVM for each symbol is recorded.

The process is repeated for more transmitted packets by the EUT until a total of 200 blocks have been measured (any remaining blocks from the end of the final packet are discarded).

This test is repeated while the EUT continues to transmit blocks in the mid operating frequency and the high operating frequencies.

This is described in the BT Test Specification TRM/CA/11/C.


EDR Differential Phase Encoding Test Description

Description

Sets up all parameters for EDR Differential Phase Encoding Measurement. See Bluetooth EDR Fetch Differential Phase Encoding Results for fetching of results.

Perform the EDR Differential Phase Encoding Test to verify that the modulator correctly differential phase encodes the data.

No additional test equipment is required.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | Off
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | Off
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 100
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH1
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Transmitter | Transmitter
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

The Test Set performs the test in transmitter test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant EDR Differential Phase Encoding test is performed with the EUT in transmitter test mode transmitting 2-DH1 or 2-EV3 packets with maximum length payload containing PRBS9. Hopping and data whitening are turned off.

If 8DPSK modulation is supported by the same EUT, the test is repeated using an additional test sequence while the EUT transmits 3-DH1 or 3-EV3 packets with the maximum length payload containing PRBS9.

The EUT transmits at maximum output power and the lowest operating TX frequency to the Test Set. The Test Set demodulates 100 packets and compares each payload with the expected PRBS9 data.

This is described in the BT Test Specification TRM/CA/12/C.

No additional test equipment is needed.


EDR Guard Interval Test Description

Description

Sets up all parameters for EDR Guard Interval Measurement. See Bluetooth EDR Fetch Guard Interval Results for fetching of results.

Perform the EDR Guard Interval Test to verify the guard time between the frequency modulated [GFSK] header and phase modulated [DPSK] payload portions of a packet.

No additional test equipment is required.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | Off
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | Off
MedChannel | 0 - 78 | 39
Number of Packets | 1 to 50,000 | 1
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback Or Transmitter | Loopback
Tx Power Level (dBm) | -95 to 0 | -40
Whitening | Off or On | Off

Compliance with the Bluetooth RF Test Specification?

This test is not a requirement of the Bluetooth RF Test Specification.


EDR Sensitivity Test Description

Description

Sets up all parameters for EDR Sensitivity Measurement. See Bluetooth EDR Fetch Sensitivity Results for fetching of results.

Perform the EDR Sensitivity Test to verify the receiver sensitivity for the 10-4 bit error rate using a non-ideal transmitter.

A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | On
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 200000000 | 1602440
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -70
Whitening | Off or On | On

Compliance with the Bluetooth RF Test Specification?

The Test Set performs the test in loopback test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant EDR Sensitivity test is performed with the Test Set continuously sending the longest supported p/4-DQPSK packet type (2-DHx or 2-EVx) with maximum length payload containing PRBS9.

If 8DPSK is supported by the EUT the test is repeated while the Test Set continuously sends 8DPSK packets with the longest supported packet type (3-DHx or 3-EVx) and the maximum length payload containing PRBS9.

Hopping and data whitening are turned off.

The Test Set transmit power is selected to ensure the input power to the EUT receiver is -70dBm, measured over the DPSK modulated portion of the packets.

The EUT receives packets at the lowest operation frequency.

The returned packets are received and the BER is measured by the Test Set.

After 1,600,000 bits have been received the BER is compared with threshold 7x10-5. If the BER is less than this threshold then the Test Set repeats the process at the mid operating frequency and the highest operating frequency. The measured values must fulfil the following condition at low, medium and high frequencies:

BER ≤ 7x10-5 after 1,600,000 bits.

If the threshold of 7x10-5 is not achieved, the Test Set continues sampling until a minimum number of 16,000,000 bits payload bits are returned. The measured values must fulfil the following condition at low, medium and high frequencies:

BER ≤ 10-4 after 16,000,000 bits.

This is described in the BT Test Specification RCV/CA/07/C.

No additional test equipment is needed.


EDR BER Floor Performance Test Description

Description

Sets up all parameters for EDR BER Floor Performance Measurement. See Bluetooth EDR Fetch BER Floor Performance Results for fetching of results.

Perform the EDR BER Floor Performance Test to verify the receiver performance for the 10-5 bit error rate.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 200000000 | 8001336
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR_2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -60
Whitening | Off or On | On

Compliance with the Bluetooth RF Test Specification?

The Test Set performs the test in loopback test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant EDR BER Floor Performance test is performed with the Test Set continuously sending the longest supported p/4-DQPSK packet type (2-DHx or 2-EVx) with maximum length payload containing PRBS9.

If 8DPSK is supported by the EUT the test is repeated while the Test Set continuously sends 8DPSK packets with the longest supported packet type (3-DHx or 3-EVx) and the maximum length payload containing PRBS9.

Hopping and data whitening are turned off.

The Test Set transmit power is selected to ensure the input power to the EUT receiver is -60dBm, measured over the DPSK modulated portion of the packets.

The EUT receives packets at the lowest operation frequency.

The returned packets are received and the BER is measured by the Test Set.

After 8,00,000 bits have been received the BER is compared with threshold 7x10-6. If the BER is less than this threshold then the Test Set repeats the process at the mid operating frequency and the highest operating frequency. The measured values must fulfil the following condition at low, medium and high frequencies:

BER ≤ 7x10-6 after 8,000,000 bits.

This is described in the BT Test Specification RCV/CA/08/C.

No additional test equipment is needed.


EDR Max Input Level Test Description

Description

Sets up all parameters for EDR Max Input Level Measurement. See Bluetooth EDR Fetch Max Input Level Results for fetching of results.

Perform the EDR Maximum Input Level Test to verify of the receiver performance at the maximum specified input signal.

Parameters

Parameter | Range | Default/ Compliance
HighChannel | 0 - 78 | 78
HighChanState | On Or Off | On
Hopping | On or Off | Off
IF Bandwidth (MHz) | 1300000, 3000000, 5000000 | 3000000
Impairments | On Or Off | Off
LowChannel | 0 - 78 | 0
LowChanState | On Or Off | On
MedChanState | On Or Off | On
MedChannel | 0 - 78 | 39
Number of Bits | 1 to 200000000 | 1602440
Packet Length | Depends on Packet Type | AUTO
Packet Type | DH1, DH3, DH5, DH135, HV3, EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5 | EDR-2DH5
Payload | BS00, BSFF, BS0F, BS55, PRBS9 | PRBS9
Poll Interval | Depends on Packet Type | AUTO
Rx Power Level (dBm) | -70 to 25 | 10
Test Mode | Loopback | Loopback
Tx Power Level (dBm) | -95 to 0 | -20
Whitening | Off or On | On

Compliance with the Bluetooth RF Test Specification?The Test Set performs the test in loopback test mode as required by the Bluetooth RF Test Specification.

Test Method:

The compliant EDR Maximum Input Level test is performed with the Test Set continuously sending the longest supported p/4-DQPSK packet type (2-DHx or 2-EVx) with maximum length payload containing PRBS9.

If 8DPSK is supported by the EUT the test is repeated while the Test Set continuously sends 8DPSK packets with the longest supported packet type (3-DHx or 3-EVx) and the maximum length payload containing PRBS9.

Hopping and data whitening are turned off.

The Test Set transmit power is selected to ensure the input power to the EUT receiver is -20dBm, measured over the DPSK modulated portion of the packets.

The EUT receives packets at the lowest operation frequency.

The returned packets are received and the BER is measured by the Test Set. The minimum number of samples must be 1,600,000 returned payload bits.

The Test Set repeats the process at the mid operating frequency and the highest operating frequency. The measured values must fulfil the following condition at low, medium and high frequencies:

BER ≤ 10-3

This is described in the BT Test Specification RCV/CA/10/C.

No additional test equipment is needed.


Output Power Test Results

Description

Fetches Results for Output Power Measurement. See Bluetooth Setup Output Power for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Output Power Test to verify the maximum peak and average RF transmit power of the EUT. Regulations allow ISM band transmitters to emit up to 20 dBm (average) when spread spectrum techniques are used. Bluetooth uses frequency hopping to spread the spectrum. There are 3 EUT power classes defined within the Bluetooth specification. Each class of equipment must conform to the relevant specifications.

Power levels within specified limits are required to ensure interoperability and regulatory requirements.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Average Power

  • Peak Power

Parameters

None


Power Control Test Results

Description

Fetches Results for Power Control Measurement. See Bluetooth Setup Power Control for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Power Control Test to verify the correct operation of the EUT transmitter level control. There are 3 EUT power classes defined within the Bluetooth specification. Power control is a mandatory for Class 1 equipment and optional for Class 2 and 3 equipment.

Power control within specified limits is required to ensure interoperability and predictable power consumption for EUTs to be used in battery powered products.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Power Control Step Size

  • Power Control Avg Power Min Step

Parameters

  • None


bluetooth fetch carrier frequency drift results

Carrier Frequency Drift Rate Results

Description

Fetches Results for Carrier Frequency Drift Rate Measurement. See Bluetooth Setup Carrier Frequency Drift for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Carrier frequency drift performance within specified limits is required to ensure interoperability.

The EUT transmitter center frequency drift, and center frequency drift rate are measured with this test.

Specifications

  • CarrFreqDriftRate

  • Slot1CarrierFreqDriftLimit

  • Slot3CarrierFreqDriftLimit

  • Slot5CarrierFreqDriftLimit

Parameters

  • None


Initial Carrier Freq Tolerance Test Results

Initial Carrier Frequency Tolerance Test Results

Description

Fetches Results for Initial Carrier Frequency Tolerance Measurement. See Bluetooth Setup Initial Carrier Frequency Tolerance for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Initial Carrier Frequency Tolerance (ICFT) Test to verify the performance of the EUT voltage controlled oscillator (VCO) and phase locked loop (PLL). This is achieved by measuring the accuracy of the EUT transmitter center frequencies. Due to the frequency hopping scheme a Bluetooth transmitter must quickly and accurately establish the frequency of each of the 79 channels before data transfer begins.

ICFT performance within specified limits is required to ensure interoperability.

A consistent offset is observed in the results may be removed by fine tuning the EUT transmitter VCO reference oscillator frequency.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • ICFT

Parameters

None


Modulation Characteristics Test Results

Description

Fetches Results for Modulation Characteristics Measurement. See Bluetooth Setup Modulation Characteristics for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Modulation Characteristics Test to verify the performance of the modulation circuitry. Bluetooth uses gaussian frequency shift keying (GFSK) to transfer data at a rate of 1 Mb per second. A binary 1 causes a positive frequency shift while a binary 0 causes a negative shift.

The modulation depth and rate are chosen to minimize unwanted products within the Bluetooth channel spacing. The circuitry must be capable of generating the rate and depth of modulation required for a receiver to decode a 101010 pattern. However, it must not over-modulate when sending continuous blocks of 1 or 0 in the data, swamping the receiver.

Modulation performance within specified limits is required to ensure interoperability.

No additional test equipment is required.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Delta F1 Average

  • Delta F2 Average

  • Delta F1 Delta F2 Ratio

  • Delta F2 Maximum

Parameters

None


Single Slot Sensitivity Test Results

Description

Fetches Results for Single Slot Sensitivity Measurement. See Bluetooth Setup Single Slot Sensitivity for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Sensitivity Tests to verify the performance of the EUT receiver when presented with a non-ideal signal. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


Multi Slot Sensitivity Test Results

Description

Fetches Results for Multi Slot Sensitivity Measurement. See Bluetooth Setup Multi Slot Sensitivity for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Sensitivity Tests to verify the performance of the EUT receiver when presented with a non-ideal signal. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


Max Input Level Test Results

Maximum Input Level Test Results

Description

Fetches Results for Max Input Level Measurement. See Bluetooth Setup Max Input Level for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Maximum Input Level Test to verify the performance of the EUT receiver at high input RF power levels. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low power levels but equally must also sustain communication when the input level is high due to a nearby transmitter emitting high power levels.

Maximum input level performance within specified limits is required to ensure interoperability.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


bluetooth edr fetch relative power results

EDR Relative Power Results

Description

Fetches Results for EDR Relative Power Measurement. See Bluetooth Setup EDR Relative Power for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR Relative Power Test to verify the difference in average transmit power during frequency modulated [GFSK] and phase modulated [DPSK] portions of a packet.

Power levels within specified limits are required to ensure interoperability and regulatory requirements.

Specifications

    • RelativePower (@ High Power)

    • RelativePower (@ Low Power)

GFSK and DPSK values are also shown but these have no limits attached.

Parameters

    • None


bluetooth edr fetch carrier freq stability results

EDR Carrier Frequency Stability & Modulation Accuracy Results

Description

Fetches Results for EDR Carrier Frequency Stability & Modulation Accuracy Measurement. See Bluetooth EDR Setup Carrier Freq Stab Mod Accuracy for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR Frequency Stability and Modulation Accuracy Test to verify the transmitter carrier frequency stability and modulation accuracy.

It tests, the clock's "crystal trim" accuracy by measuring the frequency error and the DEVM to measure the modulation accuracy.

Specifications

  • Initial Frequency Error (ωi)

  • Initial Frequency Error plus Block Frequency Error (ωi+ ω0)

  • Block Frequency Error (ω0)

  • RMS DEVM

  • Peak DEVM

  • Percentile DEVM

Parameters

  • None


Bluetooth EDR Fetch Differential Phase Encoding Results

EDR Differential Phase Encoding Results

Description

Fetches Results for EDR Differential Phase Encoding Measurement. See Bluetooth EDR Setup Differential Phase Encoding for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR Frequency Stability and Modulation Accuracy Test to verify the transmitter carrier frequency stability and modulation accuracy.

It tests, the clock's "crystal trim" accuracy by measuring the frequency error and the DEVM to measure the modulation accuracy.

Specifications

  • PER

Parameters

  • None


bluetooth edr fetch guard interval results

EDR Guard Interval Results

Description

Fetches Results for EDR Guard Interval Measurement. See Bluetooth Setup EDR Guard Interval for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR Guard Interval Test to verify the guard time between the frequency modulated [GFSK] header and phase modulated [DPSK] payload portions of a packet.

Specifications

    • GuardInterval

Parameters

    • None


EDR Sensitivity Test Results

Description

Fetches Results for Single Slot Sensitivity Measurement. See Bluetooth EDR Setup Sensitivity for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR Sensitivity Test to verify the receiver sensitivity for the 10-4 bit error rate using a non-ideal transmitter.

A Bluetooth receiver must have sufficient sensitivity to sustain communication at low input power levels and tolerate a degree of poor transmitter performance.

Sensitivity performance within specified limits is required to ensure interoperability.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


EDR BER Floor Performance Test Results

Description

Fetches Results for EDR BER Floor Performance Measurement. See Bluetooth EDR Setup BER Floor Performance for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the EDR BER Floor Performance Test to verify the receiver performance for the 10-5 bit error rate.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


EDR Max Input Level Test Results

Description

Fetches Results for EDR Max Input Level Measurement. See Bluetooth EDR Setup Max Input Level for setting up parameters. Bluetooth Run Sequence also has to be run before these results can be fetched.

Perform the Maximum Input Level Test to verify the performance of the EUT receiver at high input RF power levels. A Bluetooth receiver must have sufficient sensitivity to sustain communication at low power levels but equally must also sustain communication when the input level is high due to a nearby transmitter emitting high power levels.

Maximum input level performance within specified limits is required to ensure interoperability.

Specifications

To comply with the Bluetooth Test Specification configure the Test Set as follows:

  • Sensitivity BER

  • Sensitivity PER

Parameters

None


WLAN Demod A/G Test Description

WLAN Demod OFDM Description

Description

Fast measurement of EVM for 11a/g signals. Also returns IQ Offset, Frequency Error and time-gated power.

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance
DUTBand | A, G | Either
DutDataRate (Mbps) | 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, 54 | Dependant on Band
DUTPower (dBm) | -60 to 25 | 0
WLAN EVM Use Standard Specs | True Or False | True
WLANFrequency | 2412 - 5995 | 2412
WLANReference FilterProperty | Rect, Gaussian, RaisedCos | Rect

Specifications

    • WLANCentreFreqLeakage

    • WLANClockFreqErr

    • WLANDemodAveragePower

    • WLANDemodFreqErr

    • WLANEVMRMSLimit


WLAN Demod B Test Description

WLAN Demod (DSSS) Description

Description

Fast measurement of EVM for 11b signals. Also returns IQ Offset, Frequency Error and time-gated power.

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance
DUTBand | B | B
DutDataRate (Mbps) | 1, 2, 5.5, 11 | 11
DUTPower (dBm) | -60 to 25 | 0
WLAN EVM Use Standard Specs | True Or False | True
WLANFrequency | 2412 - 2484 | 2412
WLANReference FilterProperty | Rect, Gaussian, RaisedCos | Rect

Specifications

    • WLANCarrierSuppression

    • WLANClockFreqErr

    • WLANDemodAveragePower

    • WLANDemodFreqErr

    • EVMPeak

    • EVMRMS


Transmitter Spectral Flatness Test (OFDM)

Description

Spectral flatness is a measurement of the power variations in the carriers of an OFDM (IEEE 802.11A/G) signal. It is measured during the 8ms channel estimation phase of the burst, with all 52 carriers active but after the start of a normal burst. This test specifies a mask for the magnitude response of the transmitter channel.

Spectral flatness must be within ± 2 dB for ± 16 sub carriers and within +2/-4 dB for all sub carriers, the 0 dB level is established over ± 16 sub carriers.

  • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.9.6.2 Spectral Flatness

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance
DUTBand | A, G | Either
DutDataRate (Mbps) | 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, 54 | Dependant on Band
DUTPower (dBm) | -60 to 25 | 0
WLANFrequency | 2412 - 5995 | 2412

Specifications/Results

  • WLANSpectralFlatnessMargin : This result shows you whether the measured signal complies with the EWC standard referenced above. They show you how good the "worst" subcarrier is compared to the requirements of the specification.
    A positive result indicates that the measured signal complies with the mask, and the closest it comes to the mask is the result.
    A negative result indicates that the measured signal fails the mask, and the value shows the greatest amount by which it fails.


Transmitter Spectral Mask Test (DSSS/OFDM)

Description

The Transmitter Spectral Mask measurement includes the in-band and out-of-band spurious emissions. This test specifies that the transmitted signal does not exceed the IEEE 802.11 a, b, g specified spectral mask. The reference level power is taken as the Power Spectral Density (PSD) in the signal.

Spectral mask margin is the worst difference between the spectral mask and the measured PSD. A positive value indicates the minimum margin by which the PSD passed this test. A negative value indicates the worst-case amount by which the PSD failed this test. This test ensures that multiple WLAN devices do not unduly interfere with each other. The spectrum test can be a good indicator of deteriorating performance.

  • IEEE Std 802.11b-1999 Paragraph 18.4.7.3 Transmit spectrum mask

  • IEEE Std 802.11a-1999 Paragraph 17.3.9.2 Transmit spectrum mask

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance | Additional Information
DUTBand | A, G | Either |
DutDataRate (Mbps) | 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, 54 | Dependant on Band |
DUTPower (dBm) | -60 to 25 | 0 |
Increased Dynamic Range | 0 or 1 | 0 | The increased dynamic range setting only applies to the 802.11b spectral mask measurements using a bandwidth of 66 MHz.
WLANCollectAnd PlotSpectralMask Data | True Or False | True | Allows the user to decide to collect data used to plot Spectral Mask graphs. This will only be applicable if data collection is on, and Reduced Data/Graphical Data Collection is selected.
WLANFrequency | 2412 - 5995 | 2412 |

Specifications/Results

  • WLANSpectralMaskMargin(dB) : The worst difference between the spectral mask and the measured Power Spectral Density (PSD).
    A positive value indicates the minimum margin by which the PSD passed this test
    A negative value indicates the worst case amount by which the PSD failed this test
    When the Reference Level is relative (which is the normal case), the spectral mask margin will typically report 0 dB for a passing spectral mask, since the highest PSD has become the 0 dB reference for the spectral mask.


Transmitter Power Up and Power Down Ramp Test (DSSS)

Description

This ensures that the power of the burst turns on/off at the correct rate, neither rising nor falling too quickly or too slowly.

  • IEEE Std. 802.11b-1999 16 September 1999 Paragraph 18.4.7.6

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance | Additional Information
DUTBand | B | B |
DutDataRate (Mbps) | 1, 2, 5.5, 11 | 11 |
DUTPower (dBm) | -60 to 25 | 0 |
WLANCollectAnd PlotPowerUp PowerDownRamp | True Or False | True | Allows the user to decide to collect data used to plot Power Up/Down Ramps. This will only be applicable if data collection is on, and Reduced Data/Graphical Data Collection is selected.
WLANFrequency | 2412 - 5995 | 2412 |
WLANReference FilterProperty | Rect, Gaussian, RaisedCos | Rect |

Specifications/Results

  • WLANPowerDownTimeLimit (us) : The time, in seconds, for the signal level to fall from the DownRamp High Threshold to DownRamp Low Threshold.

    Section 18.4.7.6 of 802.11b specifies that the power down-ramp from 90% to 10% of maximum power shall be no more than 2µs.

  • WLANPowerUpTimeLimit (us) : The time, in seconds, for the signal level to rise from the UpRamp Low Threshold to UpRamp High Threshold.

    Section 18.4.7.6 of 802.11b specifies that the power up-ramp from 10% to 90% of maximum power shall be no more than 2µs.


Receiver Maximum/Minimum Input Level Sensitivity Test (DSSS/OFDM)

Description

The receiver maximum input level sensitivity and receiver minimum input level sensitivity tests require, for a specified input power level at the antenna connector, that a WLAN receiver will receive and demodulate with a FER (802.11b) or PER (802.11a) at or below that specified in the IEEE standard:

  • IEEE Std 802.11b-1999 16 September 1999 Paragraph 18.4.8.2 Receiver maximum input level

  • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.10.4 Receiver maximum input level

  • IEEE Std 802.11b-1999 16 September 1999 Paragraph 18.4.8.1 Receiver minimum input level

  • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.10.1 Receiver minimum input level

Parameters

If WLAN Freq Band loop is used, DUTBand & WLANFrequency parameters are generated from the looping parameters. Refer to Start Loop Test Step.

If WLAN Data Rate Loop is used, the DutDataRate parameter is generated from the looping parameters. Refer to Start Loop Test Step.

Parameter | Range | Default/ Compliance | Additional Information
DUTBand | A, B, G | Either |
DutDataRate (Mbps) | 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, 54 | Dependant on Band |
TxPowerLevel (dBm) | TBD | -40 |
WLANUseStandard PERSpec | True Or False | True | Will set the TxPowerLevel to the 802.11 specification value beofre running the measurement, otherwise the parameter TxPowerLevel value will be used.
WLANFrequency | 2412 - 5995 | 2412 |

Specifications/Results

  • WLANPERLimit (%)


Agilent N4018C/19C Bluetooth/Wireless LAN Wireless Test Manager Specifications

Alphabetical Listing of Specifications

Click on a letter below to be linked to the corresponding location in the table.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Specification | Description
Average Power (dBm) | The Average Power limit sets the pass/fail values for the average transmit power of the EUT.
Block Frequency Error (kHz) | The Block Frequency Error limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test block frequency (ω0)
CarrFreqDriftRate | The Drift Rate limit sets the pass/fail values for the maximum drift rate within a packet.
Delta F1 Average | The Delta f1 Average sets the pass/fail limits for the delta f1 average measurement using a 00001111 (BS0F) bit pattern payload.
Delta F2 Average | The Delta f2 Average limit sets the pass/fail values for the delta f2 average measurement using a 1010101010 (BS55) bit pattern payload.
Delta F2 Delta F1 Ratio | The Delta f2 Average/Delta f1 Average sets the pass/fail limits for the delta f2 average/delta f1 average measurement. Only the lower limit is required.
Delta F2 Maximum | The Delta f2 Maximum limit sets the pass/fail values for the delta f2 maximum measurement using a 1010101010 (BS55) bit pattern payload. Only a lower limit is required.
Dpen PER (Percent) | The EDR Differential Phase Encoding limit sets the pass/fail value for the upper Packet Error Rate.
DPSKHigh (dBm) |
DPSKLow (dBm) | This sets the pass/fail limits for the DPSK (Low Power) part of the EDR Relative Power measurement. Default is None for Upper and Lower.
EDRGuardIntervalLimit (us) | The EDR Guard Interval limit sets the pass/fail value for the upper and lower guard time interval between the frequency modulated [GFSK] header and phase modulated [DPSK] payload portions of a packet.
EDRSensitivityBERLimit (Percent) | The EDR Sensitivity limit sets the pass/fail value for the upper Bit Error Rate.
EDRSensitivityPERLimit (Percent) | The EDR Sensitivity limit sets the pass/fail value for the upper Packet Error Rate.
Error Packets | This sets the pass/fail limits for the number of Error Packets in the EDR Differential Phase Encoding measurement. No limits as default.
EVMPeak (Percent) | This sets the pass/fail limits for the average peak error vector magnitude result from a multi-measurement.
EVMRMS (Percent) | This sets the pass/fail limits for the average peak magnitude error result from a multi-measurement.
GFSKHigh (dBm) | This sets the pass/fail limits for the GFSK (High Power) part of the EDR Relative Power measurement. Default is None for Upper and Lower.
GFSKLow (dBm) | This sets the pass/fail limits for the GFSK (Low Power) part of the EDR Relative Power measurement. Default is None for Upper and Lower.
ICFT | The ICFT limit sets the pass/fail values for the EUT transmitter frequency accuracy (Initial Carrier Frequency Tolerance).
Initial Frequency Err (kHz) | The Initial Frequency Error limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test initial frequency (ωi)
Initial Plus Block Error (kHz) | The Initial Plus Block Error limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test block + Initial frequency (ωi + ω0)
Missing Packets | This sets the pass/fail limits for the number of Missing Packets in the EDR Differential Phase Encoding measurement. No limits as default.
NinetyNineDEVM (Percent) | The NinetyNineDEVM limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test 99 percentile DEVM.
Peak Power (dBm) | The Peak Power limit sets the pass/fail values for the peak transmit power of the EUT.
PeakDEVM (Percent) | The PeakDEVM limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test peak DEVM.
Power Control Avg Power Min Step (dBm) | The Minimum Step Average Power limit sets the pass/fail values for the average transmit power of the EUT at the minimum step setting.
Power Control Step Size (dB) | The Power Step Size limit sets the pass/fail values for the transmitter power step size of the EUT.
RMSDevm (Percent) | The RMSDEVM limit sets the pass/fail values for the EDR Frequency Stability and Modulation Accuracy Test RMS DEVM.
RPOWHigh (dB) | The EDR Relative Power limit sets the pass/fail values for upper and lower power levels.
RPOWLow (dB) | The EDR Relative Power limit sets the pass/fail values for upper and lower power levels.
Sensitivity BER | The BER limit sets the pass/fail values for a bit error rate measurement.
Sensitivity PER | The PER limit sets the pass/fail values for a packet error rate measurement.
Slot1CarrierFreqDriftLimit (kHz) | The Drift limit sets the pass/fail values for packet frequency drift (Single Slot Packet Types)
Slot3CarrierFrequencyDriftLimit (kHz) | The Drift limit sets the pass/fail values for packet frequency drift. (Three Slot Packet types)
Slot5CarrierFrequencyDriftLimit (kHz) | The Drift limit sets the pass/fail values for packet frequency drift. (Five Slot Packet Types)
WLANAutoRangePowerRange (dBm) | The PowerRange limit sets the pass/fail values for the AutoRange calculated Power Range Value.
WLANAutoRangeTriggerLevel (V) | The WLANAutoRangeTriggerLevel limit sets the pass/fail values for the AutoRange calculated Trigger Level Value
WLANCentreFreqLeakage (dB) | The WLANCentreFreqLeakage limit sets the pass/fail values for the Centre Frequency Leakage result.
WLANClockFreqErrLimit (ppm) | The WLANClockFreqErr limit sets the pass/fail values for the frequency error results.
WLANDemodAveragePower (dBm) | The WLANDemodAveragePower limit sets the pass/fail values for the Demod average power result.
WLANDemodCarrierSuppression (dB) | The WLANDemodCarrierSuppression limit sets the pass/fail values for the Demod Carrier Suppression result.
WLANDemodFreqErr (ppm) | The WLANDemodFreqErr limit sets the pass/fail values for the Demod frequency error result.
WLANEVMRMSLimit (dB) | The WLANEVMRMS limit sets the pass/fail values for the RMS EVM Result.
WLANPERLimit (Percent) | The WLANPER limit sets the pass/fail values for the PER Result.
WLANPowerDownTimeLimit (us) | The WLANPowerDownTime limit sets the pass/fail values for the Power Down Ramp Time Result.
WLANPowerUpTimeLimit (us) | The WLANPowerUpTime limit sets the pass/fail values for the Power Up Ramp Time Result.
WLANSpectralMaskMargin (dB) | The WLANSpectralMaskMargin limit sets the pass/fail values for the Spectral Mask Margin Result.
WLANXTalTrimFrequency (Hz) | The WLANXTalTrimFrequency limit sets the pass/fail values for the Xtal Trim frequency calibration result.


Alphabetical Listing of Global and Test Parameters

Agilent N4019C Bluetooth/Wireless LAN Wireless Test Manager
Global and Test Plan-Specific Parameters

Alphabetical Listing of Global and Test Plan-Specific Parameters

Click on a letter below to be linked to the corresponding location in the table.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Parameter

Description

Always Fail Test Plan

This parameter sets whether or not your overall test plan fails if any of the fail steps are entered in to.

BT Activate Delay

This global parameter defines the delay period between the ACL connected state and activating test mode. This value allows a settling time for the EUT to process the command. You can enter values between 0 and 60 seconds.

BT Command Delay

This global parameter defines the delay period after each test mode command issued by the Test Set. You can enter values between 0 and 1 second. The value is rounded to a multiple of 1.25 ms.

BT DUT Name

This parameter defines the Bluetooth Device Under Test Name (e.g. COM1) to be connected to when running measurements.

BT DUT Protocol

Defines the protocol to be used in the Bluetooth Device Connection, e.g "H4"

BT DUT Speed

Specifies the speed of the Bluetooth Device Connection, e.g. 115200 bps

BT DUT Transport

Specifies the transport required for connection to the Bluetooth Device Under Test, e.g. "UART" or "USB"

BT EDR Impairments Table

This parameter specifies the required dirty transmitter impairment values, to be used when impairments are ON. For Bluetooth EDR measurements only.

BT EUT Channel Tx Rx Pair

This parameter is used to specify the EUT Transmit and Receive Channels to be used as looping parameter in the test step.

BT Exit TestMode Before Disconnect

Use this global parameter to specify whether or not the Test Set exits test mode by means of issuing the 'exit test mode' LMP command (LMP_test_control command with test scenario set to ’exit test mode’) before it disconnects (LMP_detach) its link to the EUT. Some EUTs will not exit test mode correctly unless this parameter is enabled (Range On/Off, Default On). For Bluetooth Testing only.

BT Frequency Reference

Use this global parameter to set the frequency reference source. (Range INT | EXT, default INT). For Bluetooth testing only.

BT Impairments EDR Max Dev

This parameter defines the maximum deviation of the sine wave impairment, if impairments is set to ON. For Bluetooth EDR measurements only.

BT Impairments EDR Mode

This parameter defines what type of impairment is applied when impairments set to ON. For Bluetooth EDR measurements only.

BT Impairments EDR Mod Freq

This parameter defines the modulation frequency of the sine wave impairments, when impairments are ON. For Bluetooth EDR measurements only.

BT Impairments Max Deviation

This parameter defines the maximum deviation of the sine wave impairment, if impairments is set to ON. For Bluetooth EDR measurements only.

BT Impairments Mode

This parameter defines what type of impairment is applied when impairments set to ON. For Bluetooth 1.x Measurements only.

BT Impairments Mod Freq

This parameter defines the modulation frequency of the sine wave impairments, when impairments are ON. For Bluetooth 1.x measurements only.

BT Impairments Table

This parameter specifies the required dirty transmitter impairment values, to be used when impairments are ON. For Bluetooth 1.x measurements only.

BT Initiate Authentication

This global parameter is used when 'pairing' two Bluetooth devices. Use this command to enable or disable the authentication request process.

When the authentication is set 'on', the Test Set requests a PIN from the EUT. The value returned from the EUT must match that specified 'BT PIN' parameter for a successful connection. If authentication is set 'off' the EUT may attempt to pair with the Test Set by requesting a PIN.

BT Loss Compensation

This global parameter allows you to apply a fixed loss within the Test Set.

The loss values are applied when displaying the power of received signals and to the transmitted signal level. For example, if the loss is set to 1.3 dB, and the transmit level is set to –30 dB, then the actual transmitted power level is –28.7dB. An error is produced if the applied loss value would cause the test limit to be exceeded.

BT Page Scan Repetition Mode

Use this global parameter to set a Page Scan Repetition Mode for the Test Set that is appropriate for the EUTs you are testing. This helps ensure consistent and repeatable connection to the EUTs during test.

BT Power Class

Use this global parameter to set the power class of the EUT.

BT Power Control Mode

This global parameter is used to reduce the execution time for a test sequence with more than one test by changing the EUT output power only once before the tests are executed rather than before each individual test. This also enables a series of EUT Output Power tests to be carried out where you can control the EUT output power.

Error 901, "No EUT min power indication" is set if the EUT fails to reach minimum power after 10 decrements. Error 902, "No EUT max power indication" is set if the EUT fails to reach maximum power after 10 increments.

BT Power Control Step

Use this command to set the number of steps to be used by the EUT power control mode.

BT PIN

This global parameter is used when 'pairing' two Bluetooth devices. Use this command to set the required PIN on the EUT. The value can be up to four digits in length ranging from 0 to 9999. This is used in when authentication is ON.

BT Require Encryption

This global parameter is used when 'pairing' two Bluetooth devices. Use this parameter to enable or disable the encryption process. (Range ON | OFF, Default OFF)

BT STE Address

This global parameter is used to set the Test Set's Bluetooth device address, in hexadecimal.

The numeric value parameter can accept non-decimal numeric program data and is not restricted to hexidecimal. However, the query response format is hexidecimal.

Default address is #BDBDBDBDBDBD

Comment 1

This parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan.

Comment 2

This parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan.

Comment 3

This parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan.

Comment 4

This parameter allows you to specify a string that is displayed as a comment at the appropriate position in your test plan.

DUT Band

This parameter sets the required Wireless LAN Band. (Range A, B or G) Default is B.

DUT Data Rate (Mbps)

This parameter sets the required Wireless LAN DUT Data Rate. Default 11

DUT Power (dBm)

This parameter sets the required Wireless LAN DUT Power Level. Default 0

HighChannel

This parameter specifies the high frequency points to be used by the specified test, by Bluetooth channel number. Used for Bluetooth Testing.

HighChanState

This parameter determines whether the high frequency point will be used in the specified test. (On Or Off). Used for Bluetooth Testing.

Hopping

This parameter sets Hopping on or off. You can also configure hopping to operate between the specified High, Medium, and Low channels. Used for Bluetooth Testing.

IF Bandwidth

This parameter specifies the Test Set receiver IF bandwidth to be used for the test. Used for Bluetooth Testing.

Impairments

Set to ON or OFF in individual test steps, and will apply specified dirty transmitter impairment values.

Increased Dynamic Range

Increased Dynamic Range for the DSSS Spectral Mask Measurement. The increased dynamic range setting only applies to the 802.11b spectral mask measurements using a bandwidth of 66 MHz.

The default value is OFF

LinkInq
Duration (Sec)

Use this parameter to specify the timeout value to be used when performing an EUT Bluetooth address inquiry

Loop Parameter

This parameter sets which parameter to loop on.

Loop Separated Sequence

This parameter sets a comma separated list of values corresponding to the loop parameter setting on each successive iteration of the loop.

Loop Start

This parameter sets the initial value that the loop parameter is to be set to when the Loop Start...Loop Stop looping is started.

Loop Step

This parameter sets the step size that the loop structure uses to define the next value.

Loop Stop

This parameter sets the stop value that the loop parameter is set to.

LowChannel

This parameter specifies the low frequency points to be used by the specified test, by Bluetooth channel number.

LowChanState

This parameter determines whether the low frequency point will be used in the specified test. (On Or Off)

MedChannel

This parameter specifies the middle frequency points to be used by the specified test, by Bluetooth channel number.

MedChanState

This parameter determines whether the middle frequency point will be used in the specified test. (On Or Off)

NumBits

This parameter specifies the total number of bits to be used in a Bit Error Rate (BER) measurement.

Num Blocks

This parameter specifies the number of returned 50 symbol payload blocks used for the test. Only used for Bluetooth EDR Carrier Frequency Stability and modulation Accuracy Test.

NumPackets

This parameter specifies the number of packets to be used in the test. Increasing the quantity of packets tested can significantly increase the test time depending on the packet types and the number of channels tested.

PacketLength

This parameter specifies the length of the data payload. The number of bytes in the payload depends on the type of packet selected.

PacketType

This parameter specifies the packet types to be tested. The valid options depend on the selected link type and subject to the supported features of the EUT.

Payload

This parameter specifies the contents of a packet.

PollInterval (sec)

This parameter specifies the time interval between test packets sent from the Test Set to the EUT. When set to AUTO the Test Set calculates the minimum value. Alternatively, you can specify the value.

PowerRange (dBm)

This parameter sets the PowerRange of the Test Set.

RPOWStart
HeaderPower (%)

Use this parameter to set the start point of header used for the EDR Relative Power Measurement.

RPOWStop
HeaderPower (%)

Use this parameter to set the stop point of the header used for the EDR Relative Power Measurement.

RPOWStart
DPSKPower (%)

Use this parameter to set the start point of the payload used for the EDR Relative Power Measurement.

RPOWStop
DPSKPower (%)

Use this parameter to set the stop point of the payload used for the EDR Relative Power Measurement.

RxPowerLevel (dBm)

Use this parameter to define the expected input power level, or the EUT transmit power.

TestMode

Specifies the type of test mode link to be established between the Test Set and EUT, for the specified test.

TxPowerLevel (dBm)

This parameter specifies the Test Set RF transmitter level to be used for individual tests.

Whitening

This parameter sets data whitening on or off. Data whitening is a scrambling process applied to both the header and data. It is applied to minimize any DC bias in the packet.

Whitening is only applicable with a loopback testmode connection to the EUT and the PRBS9 payload pattern selected.

WLANCollectAnd
PlotPowerUpDown
Graphs

This parameter allows the user to decide to collect data used to plot PowerUpRamp and PowerDownRamp graphs for Wireless LAN testing. This will only be applicable if data collection is on, and Reduced Data/Graphical Data Collection is selected.

WLANCollectAnd
PlotSpectralMask
Data

This parameter allows the user to decide to collect data used to plot Spectral Mask graphs for Wireless LAN testing. This will only be applicable if data collection is on, and Reduced Data/Graphical Data Collection is selected.

WLANDUTData
RateList

This parameter is used to specify the WLAN DUT Data Rate to be used as looping parameter in the test step.

WLANDUTType

This parameter is used by the user if he wishes to use a variety of different WLAN Devices Under Test.

WLAN Freq Band

This parameter is used to specify the WLAN Band and Frequency to be used as looping parameter in the test step.

WLANFrequency (Hz)

This parameter is used to specify the frequency at which the Wireless LAN measurements are run. If looping is implemented in a test plan this parameter is ignored.

WLAN EVM Use Standard Specs

This parameter is used to determine if the WLAN 802.11 specification values are output as limits instead of those defined in the Wireless Test Manager UI, for EVM Tests.

WLAN PathLoss A Band

This parameter is used to define a fixed path loss for Band A/G Measurements.

WLAN PathLoss B Band

This parameter is used to define a fixed path loss for Band B Measurements.

WLAN PER Use Standard Specs

This parameter is used to determine if the WLAN 802.11 specification values are output as limits instead of those defined in the Wireless Test Manager UI, for PER Tests.

WLANReference
FilterProperty

This parameter is used to determine the reference filter used during DSSS demodulation in the IEEE802.11b Demod measurement. Allowed values are Rect, Gaussian and RaisedCos. Default is Rect.


Error Messages

Description

An error message is generated by WTM for errors in looping structure when running test plan steps or with interaction with the power supply or test set.

For more information, choose a book or topic below

  • Looping Structure Error

  • Test Set Activation Error


Looping Structure Error

This Looping Structure Error message window is displayed for the following scenarios:

  • You entered a positive Loop Step value and the Loop Stop value is less than the Loop Start value.

  • You entered a negative Loop Step value and the Loop Start value is less than the Loop Stop value.

To avoid this error, enter a negative Loop Step value to decrement the Loop Parameter value and a positive Loop Step value to increment the Loop Parameter value.

This message is also displayed if an End Loop is encountered as a Test Plan Step prior to a Start Loop step.

Click the OK button to close the message window.


Global Parameters

Global Parameters Description

Global Parameters are defined as test conditions that apply to several or all tests. Not all global parameters apply to all tests. Global parameters are often used at the beginning of tests to be visible to other modules.

The Agilent E4018C/19C Wireless Test Manager's (WTM) database structures parameters as either global or test-specific, but not both. Two parameters with the same name can not be added even if one is global and one is test-specific.

For more information about changing/editing/adding Global Parameters, refer to the WTM online help topic Setting a Test Plan's Global Parameters.

Test Plan-Specific Parameters Description

Test plan-specific parameters are specific to one instance of a test. The value set to that parameter is unique to that specific instance of the test. Another instance of the test in the same test plan has its own unique values for any test specific parameters.

Accessing Global Parameters

To view Global Parameters in the Agilent E4018C/19C Wireless Test Manager, select the Set Global Parameters tab.

The Global parameters for test plan group box displays the Parameter Name(s) and the values for the test plan displayed in the Current test plan field. Click on the example graphic link below, parameter names are highlighted in yellow and values are highlighted in cyan.

To change a global parameter value, click on the data in the value column. When the data is selected, enter the value you want. Some parameter values display a drop-down arrow when selected. Clicking the arrow opens a list. Select the value you want by clicking on it.

Click here for an example graphic of the Wireless Test Manager window.

For more information, see Alphabetic Listing of Global and Test Parameters


Developer Information

The books and topics in this section provide procedures and reference information for developers.

For more information, choose a book or topic below:

  • Customizing the User Interface

  • Wireless Test Manager Database

  • Wireless Test Manager User Interface Localization

  • WTMNet Lan Interface


Customizing the User Interface

All screens seen by the user can be modified in the Development mode. New Tabs can be defined, and action elements such as buttons and check boxes may be added wherever desired. Instructions for this are in the help system of the Development environment.


Wireless Test Manager Database

The topics in this section provide information about the database used by the Wireless Test Manager and the Add Wireless Test Wizard.

For more information, choose a topic below:

  • Database Alignment

  • Database Overview


Database Alignment

Database Alignment is a feature of the Wireless Test Wizard which automatically scans the database to ensure that it aligns with your Microsoft® Visual Basic® project's source code. If there is a mismatch between the database and the source code, the database is modified to align it to the source code.

The Wireless Test Wizard always treats the information in your source code as being the original, and the information contained in the database as a copy.

If you comment out a Test Step in your source code, running the Database Alignment feature removes all entries relating to the commented-out step from the database.

Related Topic: Database Overview


Database Overview

The Wireless Test Manager and the Wireless Test Wizard use a Microsoft® Access® database file format (.mdb) to store information about your test plans, test plan steps, specifications, parameters and global parameters. The database is stored in the "...\WirelessTestManager\E656X\TestData\" folder (where X completes the specific model number, for example E6560) within the target installation folder.

The Wireless Test Wizard automatically updates the database when it implements the changes you specify using the Wizard's user interface screens.

Although it is possible to open and view the database file using a database application such as Microsoft Access®, you must not make any changes to the database structure in this way. Otherwise, the database may not work correctly with the Wireless Test Manager or the Wireless Test Wizard.


Wireless Test Manager User Interface Localization

The topics in this section provide information about how to localize the Wireless Test Manager's User Interface.

For more information, choose a topic below:

  • Localizing the Wireless Test Manager's User Interface

  • Required Filenames for Localization


Localizing the Wireless Test Manager's User Interface

The Wireless Test Manager allows you to manually translate the user interface into the language of your choice. This means that you can change all of the screen titles, control labels and instructional text on the user interface. When you use the language version of Microsoft® Windows® which matches the new language file you have created, the Wireless Test Manager displays the user interface text you have created.

All text for the user interface is stored in a Unicode text file format which you can open and edit in most text editors. This file must always be saved with a .lng file extension.

To view or edit the localization file using WordPad®

Before starting this procedure, you should determine the file name that you need to use for the localization language. Go to the topic Required Filenames for Localization and make a note of the filename you must use.

  1. Click the Windows Start button, point to Programs, Accessories, then click WordPad.

The above step assumes that you have not customized the location of your Start Menu Programs.

  2. When WordPad starts, click Open on the File menu.
    The Open dialog box is displayed.

  3. Navigate to the localization file at the following location within the Wireless Test Manager target installation folder:
    "...\WirelessTestManager\Common\ExecLocalization\English.lng"

  4. Click Open to open the file.

  5. To ensure that you don't make any unwanted changes to the English.lng file, immediately save a copy of the file with the correct file name for the localization language. For example, if you are creating a French (France) localization file, save the file as "French.lng".

  6. You can now work through the file making your localization changes.
    Comments are provided at the top of the file which give you instructions on the required format and how you can add comments to the file.

You must use the specified format when you edit the file to ensure that your changes are displayed correctly on the Wireless Test Manager's graphical user interface. You must not edit the numbers in the left column as the Wireless Test Manager uses those numbers to determine which user interface control the text applies to.

  7. When you have finished making your changes, save the file and close WordPad.
    The next time you open your wireless test project in Visual Basic® and run the code, or start the run-time version of the Wireless Test Manager, your changes are displayed in the Wireless Test Manager's user interface.

If the correct localization number for a text label on the user interface is not present in the appropriate .lng file, "???<number>" is displayed on the user interface indicating the number that is missing.


Required Filenames for Localization

The table below defines for each language, the filename that you need to use for the localization file (.lng).

Alphabetical Listing of Required Filenames

Click on a letter below to be linked to the corresponding location in the table.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Locale Description | Decimal Value | Required Filename
Afrikaans | 1078 | Afrikaans.lng
Albanian | 1052 | Albanian.lng
Arabic – United Arab Emirates | 14337 | Arabic.lng
Arabic - Bahrain | 15361 | 15361Arabic.lng
Arabic - Algeria | 5121 | 5121Arabic.lng
Arabic - Egypt | 3073 | 3073Arabic .lng
Arabic - Iraq | 2049 | 2049Arabic .lng
Arabic - Jordan | 11265 | 11265Arabic.lng
Arabic - Kuwait | 13313 | 13313Arabic.lng
Arabic - Lebanon | 12289 | 12289Arabic.lng
Arabic - Libya | 4097 | 4097Arabic.lng
Arabic - Morocco | 6145 | 6145Arabic.lng
Arabic - Oman | 8193 | 8193Arabic.lng
Arabic - Qatar | 16385 | 16385Arabic .lng
Arabic - Saudi Arabia | 1025 | 1025Arabic.lng
Arabic - Syria | 10241 | 10241Arabic.lng
Arabic - Tunisia | 7169 | 7169Arabic.lng
Arabic - Yemen | 9217 | 9217Arabic.lng
Armenian | 1067 | Armenian.lng
Azeri – Latin | 1068 | Azeri.lng
Azeri – Cyrillic | 2092 | 2092Azeri.lng
Basque | 1069 | Basque.lng
Belarusian | 1059 | Belarusian.lng
Bulgarian | 1026 | Bulgarian.lng
Catalan | 1027 | Catalan.lng
Chinese - China | 2052 | Chinese.lng
Chinese - Hong Kong S.A.R. | 3076 | 3076Chinese.lng
Chinese – Macau S.A.R | 5124 | 5124Chinese.lng
Chinese - Singapore | 4100 | 4100Chinese.lng
Chinese - Taiwan | 1028 | 1028Chinese.lng
Croatian | 1050 | Croatian.lng
Czech | 1029 | Czech.lng
Danish | 1030 | Danish.lng
Dutch – The Netherlands | 1043 | Dutch.lng
Dutch - Belgium | 2067 | 2067Dutch.lng
English - Australia | 3081 | 3081English.lng
English - Belize | 10249 | 10249English.lng
English - Canada | 4105 | 4105English.lng
English – Carribbean | 9225 | 9225English.lng
English - Ireland | 6153 | 6153English.lng
English - Jamaica | 8201 | 8201English.lng
English - New Zealand | 5129 | 5129English.lng
English - Phillippines | 13321 | 13321English.lng
English - South Africa | 7177 | 7177English.lng
English - Trinidad | 11273 | 11273English.lng
English - United Kingdom | 2057 | 2057English.lng
English - United States | 1033 | English.lng
Estonian | 1061 | Estonian.lng
Farsi | 1065 | Farsi.lng
Finnish | 1035 | Finnish.lng
Faroese | 1080 | Faroese.lng
French - France | 1036 | French.lng
French - Belgium | 2060 | 2060French.lng
French - Canada | 3084 | 3084French.lng
French - Luxembourg | 5132 | 5132French.lng
French - Switzerland | 4108 | 4108French.lng
Gaelic – Ireland | 2108 | Gaelic.lng
Gaelic - Scotland | 1084 | 1084Gaelic.lng
German - Germany | 1031 | German.lng
German - Austria | 3079 | 3079German.lng
German - Liechtenstein | 5127 | 5127German.lng
German - Luxembourg | 4103 | 4103German.lng
German - Switzerland | 2055 | 2055German.lng
Greek | 1032 | Greek.lng
Hebrew | 1037 | Hebrew.lng
Hindi | 1081 | Hindi.lng
Hungarian | 1038 | Hungarian.lng
Icelandic | 1039 | Icelandic.lng
Indonesian | 1057 | Indonesian.lng
Italian - Italy | 1040 | Italian.lng
Italian - Switzerland | 2064 | 2064Italian.lng
Japanese | 1041 | Japanese.lng
Korean | 1042 | Korean.lng
Latvian | 1062 | Latvian.lng
Lithuanian | 1063 | Lithuanian.lng
FYRO Macedonian | 1071 | FYRO Macedonian.lng
Malay - Malaysia | 1086 | Malay.lng
Malay – Brunei | 2110 | 2110Malay.lng
Maltese | 1082 | Maltese.lng
Marathi | 1102 | Marathi.lng
Norwegian - Bokmål | 1044 | Norwegian.lng
Norwegian – Nynorsk | 2068 | 2068Norwegian.lng
Polish | 1045 | Polish.lng
Portuguese - Portugal | 2070 | Portuguese.lng
Portuguese - Brazil | 1046 | 1046Portuguese.lng
Raeto-Romance | 1047 | Raeto-Romance.lng
Romanian - Romania | 1048 | Romanian.lng
Romanian - Moldova | 2072 | 2072Romanian.lng
Russian | 1049 | Russian.lng
Russian - Moldova | 2073 | 2073Russian.lng
Sanskrit | 1103 | Sanskrit.lng
Serbian - Cyrillic | 3098 | Serbian.lng
Serbian – Latin | 2074 | 2074Serbian.lng
Setsuana | 1074 | Setsuana.lng
Slovenian | 1060 | Slovenian.lng
Slovak | 1051 | Slovak.lng
Sorbian | 1070 | Sorbian.lng
Spanish - Spain | 1034 | Spanish.lng
Spanish - Argentina | 11274 | 11274Spanish.lng
Spanish - Bolivia | 16394 | 16394Spanish.lng
Spanish - Chile | 13322 | 13322Spanish.lng
Spanish - Colombia | 9226 | 9226Spanish.lng
Spanish - Costa Rica | 5130 | 5130Spanish.lng
Spanish - Dominican Republic | 7178 | 7178Spanish.lng
Spanish - Ecuador | 12298 | 12298Spanish.lng
Spanish - Guatemala | 4106 | 4106Spanish.lng
Spanish - Honduras | 18442 | 18442Spanish.lng
Spanish - Mexico | 2058 | 2058Spanish.lng
Spanish - Nicaragua | 19466 | 19466Spanish.lng
Spanish - Panama | 6154 | 6154Spanish.lng
Spanish - Peru | 10250 | 10250Spanish.lng
Spanish - Puerto Rico | 20490 | 20490Spanish.lng
Spanish - Paraguay | 15370 | 15370Spanish.lng
Spanish - El Salvador | 17418 | 17418Spanish.lng
Spanish - Uruguay | 14346 | 14346Spanish.lng
Spanish - Venezuela | 8202 | 8202Spanish.lng
Sutu | 1072 | Sutu.lng
Swahili | 1089 | Swahili.lng
Swedish - Sweden | 1053 | Swedish.lng
Swedish - Finland | 2077 | 2077Swedish.lng
Tamil | 1097 | Tamil.lng
Tatar | 1092 | Tatar.lng
Thai | 1054 | Thai.lng
Turkish | 1055 | Turkish.lng
Tsonga | 1073 | Tsonga.lng
Ukrainian | 1058 | Ukrainian.lng
Urdu | 1056 | Urdu.lng
Uzbek – Cyrillic | 2115 | Uzbek.lng
Uzbek – Latin | 1091 | 1091Uzbek.lng
Vietnamese | 1066 | Vietnamese.lng
Xhosa | 1076 | Xhosa.lng
Yiddish | 1085 | Yiddish.lng
Zulu | 1077 | Zulu.lng


WTMNet Lan Interface

The WTMNet LAN interface can be used to control the operation of the WTM or obtain testing information from WTM. The WTM must be on the Run Test Plan Tab before LAN control can occur.

LAN functionality is turn on via the Change Configuration tab and selecting LAN on the SystemIO Tab. When LAN is enabled a globe icon will appear in the top right. If a client is not attached to WTM the globe icon will be red. If a client is attached the globe icon will be green.

When in the Developer Mode, the following are the interface commands to the WTM LAN connection:

  • WTM.TestData.SetCurrentTestPlan Desired test plan name

Sets the WTM current test plan to the Desired test plan name.

If the Desired test plan name is not found an error is return via a LAN message. The test plan cannot be changed if a test plan is currently running.

  • WTM.TestData.QueryAllTestResults

Returns all the test information currently in the WTM tests results information list view control. Each line of information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "TestResults" & ControlChars.Tab & TestResults

The TestResults will be a tab separated string. Information in each tab location will correspond to information in the columns of the list view control. This item cannot be queried if a test plan is currently running.

  • WTM.TestData.TotalTestTimeSec

Returns the total test time for the last run in seconds. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "TotalTestTimeSec" & TestTime

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.TotalPassed

Returns the number of results that passed for the previous test run. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "TotalPassed" & NumberPassed

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.TotalFailed

Returns the number of results that failed for the previous test run. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "TotalFailed" & NumberFailed

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.AvailableTestPlans

Returns a tab separated list of the currently available test plans. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & " AvailableTestPlans" & TabSeperatedListOfCurrentAvailableTestPlans

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.CurrentTestPlan

Returns the currently selected test plan. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "CurrentTestPlan" & CurrentTestPlan

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.SummaryResults

Returns the summary results (Passed, Failed, Aborted) for the last run. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & " SummaryResults" & SummaryResults

This item cannot be queried if a test plan is currently running.

  • WTM.TestData.MemoText

Returns the current information in the memo data text. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & " MemoText" & TextCurrentlyInMemoArea

  • WTM.FlowControl.TestPlanRunning

Returns a true or false indication for the test plan running condition. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & " TestPlanRunning" & RunningCondition

  • WTM.FlowControl.ProgressBarMaximum

Returns the maximum value of the progress bar. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & "ProgressBarMaximum" & MaxValue

  • WTM.FlowControl.ProgressBarValue

Returns the current value of the progress bar. The information will be returned in the following format:

"WTMQ" & ControlChars.Tab & " ProgressBarValue " & CurrentValue

  • WTM.FlowControl.StartTestPlan

This command will start the currently selected test plan.

This item will be ignored if a test plan is currently running.

  • WTM.FlowControl.AbortTestPlan

This command will abort the currently selected test plan.

  • WTM.Display.ShowForm

This command will make the WTM form visible

  • WTM.Display.HideForm

This command will make the WTM form invisible

The above commands/queries are all of the form “client send command and receive response from WTM if one is available.” It may be desired to have WTM tell the client when a given item has changed. This can be accomplished by using the following Auto Response configuration commands. If an auto response item is set to true then WTM will automatically send a response to the client (without the client sending a request) when the desired item is changed. The available auto response items are as follows:

  • WTM.AutoResponse.MemoTextChangeEnabled True or False

  • WTM.AutoResponse.TestPlanChangeEnabled True or False

  • WTM.AutoResponse.ProgressBarChangeEnabled True or False

  • WTM.AutoResponse.TestPlanRunningChangeEnabled True or False

  • WTM.AutoResponse.TestResultsEnabled True or False

  • WTM.AutoResponse.TestPlanListEnabled True or False

The following is an event that the Exec exposes for the WTM LAN connection:

Exec_LanMessageReceived(ByVal Message As String, ByRef CancelAction As Boolean) Handles Exec.LanMessageReceived

  • This event is raised any time WTM receives information from the WTMNet LAN interface. This event is raised before the Exec processes the command.

  • Message contains the information received from the WTMNet LAN interface.

  • If the application sets CancelAction= True, then the Exec will not process the command.


Troubleshooting

The books and topics in this section provide troubleshooting information relating to installation, set up or use.

For more information, choose a book or topic below:

  • Contact Information

  • If you have trouble with the hardware security key

  • If you have trouble with your installation CD-ROM


Contact Information

To find information about technical support, equipment service and repair, and training, visit the following Agilent Technologies Web site:

http://www.agilent.com/find/contactus/

Service and Support

Contact your customer engineer through your local Agilent Technologies Service Center.

If you do not have access to the Internet, one of these centers can direct you to your nearest representative:

UNITED STATES
(Toll free in US)
1-800-829-4444

AUSTRALIA/NEW ZEALAND
1-800-629-485 (Australia)
0800-738-378 (New Zealand)

AUSTRIA
0820 87 44 11

BELGIUM & LUXEMBOURG
+32 (0)2 404-9340

CANADA
1-877-894-4414

CHINA
1-800-810-0189

DENMARK
70 13 15 15

FINLAND
+358 (0)10 855 2100

FRANCE
0825 010 700 (0,125 € HT la minute)

GERMANY
0 18 05 24 63 33 (0,12 €/Min.)

IRELAND
1890 924 204

ITALY
+39 02 92 60 8484

JAPAN
(81) 426-56-7832

KOREA
(82-2) 2004-5004

LATIN AMERICA
(305) 269-7500

SPAIN
+34 91 631 3300

SWEDEN
0200 88 22 55

SWITZERLAND
0800 80 53 53

TAIWAN
0800-047-866

THE NETHERLANDS
+31 (0)20 547-2111

UK
+44 (0)7004 666 666

OTHER ASIA-PACIFIC COUNTRIES
(65) 6375-8100


If you have trouble with the hardware security key

Defective Hardware Security Key Problems

If you have a defective hardware security key, contact Agilent Technologies for support. See Contact Information for contact details.

Workaround for PCI-based Parallel Port Recognition Problems

The Sentinel System driver install process will not recognize PCI-based parallel ports with non-standard address locations. Rainbow Technologies© provide a workaround that allows the Sentinel System Driver to recognize the PCI-based parallel port. These instructions assume that the system drivers are already installed and can be used to communicate with LPT1 (usually address 378 hex):

  1. Get the resource properties for the PCI parallel port through the Windows Control Panel. (The actual icon in the Control Panel you use to display port properties depends on the version of Windows you are using.) In some cases, a range rather than an absolute address is displayed (e.g., D400-D407).

  2. Launch Setupx86.exe and choose Functions>Configure>Add from the drop-down menu.

  3. Under bus address (phy addr is not available using sentw9x.exe), enter the address or the lower end of the range (D400) and make sure that the radio button for Use this port is set to NO. Failing to do this can result in an endless loop of messages about “install the board drivers,” “port conflict”...”install board drivers,” “port conflict” and so on.

  4. Reboot the computer and launch Setupx86.exe again. Choose Functions>Configure>Edit from the drop-down menu and switch the Use this Port radio button to Yes. Complete the editing and exit the setup program.


If you have trouble with your installation CD-ROM

If you have a defective installation CD-ROM, contact Agilent Technologies for support. See Contact Information for contact details.


Alternate GSM Power Class

Description

The Alternate GSM Power Class parameter determines the power class of the mobile, when the following conditions are met:

  • The mobile does not report the power class.

  • The Get Alternate GSM Power Class from parameter is set to Parameter.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 2

To change the default value, select it and enter the value you want.

Data Range

The value you enter must be in the following range: 1 to 5


Average Power

Description

The Average Power limit sets the pass/fail values for the average transmit power of the EUT.

Compliance with the Bluetooth Test Specification?

The Bluetooth RF Test Specification lists the maximum and minimum average power values for each power class as follows:

 | Lower Limit | Upper Limit
Class 1 | >0 dBm (1 mW) | <20 dBm (100 mW)
Class 2 | >-6 dBm (0.25 mW) | <4 dBm (2.5 mW)
Class 3 | Unspecified | <0 dBm (1 mW)

Enter values accordingly.

Default Values

 | Lower Limit | Upper Limit
Class 1 | 0 dBm | 20 dBm
Class 2 | -6 dBm | 4 dBm
Class 3 | Unspecified | 0 dBm


Bad Block Handling

Description

The Bad Block Handling parameter determines how the bad blocks are handled by the BER measurement.

There are three settings:

  • Zero Data - Sets all bits within a bad block to zero before calculating the BER. This results in an average error rate of 50%.

  • Include - The bad bits are not altered before calculating the BER.

  • Exclude - All bits within a bad block are excluded from the BER calculation.

A block is defined as bad if:

  • At least one of the four expected bursts has not been received by the test set.

  • The demodulation quality of at least one of the bursts was questionable.

  • The block has failed the frame check sequence (CRC). (Each block that fails its CRC will cause the CRC error count result to increment, regardless of the BLER Bad Block Handling setting.)

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

The following values are available from the drop-down list in the Value column in the Parameters for test plan step group box:

  • Zero Data

  • Include

  • Exclude

Default Value

The default value for this parameter is: Zero Data

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.


Bit Error Rate

Bit Error Rate (BER)

Description

The BER limit sets the pass/fail values for a bit error rate measurement.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of £0.1% in 1,600,000 bits, enter values accordingly.

Default Value

0.1%


Bluetooth Link Inquiry Duration

Use this parameter to specify the timeout value to be used when performing an EUT Bluetooth address inquiry.

Range

1.28 seconds to 61.44 seconds

Resolution

1.28 seconds

Default

12.8 seconds


Bluetooth EUT Power Class

Use this command to determine the power class of the EUT.

  • PC1: maximum output power 100 mW (20 dBm) which has a range of approximately 100 m.

  • PC2: maximum output power 2.5 mW (4 dBm) which has a range of approximately 20 m.

  • PC3: maximum output power 1 mW (0 dBm) which has a range of approximately 10 m.

Changing the EUT's Power Class, while in Testmode, changes the Input Power level of any added test sequence after the power class is changed. Previous tests in the sequence remain at their original power level.

  • PC1 changes the Input Power level to 25 dBm.

  • PC2 changes the Input Power level to 10 dBm.

  • PC3 changes the Input Power level to 5 dBm.

Default Values

  • PC2


Bluetooth Page Scan Repetition Mode

Use this to set a Page Scan Repetition Mode for the Test Set that is appropriate for the EUTs you are testing. This helps ensure consistent and repeatable connection to the EUTs during test.

  • R0: Mode zero

  • R1: Mode one

  • R2: Mode two

Default Value

  • R1


Bluetooth Power Control Mode

This command is used to reduce the execution time for a test sequence with more than one test by changing the EUT output power only once before the tests are executed rather than before each individual test. This also enables a series of EUT Output Power tests to be carried out where you can control the EUT output power.

Error 901, "No EUT min power indication" is set if the EUT fails to reach minimum power after 10 decrements. Error 902, "No EUT max power indication" is set if the EUT fails to reach maximum power after 10 increments.

Range

  • NONE | INCR | DECR | MIN | MAX

Default

  • MAX


Bluetooth Power Control Step

Use this command to set the number of steps to be used by the EUT power control mode command.

Error 901, "No EUT min power indication" is set if the EUT fails to reach minimum power after 10 decrements. Error 902, "No EUT max power indication" is set if the EUT fails to reach maximum power after 10 increments.

Range

  • 1 to 10 (Resolution 1)

Default Values

  • 1


Bluetooth TestMode

Specifies the type of test mode link to be established between the Test Set and EUT, for the specified test.

  • LOOPback: specifies a loopback test mode link.

  • TRANsmitter: specifies a transmitter test mode link.

For the SSENsitivity, MSENsitivity and MILevel tests this parameter should always be set to LOOPback.

The EDR Differential Phase Encoding test is only performed in transmitter test mode.


BT EUT Channel TX Rx Pair

Description

The BT EUT Channel Tx Rx Pair parameter is used to specify the EUT Transmit and Receive Channels to be used as looping parameter in the test step.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

A table is available from the drop-down list in the Value column in the Parameter Table for: BT EUT Channel Tx Rx Pair group box:, click the [image] after [Table] to get it

Default Value

The default value for this parameter table as follows:

Channel Index | EUT Tx Channel | EUT Rx Channel
1 | 0 | 39
2 | 1 | 40
3 | 2 | 41
4 | 3 | 42
5 | 4 | 43
6 | 5 | 44
7 | 6 | 45
8 | 7 | 46
9 | 8 | 47
10 | 9 | 48
11 | 10 | 49
12 | 11 | 50
13 | 12 | 51
14 | 13 | 52
15 | 14 | 53
16 | 15 | 54
17 | 16 | 55
18 | 17 | 56
19 | 18 | 57
20 | 19 | 58
21 | 20 | 59
22 | 21 | 60
23 | 22 | 61
24 | 23 | 62
25 | 24 | 63
26 | 25 | 64
27 | 26 | 65
28 | 27 | 66
29 | 28 | 67
30 | 29 | 68
31 | 30 | 69
32 | 31 | 70
33 | 32 | 71
34 | 33 | 72
35 | 34 | 73
36 | 35 | 74
37 | 36 | 75
38 | 37 | 76
39 | 38 | 77
40 | 39 | 78
41 | 40 | 0
42 | 41 | 1
43 | 42 | 2
44 | 43 | 3
45 | 44 | 4
46 | 45 | 5
47 | 46 | 6
48 | 47 | 7
49 | 48 | 8
50 | 49 | 9
51 | 50 | 10
52 | 51 | 11
53 | 52 | 12
54 | 53 | 13
55 | 54 | 14
56 | 55 | 15
57 | 56 | 16
58 | 57 | 17
59 | 58 | 18
60 | 59 | 19
61 | 60 | 20
62 | 61 | 21
63 | 62 | 22
64 | 63 | 23
65 | 64 | 24
66 | 65 | 25
67 | 66 | 26
68 | 67 | 27
69 | 68 | 28
70 | 69 | 29
71 | 70 | 30
72 | 71 | 31
73 | 72 | 32
74 | 73 | 33
75 | 74 | 34
76 | 75 | 35
77 | 76 | 36
78 | 77 | 37
79 | 78 | 38

To change the default value, select it and enter the value you want.

Click on one of the following items to get more details:

  • Add New Row

  • Delete Row

  • Reload Defaults

  • Save as Defaults

  • OK

  • Cancel

Add New Row

Use the Add New Row button to insert a new entry in the Channel Index/EUT TxChannel/EUT Rx Channel table

Delete Row

Use the Delete Row button to remove a level pairs entry from the database. To do this, place the cursor in any field within the level pair you want to remove then click the Delete Row button.

Reload Defaults

Use the Reload Defaults button to reload the default level pairs information from the test database.

Save as Defaults

Use the Save as Defaults button to save the change you do on the table to the test database. The changed values will be the default values when the user click the Reload Defaults button next time.

OK

Use the OK button to confirm the values set in the table and return to the main user interface.

Cancel

Use the Cancel button to give up the modification set in the table and return to the main user interface.

Data Range

Channel Index is limited to 1 ..500, but it must be unique.

The value for EUT Tx Channel you enter must be in the following range: 0 to 78

The value for EUT Rx Channel you enter must be in the following range: 0 to 78


Delta f1 Average

Description

The Delta f1 Average sets the pass/fail limits for the delta f1 average measurement using a 00001111 (BS0F) bit pattern payload.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of -140 kHz and +175 kHz, enter values accordingly.

Default Value

Lower Limit: 140 kHz

Upper Limit: 175 kHz


Delta f2 Average

Description

The Delta f2 Average sets the pass/fail limits for the delta f2 average measurement using a 00001111 (BS0F) bit pattern payload.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of -140 kHz and +175 kHz, enter values accordingly.

Default Value

Lower Limit: 140 kHz

Upper Limit: 175 kHz


Delta f2 Average/Delta f1 Average

Description

The Delta f2 Average/Delta f1 Average sets the pass/fail limits for the delta f2 average/delta f1 average measurement. Only the lower limit is required.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of 80%, enter the value accordingly.

Default Value

Lower Limit: 80%

Upper Limit: None


Delta f2 Maximum

Description

The Delta f2 Maximum limit sets the pass/fail values for the delta f2 maximum measurement using a 1010101010 (BS55) bit pattern payload. Only a lower limit is required.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of 115 kHz as the lower limit, enter the value accordingly.

Default Value

Lower Limit: 115 kHz

Upper Limit: None


Drift

Description

The Drift limit sets the pass/fail values for packet frequency drift.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of ±25kHz for single-slot packets and ±40kHz for multi-slot packets, enter values accordingly.

Default Values

S1: ±25 kHz

S3: ±40 kHz

S5: ±40 kHz


Drift Rate

Carr Freq Drift Rate

Description

The Drift Rate limit sets the pass/fail values for the maximum drift rate within a packet.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of ±20kHz per 50 ms, enter values accordingly.


DUT Timeout for Receive Command (Seconds)

Description

The DUT Timeout for Receive Command (Seconds) parameter specifies the amount of time to wait during a ‘Receive from DUT’ action for the information to be returned on the serial connection.

Accessing Parameter Name(s)

To access the Parameters for a test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 2

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.

Data Range

The value you enter must be in the following range: 0 to 60.


About Parameter Table

The parameter table is a list of entries which sets the parameters or specification limits.

  1. Type or select a new value from the drop-down list. The new value you specified takes effect immediately.

  2. To add a new row in the table, click the button Add New Row.

  3. To delete the row in the table, click the row you want to move and click the button Delete Row.

  4. To restore the original default value in the system after the modification, click the button Reload Defaults.

  5. To make the modification be the default value, click the button Save as Defaults. This action can only be done in the Administrator Mode.

  6. To make the modification effective, click the button OK, otherwise click the button Cancel to disable what you have done on the table.


Administrator mode UI

The following example of a typical Administrator user interface is taken from the E6560C cdma2000/IS-95/AMPS Wireless Test Manager.


Close/Open/Engage/Disengage

This set of tabs allow you to test the communication between the Wireless Test Manager, and your E8421A Wireless Test Fixture or N4049A Wireless Test Fixture (TC-5942B).

Each tab allows you to test a single fixture action; Close, Open, Engage or Disengage. To test a fixture action, select the tab you want and press the Test Fixture 1 or Test Fixture 2 button.

The Test Fixture 2 button is only displayed if the Multi-fixture testing check box is selected on the Change Configuration tab (Fixture Control group). This is used when you want to connect two fixtures to your system.


Close/Open/Status/Engage/Disengage

This set of tabs allow you to test the communication between the Wireless Test Manager and your RS-232 fixture.

Each tab allows you to test a single fixture command; Close, Open, Status, Engage or Disengage.

To test a fixture action

This procedure assumes that your RS-232 fixture is properly connected to an RS-232 port in your test system.

  1. Select the appropriate tab for the command you want to test. For example, if you want to test the Open command, click the Open tab.

  2. Ensure that the syntax is correctly specified for your fixture in the <command>syntax edit box. If not, edit the command text.

  3. Press the Test Fixture 1 or Test Fixture 2 button.

The Test Fixture 2 button is only displayed if the Multi-fixture testing check box is selected on the Change Configuration tab (Fixture Control group). This is used when you want to connect two fixtures to your system.


Developer mode UI

The following example of using the Developer user interface is taken from the E6560C cdma2000/IS-95/AMPS Wireless Test Manager.


Global Parameters graphic popup

Portions of the graphic are highlighted for this example only.


GPIB/Bar Code Reader/DUT Phone Control/Digital IO/Fixture 1/Fixture 2/WTM LAN Control

These tabs allow you to configure the IO ports for the various system hardware devices.

You must always correctly set port assignments on these tabs before you configure the remaining device settings.
For example, if you want to configure an Agilent N4049A Wireless Test Fixture, you should specify the correct COM port before changing the Fixture model setting from None to N4049A(TC-5942B) in the Fixture control group. Otherwise a COM port error message is displayed.

The Comtrol® multiport serial adapter does not support a Parity setting of Mark or Space.

Each tab allows you to configure the IO port assignments for a different hardware device.

Click on a tab name to get more details.

  • GPIB

  • Bar Code Reader

  • DUT Phone Control

  • Digital IO

  • Fixture 1

  • Fixture 2

  • WTM LAN Control

GPIB

Use the GPIB tab to correctly specify the GPIB port for each test system.

Use the Find GPIB Ports button to search for available GPIB ports.

Bar Code Reader

Use the Bar Code Reader tab to correctly specify the bar code reader port for each test system.

Use the Find Serial Ports button to search for available serial ports.

DUT Phone Control

Use the DUT Phone Control tab to correctly specify the device under test (DUT) control port for each test system.

Use the Find Serial Ports button to search for available serial ports.

Digital IO

Use the DigitalIO tab to correctly specify the Digital IO card port for each test system.

Fixture 1

Use the Fixture 1 tab to correctly specify the fixture 1 control port for each test system.

Use the Find Serial Ports button to search for available serial ports.

Fixture 2

Use the Fixture 2 tab to correctly specify the fixture 2 control port for each test system.

Use the Find Serial Ports button to search for available serial ports.

WTM LAN Control

The WTM LAN Control tab allows you to select the use of the LAN to control the test instrument. When selected, a globe will appear in the toolbar as an annunciator. If it is red, the targeted equipment has not been found. If it is green the LAN connection has been made.


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Information contained in this document is subject to change without notice.

All Rights Reserved. Reproduction, adaptation, or translation without prior written permission is prohibited, except as allowed under the copyright laws.

This material may be reproduced by or for the U.S. Government pursuant to the Copyright License under the clause at DFARS 52.227-7013 (APR 1988).

Agilent Technologies, Inc.
Learning Products Department
24001 E. Mission
Liberty Lake, WA 99019-9599
U.S.A.

© Agilent Technologies, Inc. 2006


Operator mode UI

The following example of a typical Operator user interface is taken from the E6560C cdma2000/IS-95/AMPS Wireless Test Manager.


Previous Test Results Dialog Box

The Previous Test Results dialog box presents comprehensive results for one of the last seven previously run test plans that you specified.

Click on an item to get more details:

  • Supporting Information Box

  • Test Results Table

  • Status Bar

  • Close

Supporting Information Box

The upper text box provides the following information about the environment at the time the test plan was run:

  • Current Date

  • Current Time

  • Path Loss

  • Path Loss path name

  • Database File (.mdb)

  • Database Name

  • Database Revision

  • Test Plan Name

  • TA Model

  • TA Revision

  • Demo Mode State

Test Results Table

This table provides the actual results for each part of the test plan. The following information is available:

  • Test Title

  • Measured Value

  • Lower Limit

  • Upper Limit

  • Passed/Failed

  • Elapsed Time (Seconds)

Status Bar

This displays the following information about the test plan:

  • Total Passed

  • Total Failed

  • Run Time

Close

Use the Close button to close this dialog box.


RS-232 Fixture syntax tips

Syntax for the RS-232 fixture can be of the form data1^data2^xxx to send two or more commands to the fixture to perform a single operation.

A delay can be included between commands by using the following syntax:

data1^{delay time in seconds}^data2...

For Example:

The syntax: INWARD^{3}^CLOSE sends the INWARD command, waits 3 seconds and sends the CLOSE command.


Test Plan Steps Graphic popup

Portions of the graphic are highlighted for this example only.


XML file format

The Extensible Markup Language (XML) is the universal format for structured documents and data on the Web.

The XML file format is useful if you want to load test results into a database.


EDR BER Floor Performance Limits

Description

The EDR BER Floor Performance limit sets the pass/fail value for the upper Bit Error Rate and the upper Packet Error Rate.

Default Values

EDR BER Floor Performance BER Upper: 0.07 %

EDR BER Floor Performance PER Upper: 100.0 %


EDR Differential Phase Encoding Limits

Description

The EDR Differential Phase Encoding limit sets the pass/fail value for the upper Packet Error Rate.

Results are also returned for Number or Errored Packets and Number of Missing Packets (no limits required)

EDR Differential Phase Encoding Upper: 1.0 %


EDR Frequency Stability and Modulation Accuracy Limits

Description

The EDR Frequency Stability and Modulation Accuracy limit sets the pass/fail values for upper and lower limits.

Default Values

Initial Frequency Error (ωi) Upper: +75kHz

Initial Frequency Error (ωi) Lower: -75kHz

Initial Frequency Error plus Block Frequency Error (ωi+ ω0) Upper: +75kHz

Initial Frequency Error plus Block Frequency Error (ωi+ ω0) Lower: -75kHz

Block Frequency Error (ω0) Upper: +10kHz

Block Frequency Error (ω0) Lower: -10kHz

RMS DEVM (for pi/4-DQPSK blocks) Upper: 0.20

RMS DEVM (for 8DPSK blocks) Upper: 0.13

Peak DEVM (for pi/4-DQPSK symbols) Upper: 0.35

Peak DEVM (for 8DPSK symbols) Upper: 0.25

Percentile DEVM (for pi/4-DQPSK) Upper: 30

Percentile DEVM (for 8DPSK) Upper: 20


EDR Guard Interval Limits

Description

The EDR Guard Interval limit sets the pass/fail value for the upper and lower guard time interval between the frequency modulated [GFSK] header and phase modulated [DPSK] payload portions of a packet.

Compliance with the Bluetooth Test Specification?

This Guard Interval test is not a requirement of the Bluetooth RF Test Specification.

Default Values

EDR Guard Interval Upper: 5.25 us

EDR Guard Interval Lower: 4.75 s


EDR Maximum Input Level Limits

Description

The EDR Maximum Input Level limit sets the pass/fail value for the upper Bit Error Rate and the upper Packet Error Rate.

Default Values

EDR Maximum Input Level BER Upper: 0.1%

EDR Maximum Input Level PER Upper: 100.0 %


EDR Relative Power Limits

Description

The EDR Relative Power limit sets the pass/fail values for upper and lower power levels.

Default Values

EDR Relative Power Upper: 4.0 dBm

EDR Relative Power Lower: -1.0 dBm


EDR Sensitivity Limits

Description

The EDR Sensitivity limit sets the pass/fail value for the upper Bit Error Rate and the upper Packet Error Rate.

Default Values

EDR Sensitivity BER Upper: 0.07 %

EDR Sensitivity PER Upper: 100.0 %


Generic Instrument Address

Description

The Generic Instrument Address parameter specifies the GPIB address of the target instrument. This is used only if the Instrument Type is set to "Generic Instrument."

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 5

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.

Data Range

The value you enter must be in the following range: 0 to 31.


GPIB Commands with Specs

Description

The GPIB Commands with Specs parameter is a table that contains both parameters and specifications. The first four columns are parameters, and the last two are specification limits. The following Parameters are included:

  • Test Step ID: This is used to identify each available GPIB command. When this test step is executed, the GPIB string will be sent to the target instrument. The Test Step ID parameter (not in the table) chooses which ones will be sent. If multiple rows have the same Test Step ID, all of the associated GPIB commands will be sent to the target instrument in top to bottom sequence.

  • SCPI: An ASCII string based on the Standard Commands for Programmable Instrumentation (SCPI) is entered here. This is the GPIB command to be sent to the target instrument.

  • Instrument Type: If "Current Test Set" is selected, that will be the target for the GPIB command. The Generic Instrument Address will be ignored. If "Generic Instrument" is selected, the GPIB address specified in the Generic Instrument Address parameter will be the target.

  • Test Title: Each command is referenced by a title; this title appears on the test summary.

  • Data Type: Either String or Numeric may be selected.

Accessing Parameter Name(s)

To access the Parameters or Specs for this test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab. Click on the >> button in the (Table) field to open the table. To edit the values, click on the appropriate cell to select it. Enter the value you want, or click on the drop-down arrow to select the value or OFF.

Default Value

The default values are listed below:

Test Step ID | SCPI | Test Title | Data Type | Lower Limit | Upper Limit
1 | *IDN? | Instrument IDN | String | Off | Off

Data Range

Allowable Ranges are shown below:

Test Step ID | SCPI | Test Title | Data Type
Any numeric value | Any String up to 50 characters long | Any String up to 50 characters long | String or Number

The Upper and Lower Limits may be any numeric value, or OFF.


High Channel

Description

The HighChannel parameter specifies the high frequency points to be used by the specified test, by Bluetooth channel number.

The HighChanState determines whether the high frequency point will be used in the specified test. (On Or Off)


Hopping

Description

The Hopping parameter sets Hopping on or off. You can also configure hopping to operate between the specified High, Medium, and Low channels.

  • OFF: the frequencies used for Test Set transmit, and receive and measure, are as specified by Low, Medium and High channels.

  • ON: the full hopping pattern is used for transmit and receive. For transmitter tests the frequencies available for test are low, medium or high frequency channels. The frequency channels are not applicable for receiver tests.


ICFT

Description

The ICFT limit sets the pass/fail values for the EUT transmitter frequency accuracy (Initial Carrier Frequency Tolerance).

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of ±75kHz, enter values accordingly.

Default Value

Lower Limit: -75

Upper Limit: +75


IF Bandwidth

Description

The IF Bandwidth parameter specifies the Test Set receiver IF bandwidth to be used for the test.

Compliance with the Bluetooth Test Specification?

The default setting of the IF Bandwidth filter is recommended by the Bluetooth RF Test Specification and should be used for manufacturing test. The default setting is shown in the table below.

When the wider IF filter settings are used the test results include the effects of spurious out-of-channel or inter-modulation products. This can be useful when evaluating the performance of devices during the development phase or test system development.

Default Setting

The table below shows the test and the default IF bandwidth. Certain tests allow the selection of the bandwidth, the choices are 1.3 MHz, 3 MHz, and 5 MHz.

Test | SCPI | IF Bandwidth | Selection
Carrier Frequency Drift | CFDR | 1.3 MHz | Yes
Initial Carrier Frequency Tolerance | ICFT | 1.3 MHz | Yes
Modulation Characteristics | MCH | 1.3 MHz | Yes
Maximum Input Level | MIL | 3 MHz | Fixed
Multi-slot Sensitivity | MSEN | 3 MHz | Fixed
Output Power | OPOW | 3 MHz | Yes
Power Control | PCON | 3 MHz | Yes
Single-slot Sensitivity | SSEN | 3 MHz | Fixed
EDR BER Floor Performance | BFP | 3 MHz | Fixed
EDR Differential Phase Encoding | DPEN | 3 MHz | Fixed
EDR Maximum Input Level | EMl | 3 MHz | Fixed
EDR Sensitivity | ESEN | 3 MHz | Fixed
EDR Frequency Stability and Modulation Accuracy | FSM | 3 MHz | Fixed
EDR Guard Time | GTIM | 3 MHz | Fixed
EDR Relative Transmit Power | RPOW | 3 MHz | Fixed


Impairments

Description

The Impairments parameter specifies the required dirty transmitter impairment values.

BT1.x Impairments

The BT1.x impairments can be applied as a table containing 10 groups of frequency offset, modulation index, and symbol timing values or as one of three sinusoidal impairments.

The default values are as follows:

Set of Parameters | Carrier Frequency Offset | Modulation Index | Symbol Timing Error
1 | 75kHz | 0.28 | -20 ppm
2 | 14kHz | 0.30 | -20 ppm
3 | -2kHz | 0.29 | +20 ppm
4 | 1kHz | 0.32 | +20 ppm
5 | 39kHz | 0.33 | +20 ppm
6 | 0kHz | 0.34 | -20 ppm
7 | -42kHz | 0.29 | -20 ppm
8 | 74kHz | 0.31 | -20 ppm
9 | -19kHz | 0.28 | -20 ppm
10 | -75kHz | 0.35 | +20 ppm

The 2 types of impairments can be applied individually or together.

The BT 1.x impairments are defined by the Global parameters BT Impairments Mode, BT Impairments Mod Freq, BT Impairments Max Deviation and BT Impairments Table. These parameter values will be used by all test steps in the test plan.

BT2.0 (EDR) Impairments

The BT2.0 impairments can be applied as a table containing 3 groups of frequency offset and symbol timing values or as one of three sinusoidal impairments.

The default values are as follows:

Set of Parameters | Carrier Offset Frequency | Symbol Timing Error
1 | 0 kHz | 0 ppm
2 | +65 kHz | +20 ppm
3 | -65 kHz | -20 ppm

The BT 1.x impairments are defined by the Global parameters BT Impairments EDR Mode, BT Impairments EDR Mod Freq, BT Impairments EDR Max Deviation and BT EDR Impairments Table. These parameter values will be used by all test steps in the test plan.

The BT 2.0 impairments function does not allow Modulation Index to be set. However, the table displays Mod Index, this value is ignored by the N4010.

Compliance with the Bluetooth Test Specification?

Refer to the specific test for compliance information.


Impairments Mode

Use this command to specify what type of impairment is applied when impairments are On.

Range

Table, Sine Or Both

Default

Both


Impairments Modulation Frequency

Impairments Sine Wave Modulation Frequency

Use this parameter to define the modulation frequency of the sine wave impairment.

Range

300Hz to 10kHz

Default

1.5kHz


Impaiments Sine Wave Max Deviation

Impairments Sine Wave Max Deviation

Description

This parameter defines the maximum deviation of the sine wave impairment.

Range

0 to 40 kHz


Instrument Type

Description

The Instrument Type parameter specifies whether the GPIB I/O is targeted at the Test Set or at a different instrument. If the Current Test Set is selected, the Generic Instrument Address parameter will be ignored.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

The following values are available from the drop-down list in the Value column in the Parameters for test plan step group box:

  • Current Test Set

  • Generic Instrument

Default Value

The default value for this parameter is: Current Test Set

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.


ISM popup

ISM - Industrial Scientific and Medical - the radio band at 2.4 GHz in which Bluetooth devices operate.


Low Channel

Description

The LowChannel parameter specifies the low frequency points to be used by the specified test, by Bluetooth channel number.

The LowChanState determines whether the low frequency point will be used in the specified test. (On Or Off)


Maximum Time for Connect (Sec)

Description

The Maximum Time for Connect (Sec) parameter specifies the maximum time the test set will wait for the Connected/Transferring state to occur. The setting units are seconds.

A timeout timer is started whenever the call-state-change-detector becomes armed or gets rearmed when already armed. The duration of this timeout is a set using this parameter and should be greater than the maximum amount of time the control program needs/wants to wait between arming the call-state-change detector and the connect/disconnect operation starting. Once the process starts and the call state has moved into one of the transitory states the GSM defined protocol timers take over and prevent the call state from staying in a transitory state forever.

Accessing Parameter Name (s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 120

To change the default value, select it and enter the value you want.

Data Range

The value you enter must be in the following range: 5 to 360


Maximum Time for Detach (Sec)

Description

The Maximum Time for Detach (Sec) parameter specifies the maximum time (in seconds) that Wireless Test Manager waits for a detach to be confirmed.

Accessing Parameter Name (s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 10

To change the default value, click on it and enter the value you want.

Data Range

The value you enter must be in the following range: 1 to 360


Medium Channel

Description

The MedChannel parameter specifies the mid frequency points to be used by the specified test, by Bluetooth channel number.

The MedChanState determines whether the mid frequency point will be used in the specified test. (On Or Off)


Minimum Step Average Power

Description

The Minimum Step Average Power limit sets the pass/fail values for the average transmit power of the EUT at the minimum step setting.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of Average Power <4 dBm at the minimum power step enter the value accordingly.

Default Values

Average Power at minimum power step for Class 1 EUT: 4 dBm


N4019C Wireless Test Manager Reference

The N4019C Reference provides information about test plan steps, test parameters, test limits (specifications), and utility functions created by Agilent Technologies. This collection of tools are provided and used with Wireless Test Manager (WTM) to perform testing of Bluetooth and Wireless LAN wireless devices.

  • Test Plan Steps provides information about Bluetooth and Wireless LAN test plan steps.

  • Alphabetical Listing of Global and Test Parameters lists all parameters in alphabetical order.

  • Alphabetical Listing of Specifications lists all specifications in alphabetical order.

  • Global Parameters describes the Global Parameters in this WTM.

  • GSM/GPRS/EGPRS Troubleshooting provides troubleshooting information relating to GSM, GPRS and EGPRS measurements. Additional information is available for the Agilent 8960 Series 10 Wireless Communications Test Set.


Number of Packets

Description

The Number of Packets parameter specifies the number of packets to be used in the test. Increasing the quantity of packets tested can significantly increase the test time depending on the packet types and the number of channels tested.

Range

0 to 50000

Default

10


Number of Payload Bits

Description

The Num Bits parameter specifies the total number of bits to be used in a Bit Error Rate (BER) measurement.

Range

1 to 10,000,000


openingbluetoothtransport

Opening the Transport to the Device

H4 Protocol

If the device is connected using H4, select “UART” for parameter BT DUT Transport, and “H4” for BT DUT protocol. BT Device Name and Speed should be as expected for the DUT, e.g. "COM1", 115200.

BCSP Protocol

BCSP is used on CSR BlueCore™ based devices. Select “UART” for parameter BT DUT Transport, then “BCSP” protocol

USB

If you have BlueSuite installed and a device with the CSR USB driver, you can select “USB” as BT DUT Transport and “CSR” as BT DUT Protocol to use this transport. BT Device Name has to be exactly as the DUT Driver would expect, e.g "\\.\csr0"

© Agilent Technologies 2006


Operator Interaction Required

Description

The Operator Interaction Required parameter specifies whether or not operator interaction is required when WTM requires an action from the DUT. When this parameter is set to Yes, a message is displayed to the user to perform the desired action. When set to No, the Data Connection DUT Commands with Specs table is used to define the serial commands to send to the DUT for the desired action.

Accessing Parameter Name(s)

To access the Parameters for a test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

The following values are available from the drop-down list in the Value column in the Parameters for test plan group box:

  • No

  • Yes

Default Value

The default value for this parameter is: Yes

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.


Packet Error Rate

Packet Error Rate (PER)

Description

The PER limit sets the pass/fail values for a packet error rate measurement.

Default Value

100 %


Packet Type

Description

The Packet Type parameter specifies the packet types to be tested. The valid options depend on the selected link type and subject to the supported features of the EUT.

Range

Bluetooth 1.x

  • HV3, DH1, DH3, DH5, DH135

DH135 is only available for the Carrier Frequency Drift Test.

Bluetooth EDR

  • EDR_2DH1, EDR_2DH3, EDR_2DH5, EDR_3DH1, EDR_3DH3, EDR_3DH5


Payload length

Packet length

Description

The Packet Length parameter specifies the length of the data payload. The number of bytes in the payload depends on the type of packet selected.

  • DH1: range 1 - 27 bytes.

  • DH3: range 1 - 183 bytes.

  • DH5: range 1 - 339 bytes.

  • DH135: range 1 - 27 bytes.

  • HV3: 30 bytes only.

  • EDR_2DH1: range 1 - 54 bytes.

  • EDR_2DH3: range 1 - 367 bytes.

  • EDR_2DH5: range 1 - 679 bytes.

  • EDR_3DH1: range 1 - 83 bytes.

  • EDR_3DH3: range 1 - 552 bytes.

  • EDR_3DH5: range 1 - 1021 bytes.

Setting Packet Length to AUTO automatically selects the maximum packet length allowed.

Default

AUTO


Payload Pattern

Description

The Payload parameter specifies the contents of a packet.

Defined payload patterns:

  • BSFF - the data payload contains 11111111.....

  • BS00 - the data payload contains 00000000.....

  • BS0F - the data payload contains a repeating pattern of 00001111.......

  • BS55 - the data payload contains a repeating pattern of 01010101.....

  • BS0F55 - uses BS0F payload packets followed by a number of BS55 payload packets. This is only available for Modulation Characteristic tests.

  • PRBS9 - the data payload contains pseudo random binary sequence 9

Default

PRBS9


Peak Power

Description

The Peak Power limit sets the pass/fail values for the peak transmit power of the EUT.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of Peak Power <23 dBm (200 mW) for the peak power output for all power classes, enter values accordingly.

Default Values

Upper Limit: 23 dBm (200 mW).


Poll Interval

Description

The Poll Interval parameter specifies the time interval between test packets sent from the Test Set to the EUT. When set to AUTO the Test Set calculates the minimum value. Alternatively, you can specify the value.

The following list shows the minimum poll intervals that can be selected for each packet type.

  • 1 slot: 1.25ms

  • 3 slot: 3.75ms

  • 5 slot: 6.25ms

The poll interval is in units of 1.25ms.

Default

AUTO


Power Step Size

Description

The Power Step Size limit sets the pass/fail values for the transmitter power step size of the EUT.

Compliance with the Bluetooth Test Specification?

To comply with the Bluetooth RF Test Specification of 2dB £ step size £ 0.8dB and average power at minimum step size of <4 dBm enter values accordingly.

Default Values

Step Size Lower Limit: 0.8 dB

Step Size Upper Limit: 2 dB


Rx Power

Rx Power Level

Use this parameter to define the expected input power level, or the EUT transmit power.

Range

-70 to 25dBm

Default

25dBm


Send Receive DUT Command

Description

The Send Receive DUT Command test plan step allows direct reading and writing with a device under test (DUT) . All command strings you want to include are built into the table, each with its own Test Step ID in the table. When this test plan step is executed, a command or series of commands from the table is executed, the one with the Test Step ID that matches the Test Step ID parameter.

Specifications

Upper and lower specification limits are included in the Table, Send Receive DUT Commands with Specs.

Parameters

  • DUT Timeout for Receive Command (Seconds)

  • Send Receive DUT Commands with Specs

  • Test Step ID


Send Receive DUT Commands with Specs

Description

The Send Receive DUT Commands with Specs parameter is a table that contains both parameters and specifications. The first five columns are parameters, and the last one is a specification limit. The following Parameters are included:

  • Test Step ID: This parameter is used to identify each available DUT command. When this test step is executed, the Command or Information string will be sent to the DUT or test set. The Test Step ID parameter (not the column in the table) allows you to select which of the available commands are sent during execution of this step. If multiple rows have the same Test Step ID, all of the associated GPIB commands will be sent to the target device in top to bottom sequence.

  • Action: If “Send to DUT” is selected, the Command or Information string is sent to the DUT. The contents of the Receive Data Action and Compare Data fields are ignored. If “Receive from DUT” is selected, the Command or Information string should contain the exact expected return. If “Wait mSec” is selected, the Command or Information string should contain the amount of time, in milliseconds, to wait. If “Send GPIB to Test Set” is selected, the Command string is sent to the current test set in use.

  • Test Title: Each command is referenced by a title; this title appears on the test summary.

  • Command or Information: This field is used to identify the information to be used with the Action selected. For the “Send to DUT” and “Send GPIB to Test Set” actions, this field contains the command to send to the selected device. For the “Receive from DUT” action, this field should contain the expected data to be returned from the DUT. For the “Wait mSec” action, this field should contain a number identifying the amount of time to pause the program. If characters are needing to be sent or are contained in the expected data, they must be in the following format: ~(2,10,13). The numbers are parsed and added to the Command or Information string as characters.

  • Data Action: This field is only used if the Action field is set to “Receive from DUT” or “Send GPIB to Test Set”, and if the GPIB command is a query. If “None” is selected, no information is compared or displayed. If “Display” is selected, the data received from the DUT or Test Set will appear on the test summary. If “Display and Compare” is selected, the compare data field is used to obtain the specifications and the results will appear on the test summary.

  • Compare Data: This field contains the specifications to compare against if the Data Action field is set to “Display and Compare”. The format of this field for numeric data is LL, UL [, Location] where LL is the lower limit, UL is the upper limit, and the optional Location identifies the data location when multiple items are returned from the DUT or Test Set. That is, 0, 10 , 2 would result in a lower limit of 0 and an upper limit of 10 with a data location of 2. So if the returned data was “+1,8.345” then the value of 8.345 would be compared to the 0, 10 limits.

Accessing Parameter Name(s)

To access the Parameters or Specs for this test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab. Click on the >> button in the (Table) field to open the table. To edit the values, click on the appropriate cell to select it. Enter the value you want, or click on the drop-down arrow to select the value or OFF.

Default Value

The default values are listed below:

Test Step ID | Action | Test Title | Command or Information | Data Action | Compare Data
1 | Send to DUT | Send Command | Add command or information here | Display | LL, UL [, Location]

Data Range

Allowable Ranges are shown below:

Test Step ID | Action | Test Title | Command or Information | Data Action | Compare Data
Any numeric value | Send to DUT Receive from DUT Wait mSec Send GPIB to Test Set | Any String up to 50 characters long | Any String up to 50 characters long | None Display Display and Compare | Any String up to 50 characters long

The Upper and Lower Limits may be any numeric value, or OFF.


Send Receive GPIB

Description

The Send Receive GPIB test plan step allows direct reading and writing to any instrument on the GPIB. All desired command strings are built in the table, each with its own Test Step ID in the table. When this test plan step is executed, a command or series of commands from the table is executed, the one with the Test Step ID that matches the Test Step ID parameter.

Specifications

Upper and lower specification limits are included in the Table, GPIB Commands with Specs.

Parameters

  • Generic Instrument Address

  • GPIB Commands with Specs

  • Instrument Type

  • Test Step ID

  • Timeout (Seconds)


Setting Loss Compensation

Bluetooth Loss Compensation

Overview

The Test Set allows you to set a fixed loss.

The loss values are applied when displaying the power of received signals and to the transmitted signal level. For example, if the loss is set to 1.3 dB, and the transmit level is set to –30 dB, then the actual transmitted power level is –28.7dB. An error is produced if the applied loss value would cause the test limit to be exceeded.

Limits

-50 dB .. 40db

Default Value

0db


Setting Specifications Table

This table offers the six button for operation.

To set specifications for a step

  1. Type or select a new value for the specification from the drop-down list.
    The new value you specified takes effect immediately.

  2. To add a new row in the table, click the button Add New Row.

  3. To delete the row in the table, click the row you want to move and click the button Delete Row.

  4. To restore the original default value in the system after the modification,, click the button Reload Defaults.

  5. To make the modification be the default value, click the button Save as Defaults.

  6. To make the modification effective, click the button OK, otherwise click the button Cancel to disable what you have done on the table.


Technology Troubleshooting

N4018C/N4019C Troubleshooting

The Following Troubleshooting information is available:

  • Error Messages

  • Contact Information


Test plan start end control

Use this check box to specify whether or not the test plan starts automatically as soon as the bar code number has been received from the bar code reader.

Use this check box to specify whether or not you start the test plan by pressing a key on the front panel of the 8960 test set. If selected, the graphic on the Run Test Plan button changes to indicate that this selection has been made.

Use this check box to specify whether or not the test plan starts automatically as soon as the fixture holding the device under test is closed.

If this box is selected, Open fixture at end of test plan must also be checked to avoid an infinite looping condition.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model: box, within the Fixture control group on the Change Configuration tab.

Use this check box to specify whether or not the results remain displayed after the test plan has finished.

Selecting this check box closes the results display grid after the test plan has finished.

Clearing this check box ensures that the results remain displayed after the test plan has finished.

Use this check box to specify whether or not the fixture opens automatically after the test plan is complete.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Use this check box to specify whether or not the device under test is disengaged automatically after the test plan is complete.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Use this check box to specify whether or not the fixture opens automatically if the test plan aborts.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Use this check box to specify whether or not the device under test is disengaged automatically if the test plan aborts.

This check box is only available if you have selected either N4049A(TC-5942B) or RS-232 in the Fixture Model box, within the Fixture control group on the Change Configuration tab.

Test Plan Start and End Control (Change Configuration Tab)

The items in this group allow you to configure the events that occur either before a test plan starts or after it has finished. Click on an item to get more details:

Start test plan when bar code information received

Start test plan from 8960 front panel

Start test plan when fixture is closed

Return to view test conditions at end of test plan

Open fixture at end of test plan

Disengage DUT at end of test plan

Open fixture if test plan aborts

Disengage DUT if test plan aborts


Test Set Activation Error

This Test Set Activation Error message window is displayed for the following scenarios:

  • The 8960 test set is configured in the Change Configuration/Instrument Control with an address other that None, demo mode is turned off, and:

  • The 8960 test set is not connected through GPIB.

  • The 8960 test set is not turned on.

  • The VISA drivers are not installed.

To avoid this error, turn demo mode on or set the 8960 Test Set address to None.

Click the OK button to close the message window.


Test Set Transmit Power

Test Set Transmit Power (Tx Power Level)

Description

The Test Set Transmit Power parameter specifies the Test Set RF transmitter level to be used for this test.

Range

0 to -90dBm

Default

-40dBm


Test Step ID

Description

The Test Step ID parameter specifies which of the available commands in the GPIB Commands with Specs or Send Receive DUT Commands with Specs table are sent during execution of this step.

All the commands are built in the table, and each copy of the test plan step will send all the commands with Test Step ID field that match this parameter.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 1

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.


Timeout (Seconds)

Description

The Timeout (Seconds) parameter specifies a time limit in seconds for the completion of the GPIB command.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

Default Value

The default value for this parameter is: 2

To change the default value, click on the value and a drop-down arrow appears. Select the value you want from the list.

Data Range

The value you enter must be in the following range: 0 to 60.


Whitening

Description

The Whitening parameter sets data whitening on or off. Data whitening is a scrambling process applied to both the header and data. It is applied to minimize any DC bias in the packet.

Whitening is only applicable with a loopback testmode connection to the EUT and the PRBS9 payload pattern selected.

Range

On Or Off

Default

Off


WLAN AutoRange Trigger Level

AutoRange Trigger Level

Description

This figure represents an appropriate Trigger Level for the input signal, calculated using the AutoRange function on a transmitted signal.

Default Values

Upper Limit: 3.0V

Lower Limit: 1e-5V


WLAN AutoRange Power Range

AutoRange Power Range

Description

This figure represents the lowest Power Range that can be set without causing overloading in the input signal. This will yield the most accurate measurement results.

Default Values

Upper Limit: 25dBm

Lower Limit: -60dBm


WLan DUT Data Rate Loop

WLAN DUT Data Rate

Description

The WLAN DUT Data Rate parameter is used to specify the WLAN DUT Data Rate to be used as looping parameter in the test step.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

A table is available from the drop-down list in the Value column in the Parameter Table for: WLAN DUT Data Rate group box:, click the [image] after [Table] to get it

Default Value

The default value for this parameter table as follows:

Index | DUT Data Rate (Mbps)
1 | 11

But a populated table when used for looping may look like this:

Index | DUT Data Rate (Mbps)
1 | 6
2 | 9
3 | 12
4 | 18
5 | 24
6 | 36
7 | 48
8 | 54

To change the default value, select it and enter the value you want.

Click on one of the following items to get more details:

  • Add New Row

  • Delete Row

  • Reload Defaults

  • Save as Defaults

  • OK

  • Cancel

Add New Row

Use the Add New Row button to insert a new entry in the Index/Dut Data Rate table

Delete Row

Use the Delete Row button to remove a level pairs entry from the database. To do this, place the cursor in any field within the level pair you want to remove then click the Delete Row button.

Reload Defaults

Use the Reload Defaults button to reload the default level pairs information from the test database.

Save as Defaults

Use the Save as Defaults button to save the change you do on the table to the test database. The changed values will be the default values when the user click the Reload Defaults button next time.

OK

Use the OK button to confirm the values set in the table and return to the main user interface.

Cancel

Use the Cancel button to give up the modification set in the table and return to the main user interface.

Data Range

Index is limited to 1 ..100, but it must be unique.

The value for DUT Data Rate you enter must be in the following range: 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, 54


WLan Freq Band Pair

WLAN Frequency / Band

Description

The WLAN Freq Band parameter is used to specify the WLAN Band and Frequency to be used as looping parameter in the test step.

Accessing Parameter Name(s)

To access the Parameters for test plan step in the Wireless Test Manager, click on the Set Specs/Parameters tab.

A table is available from the drop-down list in the Value column in the Parameter Table for: WLAN Freq Band group box:, click the [image] after [Table] to get it

Default Value

The default value for this parameter table as follows:

Index | WLAN Band | WLAN Frequency(MHz)
1 | B | 2412

But a populated table when used for looping may look like this:

Index | WLAN Band | WLAN Frequency(MHz)
1 | B | 2412
2 | B | 2417
3 | B | 2422
4 | B | 2427
5 | B | 2432
6 | B | 2437
7 | B | 2442
8 | B | 2447
9 | B | 2452
10 | B | 2457
11 | B | 2462
12 | B | 2467
13 | B | 2472
14 | B | 2477
15 | B | 2484
16 | G | 2412
17 | G | 2417
18 | G | 2422
19 | G | 2427
20 | G | 2432
21 | G | 2437
22 | G | 2442
23 | G | 2447
24 | G | 2452
25 | G | 2457
26 | G | 2462
27 | G | 2467
28 | G | 2472
29 | G | 2477
30 | G | 2484

To change the default value, select it and enter the value you want.

Click on one of the following items to get more details:

  • Add New Row

  • Delete Row

  • Reload Defaults

  • Save as Defaults

  • OK

  • Cancel

Add New Row

Use the Add New Row button to insert a new entry in the Index/WLAN Band/WLAN Freq table

Delete Row

Use the Delete Row button to remove a level pairs entry from the database. To do this, place the cursor in any field within the level pair you want to remove then click the Delete Row button.

Reload Defaults

Use the Reload Defaults button to reload the default level pairs information from the test database.

Save as Defaults

Use the Save as Defaults button to save the change you do on the table to the test database. The changed values will be the default values when the user click the Reload Defaults button next time.

OK

Use the OK button to confirm the values set in the table and return to the main user interface.

Cancel

Use the Cancel button to give up the modification set in the table and return to the main user interface.

Data Range

Index is limited to 1 ..1000, but it must be unique.

The value for WLAN Band you enter must be in the following range: A, B or G

The value for WLAN Freq you enter must be in the following range: 2412 to 2484 in steps of 5 & 5000 to , ensuring that the frequency selected is valid for the WLAN Band Selected.


WLAN Transmitter Average Power

Transmitter Average Power Test (DSSS/OFDM)

Description

The transmitter average power test is a time-gated, frequency bandwidth-limited power measurement, which runs regardless of modulation format.

    • IEEE Std 802.11b-1999 16 September 1999 Paragraph 18.4.7.1 Transmit power levels

    • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.9.1 Transmit power levels

In the IEEE 802.11 specification, as listed above, the transmit power test is based on the maximum allowable output power in accordance with practices specified by the appropriate regulatory bodies.

Limits

-100 to 20 dBm


Transmitter Carrier Suppression Test (DSSS)

Introduction

When the information signal in the up conversion stage of a transmitter modulates a radio-frequency (RF) carrier, some of the RF carrier signal leaks through the mixer and appears at the transmitter output. RF carrier suppression is the measure of the RF carrier leakage relative to the modulated output signal.

  • IEEE Std 802.11b-1999 16 September 1999 Paragraph 18.4.7.7 RF Carrier Suppression

Limits

> 15 dB


WLAN Transmitter Center Frequency Leakage Test (OFDM)

Transmitter Center Frequency Leakage Test (OFDM)

Introduction

Center Frequency Leakage is the portion of the transmitter energy that leaks through the transmitter components. This unwanted energy appears in the modulated signal at the signal center frequency. This test specifies center frequency leakage relative to total transmitted power. Energy at the centre frequency of the carrier can cause problems with receiver structures that use zero frequency intermediate signals. 802.11a specifically avoids using the centre carrier for transmission.

  • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.6.1 Transmitter Center Frequency Leakage

Limits

< -15dB


WLAN Transmitter Center Frequency Tolerance Test (DSSS/OFDM)

Transmitter Center Frequency Tolerance Test (DSSS/OFDM)

Introduction

The Transmit Center Frequency Tolerance (Frequency Error) is a measurement of the center frequency offset from the desired carrier frequency in units of parts per million (ppm).

  • IEEE Std. 802.11a-1999 16 September 1999 Paragraph 17.3.9.4

  • IEEE Std. 802.11b-1999 16 September 1999 Paragraph 18.4.7.4

Limits

-25 to 25 ppm


Transmitter Chip Clock Frequency Tolerance Test (DSSS)

Introduction

Chip clock frequency tolerance is a measure of how much the chip clock frequency is offset from the desired chip clock frequency.

  • IEEE Std. 802.11b-1999 16 September 1999 Paragraph 18.4.7.5

Circuit transients can produce time-varying frequency changes in the local oscillator. The performance of the equalizer in the receiver depends on the preamble sequence used for training. This can be adversely affected by the transient frequency instabilities in the transmitter.

Limits

-25 to 25 ppm

//


WLAN Transmitter Modulation Accuracy - EVM Test (DSSS/OFDM)

Transmitter Modulation Accuracy - EVM Test (DSSS/OFDM)

Introduction

Error Vector Magnitude (EVM), the transmitter modulation accuracy test, is calculated by comparing the actual measured signal with an ideal reference signal to determine the error vector. The EVM value is the root mean square (RMS) value of the error vector over time at the instants of the symbol (or chip) clock transitions. Every chip has its own error vector; EVM is the RMS average of all errors in a packet of 1000 chips.

  • IEEE Std 802.11b-1999 16 September 1999 Paragraph 18.4.7.8 Transmit modulation accuracy

  • IEEE Std 802.11a-1999 16 September 1999 Paragraph 17.3.9.7 Transmit modulation accuracy test

Limits

Defaults

0 to 35 Percent (Peak)

0 to 16 Percent (RMS)

If WLAN EVM Use Standard Specs parameter is set to true, RMS limits are data rate dependent:

Band A/G Results are in dBm, Band B in %

Data Rate (Mbps) | Upper Limit
1 | 35%
2 | 35%
5.5 | 35%
11 | 35%
6 | -5.0dBm
9 | -8.0dBm
12 | -10.0dBm
18 | -13.0dBm
24 | -16.0dBm
36 | -19.0dBm
48 | -22.0dBm
54 | -25.0 dBm


WLAN Transmitter Symbol Clock Frequency Tolerance Test (OFDM)

Transmitter Symbol Clock Frequency Tolerance Test (OFDM)

Introduction

Symbol clock frequency tolerance measures the symbol clock frequency offset from the desired symbol clock frequency.

  • IEEE Std. 802.11a-1999 16 September 1999 Paragraph 17.3.9.5

The symbol clock frequency tolerance is important because circuit transients can produce time-varying frequency changes in the local oscillator. The performance of the equalizer in the receiver depends on the preamble sequence used for training, which can be adversely affected by transient frequency instabilities in the transmitter.

Limits

-25 to 25 ppm

L